BMW X3 Forum
BMW X3 Forum
Welcome to the ultimate BMW X3 community.
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
Post Reply
 
Thread Tools Search this Thread
      01-19-2023, 05:03 PM   #1
Mark0405
New Member
0
Rep
5
Posts

Drives: BMW X3
Join Date: Jan 2023
Location: Ohio

iTrader: (0)

Driving Assistant Plus stopped working

Hi!

New to the forum and joined to ask this question and hopefully lean more about BMW tech.

I have a 2018 X3 with driving assistant plus and honesty it has been my favorite feature of the car. Worked great all the time. Around November of 2022, whenever I try to use dap, itís incredibly jerky and after a few bounces it shuts itself off. Under 40, it is no longer tracking the car in front (only green steering wheel icon) at all. It used to do this perfectly.

I have no warnings, no messages at all. I am wondering if perhaps there is a way to turn this off and I did that accidentally? Iíve found press and holds for some buttons but that doesnít seem to be doing anything.

I called and they told me that somehow my software reset to factory, and we performed an upgrade. No change. Also, from what I can tell windshield is clear and no obstructions to cameras.

Any ideas?
Appreciate 0
      01-20-2023, 02:22 AM   #2
freshxdough
BMW Master Technician - HV Gen 5 and HV Specialist
freshxdough's Avatar
3152
Rep
3,980
Posts

Drives: 2020 X3 M40i
Join Date: Mar 2017
Location: Orange County

iTrader: (0)

Post a photo of the icons you see when traveling behind someone so we can see what youíre seeing.
Appreciate 0
      01-24-2023, 12:19 PM   #3
Mark0405
New Member
0
Rep
5
Posts

Drives: BMW X3
Join Date: Jan 2023
Location: Ohio

iTrader: (0)

Picture

Attached some pics and will get a few better ones. Even with clear lines on freeway, it barely activates (turns green). But the bigger concern is that it will no longer just follow (green wheel only)
Attached Images
  

Last edited by Mark0405; 01-24-2023 at 06:52 PM..
Appreciate 0
      01-24-2023, 03:17 PM   #4
Tokke
Private First Class
44
Rep
121
Posts

Drives: BMW X3 20d Msport
Join Date: Jan 2019
Location: Belgium

iTrader: (0)

My lane keep assistant is having the exact same problem, i think it started around september 2022. When i release the steering wheel on the highway the car starts pulling left and right and then the system disables. When im holding the wheel, i can feel the wheel pulling in my hands and the green wheel in the dash goes on and off.

My car was in to the dealer and they say the coil spring cartridge needs to be replaced. (part nr 61315A66155). Total cost of replacing is around 300 EUR.
I have an appointment at 15 february to bring in the car, i hope it fixes the problem.
Appreciate 0
      01-24-2023, 07:05 PM   #5
Mark0405
New Member
0
Rep
5
Posts

Drives: BMW X3
Join Date: Jan 2023
Location: Ohio

iTrader: (0)

Thank you! Will look into that. Hopefully that is an easy fix. I did realize over the past few days that it seems to be getting better or “learning”. Not sure if that’s possible. I was in traffic yesterday (very slow) and it followed almost like normal (steering and start/stop) but… it was able to see the lines. Still has yet to “follow” even at slow speeds.
Appreciate 0
      01-26-2023, 05:02 PM   #6
Mark0405
New Member
0
Rep
5
Posts

Drives: BMW X3
Join Date: Jan 2023
Location: Ohio

iTrader: (0)

Just had windshield replaced and cameras recalibrated. No change. Still will not ďfollowĒ car in front at low speeds. Anyone have any insight into conditions used for this? It worked all the time (below 43mph) without having lines visible.
Appreciate 0
      02-03-2023, 09:52 AM   #7
Mark0405
New Member
0
Rep
5
Posts

Drives: BMW X3
Join Date: Jan 2023
Location: Ohio

iTrader: (0)

After disconnecting battery and reconnecting, happy to say itís back to normal!
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 10:31 AM.




xbimmers
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2023, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST