BMW X3 Forum
BMW X3 Forum
Welcome to the ultimate BMW X3 community.
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
XBimmers | BMW X3 Forum BMW X3 and X4 Forums | F25 (2011 - 2017) | F26 (2014 - Current) Second Generation BMW X3 (F25) General Forum Sat Nav stuck in “starting” screen

Post Reply
 
Thread Tools Search this Thread
      08-08-2018, 11:38 AM   #1
AlphaMendoza
Admiral
United Kingdom
2
Rep
48
Posts

Drives: X3 F25 LCI 20D
Join Date: Apr 2014
Location: North West, UK

iTrader: (0)

Sat Nav stuck in “starting” screen

Just updated my maps to Europe route 2018-1 which seemed to work ok.
Now getting the Sat Nav stuck on the “Navigation Starting” screen.
Does not happen all the time, but when it does it lasts the whole journey.
Leaving everything switched off over night then Sat Nav comes on ok next morning. Switching off for just an hour did not fix it.

This MAY be something to do with a very short session where I needed to re-park the car, and maybe I switched off before the Sat Nav had started up ?

I will do some more tests, but has anyone seen this, and got any fixes or resets?

Car is 2014 with Business Nav (entry level)

Cheers
Appreciate 0
Post Reply

Bookmarks

Tags
navigation problem

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 12:13 AM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST