BMW X3 Forum
BMW X3 Forum
Welcome to the ultimate BMW X3 community.
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
XBimmers | BMW X3 Forum BMW X3 Forums | E83 (2003-2010) First Generation BMW X3 General Forum 2007 X3 - hazards come on with wipers

Post Reply
 
Thread Tools Search this Thread
      11-18-2019, 04:50 PM   #1
powderhoundin
Registered
0
Rep
1
Posts

Drives: 2007 BMW X3 3.0si MSport 6spd
Join Date: Nov 2019
Location: Calgary, AB

iTrader: (0)

2007 X3 - hazards come on with wipers

Recently picked up a 2007 X3 3.0si and it has a very weird electrical gremlin. After starting the car, the first time you use the wipers, the hazards come on along with the dome light. You can turn both off using their respective buttons and then it won't happen again.

Anyone ever see that before or have any clue where to start diagnosing?


Thanks!
Appreciate 0
Post Reply

Bookmarks

Tags
hazard, lights, wiper, wipers

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 10:27 PM.




xbimmers
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST