BMW X3 Forum
BMW X3 Forum
Welcome to the ultimate BMW X3 community.
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
XBimmers | BMW X3 Forum BMW X3 Forums | E83 (2003-2010) First Generation BMW X3 General Forum x3 2008 DOESN'T START

Post Reply
 
Thread Tools Search this Thread
      01-13-2020, 02:54 PM   #1
tonycota
BMWX3si
Mexico
0
Rep
7
Posts

Drives: X3si 2008
Join Date: Dec 2016
Location: ensenada

iTrader: (0)

Question x3 2008 DOESN'T START

I have a 2008 X3 with new battery, last sunday try to start and nothing happens not a single light nothing completely dead, bought a new battery and nothing.
Please help
Appreciate 0
      01-14-2020, 04:15 PM   #2
tonycota
BMWX3si
Mexico
0
Rep
7
Posts

Drives: X3si 2008
Join Date: Dec 2016
Location: ensenada

iTrader: (0)

ok my friend thank you for the tip, i will try that.
Appreciate 0
      02-06-2020, 10:05 PM   #3
DannySan
Banned
4
Rep
3
Posts

Drives: 2007 x3
Join Date: Feb 2020
Location: GA

iTrader: (0)

Quote:
Originally Posted by X3MS View Post
07 and up X3's require the battery to be registered with the ECU. You will need to purchase a code scanner with battery register ability. The Foxwell NT510 will do this.

Scanner video of battery register:

That looks like a good scanner.
Appreciate 0
      02-08-2020, 06:55 AM   #4
X3MS
MARANATHA!
X3MS's Avatar
United_States
9
Rep
20
Posts

Drives: 2007 X3 M-Sport
Join Date: Nov 2018
Location: Oklahoma

iTrader: (0)

First Generation X3's Don't Have IBS.

First generation X3's don't have IBS, and won't require battery registering. Was given some bad info, dismiss previous post.
Appreciate 0
      02-11-2020, 08:58 PM   #5
tonycota
BMWX3si
Mexico
0
Rep
7
Posts

Drives: X3si 2008
Join Date: Dec 2016
Location: ensenada

iTrader: (0)

thanks

It was a bad battery, replace it a now is working.

Appreciate 0
      02-22-2020, 02:39 AM   #6
sidyid
Living it up at Hotel la Mariposa.
Spain
0
Rep
3
Posts

Drives: BMW X3 3.0 SD
Join Date: Oct 2018
Location: Spain

iTrader: (0)

I have a 2006 X3 35SD and I can turn on the ignition, get all of the lights but the car will not crank, it does not have IBS? any ideas guys?
Appreciate 0
      03-12-2020, 04:42 AM   #7
gazza6
Registered
South Africa
0
Rep
2
Posts

Drives: BMW X3 E83 2.0D xdrive
Join Date: Mar 2020
Location: JHB

iTrader: (0)

Quote:
Originally Posted by sidyid View Post
I have a 2006 X3 35SD and I can turn on the ignition, get all of the lights but the car will not crank, it does not have IBS? any ideas guys?
is the starter making any noise or movement at all?
might sound silly, check the wires on the starter motor.
if these are even loose you might not get it to even make a sound.
you might have a main fuse on the starter main line from positive.

maybe just maybe....
Appreciate 0
      05-26-2020, 05:32 AM   #8
matrixhunter
Private
matrixhunter's Avatar
Canada
12
Rep
58
Posts

Drives: 2008 BMW X3 SI M + 2014 M235I
Join Date: Dec 2012
Location: Toronto

iTrader: (0)

The starter ground wire is the issue. You can locate it near the passenger wheel well. It might be fully broken or heavily corroded.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:15 PM.




xbimmers
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST