BMW X3 Forum
BMW X3 Forum
Welcome to the ultimate BMW X3 community.
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
Post Reply
 
Thread Tools Search this Thread
      07-01-2022, 10:15 AM   #1
whitenblue
New Member
0
Rep
13
Posts

Drives: BMW X3 xDrive35i
Join Date: Mar 2020
Location: Philadelphia

iTrader: (0)

Did they fix the water pump issue?

Hi,

I have a 2017 X3 35i, inline 6 with 63K miles on it. I understand the N55 engine had a water pump issue. Since mine is at the tail end of the model run, I was wondering if the problem still existed at that time or if BMW eventually solved the problem. Anyone with a 2017 with water pump issues? If I do have to replace it, is there a better pump so I only have to do this once?

Lastly is there a DIY guide for this model? I see several on YouTube but they are for other vehicles with the N55 engine and there are some devilish details which can be misleading with certain vehicles and installations.

Thanks.
Appreciate 0
      07-01-2022, 11:19 AM   #2
Wgosma
Lieutenant Colonel
United_States
708
Rep
1,774
Posts

Drives: 2012 F25 X3 28i (N52)
Join Date: Sep 2018
Location: Northern Nevada

iTrader: (0)

Look here, may be useful:

https://www.bimmerpost.com/forums/sh...php?p=25254791

https://www.bimmerpost.com/forums/sh...php?p=19291119

There was no recall on pump from BMW; to best of my knowledge no info avail on timing of redesign, etc.
Appreciate 0
      07-01-2022, 03:44 PM   #3
tracer bullet
Colonel
tracer bullet's Avatar
United_States
1267
Rep
2,749
Posts

Drives: '11 135i , '15 X3 35i
Join Date: May 2011
Location: Saint Paul, MN

iTrader: (1)

I've forgotten the details, but have looked it up, and yes, the water pump issue (having to do with the related electronics) was indeed solved along the production timeline. My 2011 135i I had to replace it. So I looked up about my 2015 X3 and (again I forgot the details) but saw that it had been solved in between those dates. It was a reliable source / explanation and not just some schmuck on a forum (like me, hah). For a 2017 you should be fine.
Appreciate 1
Wgosma708.00
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 04:38 AM.




xbimmers
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST