BMW X3 Forum
BMW X3 Forum
Welcome to the ultimate BMW X3 community.
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
XBimmers | BMW X3 Forum BMW X3 Forums | E83 (2003-2010) First Generation BMW X3 General Forum MAF advice x3

Post Reply
 
Thread Tools Search this Thread
      11-06-2019, 05:48 PM   #1
mgcorreia
New Member
0
Rep
6
Posts

Drives: bmw x3 2005
Join Date: Oct 2019
Location: San Diego

iTrader: (0)

MAF advice x3

Hi everyone, I've been getting a p0171/p0174 code occasionally, like once a month during longer trips. My car seems to run ok but my avg mpg is a little low at 17 , when it should be closer to 18-19mpg on an x3 (2005 ; 3.0L; M54; 180k miles). Acceleration can be a little weak, but not terrible. I think I may have tracked it to the MAF sensor. That little bulb on there should be amber correct? Mine is black. I also watched this video that says if you unplug the sensor the car should immediately stall if the MAF works. Well mine kept running when I did this test. I sprayed it down super good with CRC spray but no luck. Is it shot? thanks

Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:03 AM.




xbimmers
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST