BMW X3 Forum
BMW X3 Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
XBimmers | BMW X3 Forum > BMW X3 Forums | E83 (2003-2010) > First Generation BMW X3 General Forum » [Video 2007 X3] Self Leveling Headlights won't stop moving up/down.

Post Reply
 
Thread Tools Search this Thread
      04-14-2014, 07:04 AM   #1
NikolaiRimskyK
Registered
 
Drives: 2007 X3
Join Date: Apr 2014
Location: Moncton, NB

Posts: 1
iTrader: (0)

Question [Video 2007 X3] Self Leveling Headlights won't stop moving up/down.

Sorry for the length.

Recently I purchased a 2007 X3 and I'm have issues with the Xenon headlights auto leveling, and going into some sort of panic mode.

Initial symptoms - Day One:
When I picked it up from the dealer after a heavy rain in fairly cold weather (approx 4 degrees celsius), they said that they only had the battery on the charger for 2 hours, whereas normally they would keep it on for a lot longer. (I was picking it up early). I'm not sure if the battery is an issue, as I had it checked out by an indy BMW specialist a couple days after taking ownership and he said it was fine (pics of the battery below - along with some strange thin rubber tube that doesn't appear to be connected to anything).

When I arrived at the dealership to drive it home, the dealer said that the left turn signal and high beams would not turn off. The high beam/turn signal stock was ineffective, as was the headlight dial and interior light dial. I also wasn't able to turn off the parking lights when the car was off and the key was removed, except by unplugging the battery.

The hazards worked, which allowed me to at least drive in a straight line without people cutting me off thinking that I was turning left. I had a driver in my other car behind me to ensure that I wouldn't be rear ended for the same reasons.

Day two:
All of the exterior lights started flickering wildly. Left/right turn signal alternated. Hazards were rarely functional. High/low beams and even parking lights would flicker. Pretty much undrivable without posing a danger to traffic.

Day three:
Once I got it into my mechanic, he spent about 4 hours looking it over. Computer didn't report any errors. He lifted it on the hoist and then the problem stopped. Lights worked fine. He didn't even charge me for their time, as he expected I would be back.

Day Four:
Lights worked fine. Spent about 8 hours driving around, getting used to the vehicle and enjoying every moment of it - still, with a paranoid feeling that at any moment, the lights would go crazy.

Day Five:
Sure enough, the lights started to give me issues again. Most notably, and as shown in the video, the auto leveling function seems to be constantly trying to adjust the lights. From what I understand after reading this forum at length, I do not have adaptive headlights.

As I took it over to my parents' place to show it off, the lights started flickering wildly. High beams again, right turn signal this time, turning stalk did not work, but the light mode selector did - sort of. Hazards didn't work at first, but after getting it on the highway they did. After about 5 minutes of driving without any flickering of the lights, I turned the high beams off. Everything was back to normal.

Then I parked next to the garage door and noticed the auto leveling kept kicking in. (see video).

I checked the sensors on the control arm and it looked physically fine - no broken parts.

So, that's where I'm at now. I'll bring it back into the shop Monday/Tuesday, but in the meantime, I'd kind of like to hear what everyone's' ideas are. Battery/Power, wiring, LCM, turn stalk? Where do I start without having to replace everything with trial and error and spend a bunch of money?

Thanks ahead of time.

NikolaiRimskyK is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:11 PM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST