BMW X3 Forum
BMW X3 Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
XBimmers | BMW X3 Forum > BMW X3 Forums | F25 (2011 - Current) > Second Generation BMW X3 General Forum » Engine emissions warning light

Post Reply
 
Thread Tools Search this Thread
      12-15-2011, 04:11 AM   #1
Stolenfire
0
New Member
 
Drives: BMW x3 2012
Join Date: Dec 2011
Location: Canada

Posts: 5
iTrader: (0)

Engine emissions warning light

Hey everyone,

so the engine emissions warning light has randomly come on my 2012 3.5i (Canadian model), picked it up 2 weeks ago. I was just wondering if anyone has come upon the same problem and has resolved it.


Thanks and happy holidays!

ps. sorry for the rotated image...i have no idea how to fix that
Attached Images
 
Stolenfire is offline  
Appreciate 0
Reply With Quote
      12-15-2011, 05:55 AM   #2
sfax
38
Brigadier General
 
sfax's Avatar
 
Drives: BMW X3 2011 F25
Join Date: Nov 2010
Location: Berkshire, UK

Posts: 3,853
iTrader: (0)

Not seen any X3s with this on this forum but there are some 3 series reports here

http://www.e90post.com/forums/showthread.php?t=137719

http://www.e90post.com/forums/showthread.php?t=361319
__________________

F25 xDrive20d SE __ professional multimedia package | dynamic package | climate package | 309s | xline | xenons | electric seats | folding mirrors | business speakers
sfax is offline   United Kingdom
Appreciate 0
Reply With Quote
      12-15-2011, 09:52 AM   #3
epiphone3
16
Lieutenant Colonel
 
Drives: 2013 BMW X3 35i
Join Date: Oct 2005
Location: Calgary

Posts: 1,647
iTrader: (0)

Is the engine running in the picture above?
epiphone3 is offline  
Appreciate 0
Reply With Quote
      12-15-2011, 09:56 AM   #4
BMWZ4
6
Captain
 
BMWZ4's Avatar
 
Drives: '11 Z4;'15 X3 & '14 x328i
Join Date: Apr 2010
Location: Toronto

Posts: 626
iTrader: (0)

I would bet this particular warning light has to do with your gas cap or evap valve or something along those lines.
__________________
'11 Z4 sDrive 30i; Space Grey, Coral Red Kansas, 6MT; Fully optioned & '15 28i X3 Fully Loaded; Loaded '14 x328i
BMWZ4 is offline   Canada
Appreciate 0
Reply With Quote
      12-15-2011, 10:10 AM   #5
epiphone3
16
Lieutenant Colonel
 
Drives: 2013 BMW X3 35i
Join Date: Oct 2005
Location: Calgary

Posts: 1,647
iTrader: (0)

Quote:
Originally Posted by Lotus7 View Post
Tach shows 900rpm, so presumably the engine is running.
couldn't see that on my dark-ish screen at work.

I would ask the OP if they've seen much cold weather lately and if they have used a heated garage lately. The warm, moist air in a heated garage can cause condensation in the gas tank which can result in a check-engine-light. If this were the cause, its pretty easy to make it go away by filling up the fuel tank to full and waiting for the light to clear.

However, seeing as the vehicle is brand new, I would make an appointment to get it checked out.
epiphone3 is offline  
Appreciate 0
Reply With Quote
      12-15-2011, 02:48 PM   #6
Stolenfire
0
New Member
 
Drives: BMW x3 2012
Join Date: Dec 2011
Location: Canada

Posts: 5
iTrader: (0)

Thanks for the replies! We don't use a heated garage but the weather has turned warm these past few days! (today is 13 degrees celsius in December!!) however I will book an appointment with the dealer and get it checked out, once again thanks for the speedy responses
Stolenfire is offline  
Appreciate 0
Reply With Quote
      12-15-2011, 03:35 PM   #7
epiphone3
16
Lieutenant Colonel
 
Drives: 2013 BMW X3 35i
Join Date: Oct 2005
Location: Calgary

Posts: 1,647
iTrader: (0)

if a heated garage wasn't used, I'd be surprised if water in the fuel was the issue.

Good idea to go to the dealer and get 'er checked.
epiphone3 is offline  
Appreciate 0
Reply With Quote
      02-15-2012, 08:08 PM   #8
vacro
0
Registered
 
Drives: 2012 X3 28i Titanium Silver
Join Date: Feb 2012
Location: Virginia

Posts: 2
iTrader: (0)

Check Engine Light on

My check engine light also comes on randomly. It started with 100 miles on the car. It mostly is on, but occasionally goes off for part of a day.

The gas cap is tight.

Dealer checked the code, which said fault with intake manifold pressure sensor. They performed smoke test, which revealed no leaks. Ordered a new sensor to be installed next week.

Stay tuned.
vacro is offline   United_States
Appreciate 0
Reply With Quote
      02-16-2012, 01:48 AM   #9
Lamdog
0
New Member
 
Drives: 2002 M3 SMG
Join Date: Mar 2011
Location: Bay Area, CA

Posts: 25
iTrader: (0)

I have the same problem on my 2012 3.5. Taking it in next week for the 2 nd time. I hope the dealer finds out what is wrong ... Let's keep each other posted!
Lamdog is offline  
Appreciate 0
Reply With Quote
      02-21-2012, 03:08 AM   #10
Stolenfire
0
New Member
 
Drives: BMW x3 2012
Join Date: Dec 2011
Location: Canada

Posts: 5
iTrader: (0)

Update:

After dealer cleared the code, it never came back. Dealer informed that it was probably due to a non-tightly shut gas cap, which caused the system to think that there was a leak
Stolenfire is offline  
Appreciate 0
Reply With Quote
      03-01-2012, 06:51 AM   #11
vacro
0
Registered
 
Drives: 2012 X3 28i Titanium Silver
Join Date: Feb 2012
Location: Virginia

Posts: 2
iTrader: (0)

A followup.
Dealer replaced the intake manifold pressure sensor (?)...about $80 part.
Light has been off for 7 days now....so far so good.
vacro is offline   United_States
Appreciate 0
Reply With Quote
      03-08-2012, 04:27 PM   #12
Stolenfire
0
New Member
 
Drives: BMW x3 2012
Join Date: Dec 2011
Location: Canada

Posts: 5
iTrader: (0)

Another update: The engine emissions light came on again, will be heading down to the dealer on friday. This is seriously getting annoying
Stolenfire is offline  
Appreciate 0
Reply With Quote
      03-22-2012, 01:02 AM   #13
Lamdog
0
New Member
 
Drives: 2002 M3 SMG
Join Date: Mar 2011
Location: Bay Area, CA

Posts: 25
iTrader: (0)

Same here. 3rd time I am bringing it in this thurs. their replaced the manifold pressure sensor on mine last time too. Lasted for like 7-8 days and the light came back on. I am totally pissed right now and is ready the lemon law the car if they can't fix it this time. It's ridiculous that I have to bring it in like this for a brand new car that I paid over $50k for!
Lamdog is offline  
Appreciate 0
Reply With Quote
      08-10-2012, 02:07 PM   #14
Rusty84
0
New Member
 
Drives: 2013 x3
Join Date: Jul 2012
Location: Nevada City CA

Posts: 6
iTrader: (0)

Manifold vacuum/pressure gauge

Has anybody installed a manifold vacuum/pressure gauge for their turbo engine? All my other turbos (Corvair, Saab, Mazda 626, Volvo, and RX-7) have had one and I think I'll miss it when my X3 arrives.
Rusty84 is offline  
Appreciate 0
Reply With Quote
      08-10-2012, 02:45 PM   #15
Teemo Panda
11
*Bimmerpost Plasti Dip Guru*
 
Teemo Panda's Avatar
 
Drives: E53, E46-M3, E70, F25-X3
Join Date: Jun 2011
Location: New Jersey (NJ)

Posts: 1,179
iTrader: (0)

Garage List
2013 BMW X3  [2.83]
Dude, I had that on my 2012 3.5i us spec. It I brought it to the shop 4 times they cleared the error but it kept comming back on.

BMWNA agreed to take back the car and give me an equall value of the original price of the car. So I went for the 2013 28i fully loaded

Good Luck!
__________________
Teemo Panda is offline   United_States
Appreciate 0
Reply With Quote
      12-05-2012, 03:56 PM   #16
tango131
0
Private
 
Drives: Boxster S; 2013 X3 28i
Join Date: Jun 2012
Location: Chicago

Posts: 67
iTrader: (0)

Quote:
Originally Posted by Stolenfire View Post
Hey everyone,

so the engine emissions warning light has randomly come on my 2012 3.5i (Canadian model), picked it up 2 weeks ago. I was just wondering if anyone has come upon the same problem and has resolved it.


Thanks and happy holidays!

ps. sorry for the rotated image...i have no idea how to fix that
so my wife called me today saying that this same light came on. problem is we don't have a Canadian version and instead have a US car. anywho, I searched here and came up with this thread. she had about 1/4 tank left and temps in Chicago dropped form 70 2 days ago to 30 today (yes, that happens here ). I asked her to fill it up and make sure the gas cap was tight. Lo and behold, the light went away.

Kudos to this forum!
__________________
2013 X3 28i, AW, Chestnut, Sienna, ZAP, ZCV, ZCW, ZDH, ZPP, rear view, park distance, cargo net (Wife's) (Pics and story)

2010 Porsche Boxster S (Mine)
tango131 is offline  
Appreciate 0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:20 PM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST