BMW X3 Forum
BMW X3 Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
XBimmers | BMW X3 Forum > BMW X3 Forums | F25 (2011 - Current) > Second Generation BMW X3 General Forum » low coolant level..help

Post Reply
 
Thread Tools Search this Thread
      10-08-2012, 07:59 PM   #1
Mingstar88
Second Lieutenant
Canada
2
Rep
242
Posts

 
Drives: BMW X3 35i Carbon Black MSport
Join Date: May 2011
Location: GTA

iTrader: (0)

low coolant level..help

Just started my car 10 minutes ago and it gave that warning...anyone have that experience? Going through some manual stuff right now..

Thanks
Appreciate 0
      10-08-2012, 10:06 PM   #2
Mingstar88
Second Lieutenant
Canada
2
Rep
242
Posts

 
Drives: BMW X3 35i Carbon Black MSport
Join Date: May 2011
Location: GTA

iTrader: (0)

guess i'll have to add some water and drive to dealership tmr...to top it up
Appreciate 0
      10-09-2012, 06:07 AM   #3
cheesebag
Debadged and Alpine Weiss!
cheesebag's Avatar
United Kingdom
2
Rep
249
Posts

 
Drives: 2012 F25 X3 Msport
Join Date: Nov 2011
Location: Cannock UK

iTrader: (0)

Yep... just added coolant and carried on!
Appreciate 0
      10-09-2012, 06:09 AM   #4
nyalpine90
Major General
nyalpine90's Avatar
Colombia
96
Rep
9,104
Posts

 
Drives: '15 X3 28i carbon black
Join Date: Feb 2008
Location: L.I. & Bklyn

iTrader: (4)

Garage List
2012 X3  [3.83]
Send a message via MSN to nyalpine90
add distill water a cup is fine

then get coolant from bmw
__________________
Appreciate 0
      10-09-2012, 11:24 AM   #5
Alligator69
Private First Class
1
Rep
143
Posts

 
Drives: X3 F25 2.0d Mineral Silver
Join Date: Jan 2012
Location: Italy

iTrader: (0)

Had same problem after about 15000km since new car was delivered. I added up a full bottle of BMW coolant (i think it's 2-liters) and from then I've added 5000km on top without any further level warning. Maybe a hiccup in the vehicle preparation when filling up all liquids?
Appreciate 0
      10-09-2012, 02:00 PM   #6
ZipSpeed
Private
ZipSpeed's Avatar
Canada
2
Rep
70
Posts

 
Drives: 2011 X3 xDrive35i
Join Date: Apr 2011
Location: Calgary, Alberta

iTrader: (0)

Quote:
Originally Posted by Alligator69 View Post
Had same problem after about 15000km since new car was delivered. I added up a full bottle of BMW coolant (i think it's 2-liters) and from then I've added 5000km on top without any further level warning. Maybe a hiccup in the vehicle preparation when filling up all liquids?
I had the low coolant warning about a month ago. Reservoir was bone dry. Filled it up with BMW coolant and have been checking every couple weeks. Visually I wasn't able to find any leaks and since the top off, the level hasnt dipped below max. I agree with you that BMW isnt filling enough of it at the factory.
Appreciate 0
      10-09-2012, 05:55 PM   #7
m3bs
Lieutenant
8
Rep
550
Posts

 
Drives: '11 M3 ZCP, 95 M3 Track Toy
Join Date: Feb 2008
Location: North Augusta, SC

iTrader: (1)

Same here. Filled it this weekend.
Appreciate 0
      10-09-2012, 10:14 PM   #8
car_fan
Captain
car_fan's Avatar
35
Rep
830
Posts

 
Drives: 2012 F12 650cic / 2012 E92 M3
Join Date: Jan 2010
Location: SoFla

iTrader: (0)

Quote:
Originally Posted by m3bs View Post
Same here. Filled it this weekend.
Same here 7000 on the odo had the dealer top off, was a little low but still triggered the low coolant msg/warn.
__________________
2012 650cic Space Gray/Vermillon Red/Blk.Top(retired)
2011 MINI CooperS BRGII/Lounge Green/Sport/Prem/Connect/Black Xenon/Black Conical Spokes/ACS springs/ACS exhaust/Alta Shorty/Continental Extreme DW
2012 M3 AW/FR NDH2/2MK/ZPP/ZCP/ZCW/752/6NR/OEM CF splitters/OEM CF Mirror caps
2012 X3 35i Titanium Silver/Black ZAP/ZPP/TECH/APPS/Breyton GTS/Continental Extreme DW
Appreciate 0
      10-10-2012, 08:21 AM   #9
Mingstar88
Second Lieutenant
Canada
2
Rep
242
Posts

 
Drives: BMW X3 35i Carbon Black MSport
Join Date: May 2011
Location: GTA

iTrader: (0)

dealer topped it off......he didnt put that much though
Appreciate 0
      10-10-2012, 05:35 PM   #10
mspringer
Enlisted Member
United_States
0
Rep
48
Posts

 
Drives: BMW X3 35i SAP/DHP
Join Date: May 2011
Location: NJ

iTrader: (0)

Garage List
2002 BMW M3  [0.00]
2011 BMW X3 35i  [0.00]
Happened to me as well. Got a warning when when the car was started from cold which disappeared when the car warmed, even on a restart. The difference in total coolant required to bring the level from just below minimum on the guage, which will trip the low coolant sensor, to maximum is pretty small. Apparently it's quite common to get a low coolant warning when the weather turns cold if the level wasn't close to maximum.

Marty
Appreciate 0
      10-10-2012, 09:25 PM   #11
X Three
New Member
0
Rep
7
Posts

 
Drives: 2011 BMW X3 xDrive28i
Join Date: Aug 2012
Location: Boston, MA

iTrader: (0)

I am also recently getting the low coolant level warning message . . . seems like a trend here. Never had to top off coolant in any other car about a year old before.
Appreciate 0
      10-12-2012, 09:32 AM   #12
PGB
New Member
1
Rep
24
Posts

 
Drives: 2011 X3
Join Date: Aug 2011
Location: New Jersey

iTrader: (0)

Had the same issue at 11000 miles

It was bone dry so took it into the dealer. He said it happens. huh? Spoke to a mate with a 328i and he had the same issue so not sure if it's an X3 thing or a BMW thing.
Appreciate 0
      12-07-2012, 06:17 PM   #13
nuthatch
New Member
0
Rep
6
Posts

 
Drives: 2011 X3 28i gray
Join Date: Nov 2012
Location: Central New York

iTrader: (0)

BMW coolant?

Quote:
Originally Posted by ZipSpeed View Post
I had the low coolant warning about a month ago. Reservoir was bone dry. Filled it up with BMW coolant and have been checking every couple weeks. Visually I wasn't able to find any leaks and since the top off, the level hasnt dipped below max. I agree with you that BMW isnt filling enough of it at the factory.
Is there only a BMW proprietary coolant for my X3? How can you ruin a BMW system by using a bargain brand coolant? I'd like to know.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:11 PM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST