BMW X3 Forum
BMW X3 Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
XBimmers | BMW X3 Forum > BMW X3 Forums | F25 (2011 - Current) > Second Generation BMW X3 General Forum » iphone 5 compatibility

Post Reply
 
Thread Tools Search this Thread
      11-18-2012, 06:54 PM   #1
ttvparker
New Member
 
Drives: '13 X3 28i
Join Date: Aug 2012
Location: WI

Posts: 11
iTrader: (0)

iphone 5 compatibility

I had an iPhone 4 and an x3 with compatibility that worked just fine. I got the new iPhone a while back and have been using mainly bluetooth to stream music/podcasts.

Today, I plugged it in via the lightning cable into the USB jack in the center console. Tried to do both music and BMW apps. Music was accessible through the iDrive interface, but played through the iPhone speakers. Same with web radio in BMW apps.

Is this known? Is there a fix? Thanks!
ttvparker is offline  
0
Reply With Quote
      11-19-2012, 01:30 AM   #2
ReturnZero
First Lieutenant
 
Drives: 2013 X3 35i M-Sport
Join Date: May 2012
Location: Chandler, Arizona

Posts: 301
iTrader: (1)

Maybe try updating your iDrive software? I use my iPhone 5 plugged in through USB quite often and I've never run into that issue, but I just updated mine not long ago.
ReturnZero is offline   United_States
0
Reply With Quote
      11-19-2012, 02:26 AM   #3
sfax
Brigadier General
 
sfax's Avatar
 
Drives: BMW X3 2011 F25
Join Date: Nov 2010
Location: Berkshire, UK

Posts: 3,853
iTrader: (0)

Could be something to do with the fact you had it paired for BT audio and then switched. Was the charge low when you switched? I get strange behaviour when the iPhone 5 is on low charge
__________________

F25 xDrive20d SE __ professional multimedia package | dynamic package | climate package | 309s | xline | xenons | electric seats | folding mirrors | business speakers
sfax is offline   United Kingdom
0
Reply With Quote
      11-19-2012, 02:29 AM   #4
April1
Love All
 
April1's Avatar
 
Drives: X3 28i 2011
Join Date: Nov 2011
Location: San Francisco

Posts: 738
iTrader: (1)

Send a message via Yahoo to April1
You should not have any issues with Bluetooth. You can get audio also thru the lightening g cable. Only restriction is in video display as the video signals out if the lightening cable are no more analog. You can get the video too if you buy lightening v to 30pin adapter and use old cable.
April1 is offline   United_States
0
Reply With Quote
      11-24-2012, 07:14 PM   #5
Phoskins23
New Member
 
Drives: 2013 X3 28i
Join Date: Apr 2012
Location: CT

Posts: 18
iTrader: (0)

Just got an iphone5 this week. I used the lightning/USB cable that came with the phone in the armrest USB port. Everything works perfectly and I get all audio functions and album covers too. Save your money on trying to get a Y cable - you do not need it. This is in a 2013 F25 328i.
Phoskins23 is offline  
0
Reply With Quote
      11-24-2012, 07:16 PM   #6
April1
Love All
 
April1's Avatar
 
Drives: X3 28i 2011
Join Date: Nov 2011
Location: San Francisco

Posts: 738
iTrader: (1)

Send a message via Yahoo to April1
Quote:
Originally Posted by Phoskins23 View Post
Just got an iphone5 this week. I used the lightning/USB cable that came with the phone in the armrest USB port. Everything works perfectly and I get all audio functions and album covers too. Save your money on trying to get a Y cable - you do not need it. This is in a 2013 F25 328i.
Audio with album covers will even with 2011 F25 with iPhone 5 and lightening cable.
April1 is offline   United_States
0
Reply With Quote
      11-25-2012, 03:59 AM   #7
sfax
Brigadier General
 
sfax's Avatar
 
Drives: BMW X3 2011 F25
Join Date: Nov 2010
Location: Berkshire, UK

Posts: 3,853
iTrader: (0)

Quote:
Originally Posted by Phoskins23 View Post
Just got an iphone5 this week. I used the lightning/USB cable that came with the phone in the armrest USB port. Everything works perfectly and I get all audio functions and album covers too. Save your money on trying to get a Y cable - you do not need it. This is in a 2013 F25 328i.
This was covered in detail here

http://x3.xbimmers.com/forums/showthread.php?t=758539

Note:
Quote:
USB is offered standard on all 2013 BMW models
- so you won't need a Y cable
__________________

F25 xDrive20d SE __ professional multimedia package | dynamic package | climate package | 309s | xline | xenons | electric seats | folding mirrors | business speakers
sfax is offline   United Kingdom
0
Reply With Quote
      11-25-2012, 02:09 PM   #8
docal97
New Member
 
Drives: 2010 bmw 328i xdrive
Join Date: Nov 2009
Location: southampton, pa

Posts: 14
iTrader: (0)

I had the same issue w/ the music playing from the iphone speakers even though the iphone was successfully paired w/ the bmw via BT and configured properly. I restarted the phone and everything worked perfectly.
docal97 is offline  
0
Reply With Quote
      11-27-2012, 08:10 AM   #9
terrytnt
Private
 
terrytnt's Avatar
 
Drives: 2012 X3 35i M/DHP Carbon Black
Join Date: Dec 2011
Location: Yardley, PA

Posts: 72
iTrader: (0)

iPhone 5 and Static/ Crackling

Have any of you noticed static when using your iPhone 5 in the X3? On the Mac forum, this is a problem with many folks and NOT restricted to BMW
terrytnt is offline   United_States
0
Reply With Quote
      11-27-2012, 09:03 AM   #10
sfax
Brigadier General
 
sfax's Avatar
 
Drives: BMW X3 2011 F25
Join Date: Nov 2010
Location: Berkshire, UK

Posts: 3,853
iTrader: (0)

Quote:
Originally Posted by terrytnt View Post
Have any of you noticed static when using your iPhone 5 in the X3? On the Mac forum, this is a problem with many folks and NOT restricted to BMW
When making calls over Bluetooth? Not noticed any issues so far
__________________

F25 xDrive20d SE __ professional multimedia package | dynamic package | climate package | 309s | xline | xenons | electric seats | folding mirrors | business speakers
sfax is offline   United Kingdom
0
Reply With Quote
      11-27-2012, 09:58 AM   #11
Yeltzer
First Lieutenant
 
Yeltzer's Avatar
 
Drives: F25 xDrive 20d M Sport
Join Date: Nov 2008
Location: West Mids & Worcs

Posts: 315
iTrader: (0)

Quote:
Originally Posted by sfax View Post
When making calls over Bluetooth? Not noticed any issues so far
Me neither. Same flawless reception as with the iPhone 4
__________________
F25 xDrive 20d M Sport in Alpine White, Pro Nav, Auto 'Box, 19" Wheels, Visibility Pack, Heated Seats, Reverse Cam w/ Top View, Sun Protection Glass, DAB radio
Yeltzer is offline  
0
Reply With Quote
      11-27-2012, 10:59 AM   #12
April1
Love All
 
April1's Avatar
 
Drives: X3 28i 2011
Join Date: Nov 2011
Location: San Francisco

Posts: 738
iTrader: (1)

Send a message via Yahoo to April1
Quote:
Originally Posted by terrytnt View Post
Have any of you noticed static when using your iPhone 5 in the X3? On the Mac forum, this is a problem with many folks and NOT restricted to BMW
Not observed so far though I use Bluetooth connectivity most of the time.
April1 is offline   United_States
0
Reply With Quote
      11-27-2012, 12:12 PM   #13
DonC
First Lieutenant
 
Drives: 2013 X3 3.5i M sport, etc
Join Date: Aug 2012
Location: near Seattle

Posts: 353
iTrader: (0)

I have notice it with my g4 iphone.
__________________
2013 X3 3.5i AW,Msprt,rear fogs,PS,CP, Tech, etc...
Other cars
2005 S2000
2007 TL-S
DonC is offline   United_States
0
Reply With Quote
      11-27-2012, 01:14 PM   #14
ReturnZero
First Lieutenant
 
Drives: 2013 X3 35i M-Sport
Join Date: May 2012
Location: Chandler, Arizona

Posts: 301
iTrader: (1)

Calls are very good quality with my iPhone 5, at least as good as with my 4S.

EDIT: Over Bluetooth
ReturnZero is offline   United_States
0
Reply With Quote
      11-28-2012, 12:07 PM   #15
terrytnt
Private
 
terrytnt's Avatar
 
Drives: 2012 X3 35i M/DHP Carbon Black
Join Date: Dec 2011
Location: Yardley, PA

Posts: 72
iTrader: (0)

Crazy thing is, now my iP5 is working perfectly without cracking or static... this thing tends to come and go

go figure....
terrytnt is offline   United_States
0
Reply With Quote
      09-07-2013, 06:11 AM   #16
Harvey
Registered
 
Drives: 2007 BMW X3
Join Date: Aug 2013
Location: St. Louis

Posts: 2
iTrader: (0)

I recently purchased a CPO 2007 X3. My wife's iPhone 4S pairs just fine. My iPhone 5 is not even recognized by the car, no pairing or even sensing of the Bluetooth signal. No Nav in the X3. Thoughts?
Harvey is offline  
0
Reply With Quote
      09-09-2013, 07:19 AM   #17
terrytnt
Private
 
terrytnt's Avatar
 
Drives: 2012 X3 35i M/DHP Carbon Black
Join Date: Dec 2011
Location: Yardley, PA

Posts: 72
iTrader: (0)

iPhone 5 and Static

YES! I have noticed static (i.e., crackling) when I purchased my iPhone 5 last year. However, and this is the interesting thing: the iPhone 5 ONLY makes crackling sounds when the battery is fully or almost charged , >95%. If I let the iPhone battery wear down to say, <85% - NO PROBLEMS what-so-ever.

Interesting and can't figure this out... posted this situation a while back but no one could diagnose.
terrytnt is offline   United_States
0
Reply With Quote
      09-09-2013, 01:50 PM   #18
02420X3
Captain
 
Drives: 2011 X3 35i
Join Date: Jun 2011
Location: Boston

Posts: 683
iTrader: (0)

Quote:
Originally Posted by Harvey View Post
I recently purchased a CPO 2007 X3. My wife's iPhone 4S pairs just fine. My iPhone 5 is not even recognized by the car, no pairing or even sensing of the Bluetooth signal. No Nav in the X3. Thoughts?
Harvey, you may have better luck asking your question in the 1st Generation X3 Forum, which can be found at:

http://x3.xbimmers.com/forums/forumdisplay.php?f=91
02420X3 is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:53 PM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST