BMW X3 Forum
BMW X3 Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
XBimmers | BMW X3 Forum > BMW X3 Forums | F25 (2011 - Current) > Second Generation BMW X3 General Forum » Anti Trap Window Failure

Post Reply
 
Thread Tools Search this Thread
      10-26-2012, 04:00 PM   #1
MattUK
Captain Unsensible
 
MattUK's Avatar
 
Drives: 2011 X3 3.0D MSport
Join Date: Sep 2011
Location: United Kingdom

Posts: 626
iTrader: (0)

Garage List
Anti Trap Window Failure

Combined with my tyre pressure warning message yesterday, I am also getting a message that the anti trap system on the Windows has failed.

Anyone had this before?

I've always thought that the front windows power up too slowly anyway
MattUK is offline   United Kingdom
0
Reply With Quote
      10-26-2012, 08:14 PM   #2
welkerbrads
Private First Class
 
Drives: 2011 white X3
Join Date: Apr 2009
Location: cape girardeau mo

Posts: 120
iTrader: (0)

Yes, I just had mine repaired. It was the window regulator going out on the front passenger side. Covered under warranty.
welkerbrads is offline   United_States
0
Reply With Quote
      10-26-2012, 10:27 PM   #3
dandanio
The one that drives!
 
dandanio's Avatar
 
Drives: 11 x3 35i/09 Jetta TDI
Join Date: Mar 2009
Location: New England

Posts: 173
iTrader: (0)

or just a miscalibration. Either way, simple fix.
dandanio is offline   United_States
0
Reply With Quote
      10-26-2012, 10:44 PM   #4
daninny
Enlisted Member
 
Drives: Cayman S
Join Date: Jun 2012
Location: NY

Posts: 39
iTrader: (0)

I may be off on the description, but try the following. With the door closed, open both front windows at the same time and hold the buttons past the point of complete opening for a few seconds. Then close both at the same time and hold closed for a few seconds. I watched as the service guy did this when my programming went out when they changed my headlight sensor. If this doesn't work, just bring it to the dealer - it's literally a 10 second fix.
daninny is offline  
0
Reply With Quote
      10-27-2012, 05:03 AM   #5
sfax
Brigadier General
 
sfax's Avatar
 
Drives: BMW X3 2011 F25
Join Date: Nov 2010
Location: Berkshire, UK

Posts: 3,853
iTrader: (0)

I've seen a few reports of various problems with electric windows and quite a few people had the regulator replaced. Some examples here.

http://x3.xbimmers.com/forums/showthread.php?t=604367

Haven't seen the specific anti-trap message you're getting on the forum before though
__________________

F25 xDrive20d SE __ professional multimedia package | dynamic package | climate package | 309s | xline | xenons | electric seats | folding mirrors | business speakers
sfax is offline   United Kingdom
0
Reply With Quote
      10-27-2012, 01:02 PM   #6
MattUK
Captain Unsensible
 
MattUK's Avatar
 
Drives: 2011 X3 3.0D MSport
Join Date: Sep 2011
Location: United Kingdom

Posts: 626
iTrader: (0)

Garage List
Tried the reset routine, but that made no difference.. not something im bothered about a visit for until the service is due i think
MattUK is offline   United Kingdom
0
Reply With Quote
      10-27-2012, 05:04 PM   #7
daninny
Enlisted Member
 
Drives: Cayman S
Join Date: Jun 2012
Location: NY

Posts: 39
iTrader: (0)

I probably missed something while the guy was doing the reset. Anyway, it's literally a 10 second fix. Where we are, you can just show up and they'll fix it right away. Not sure how far you're from the dealer, though (mine's only 10 minutes away).
daninny is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:12 AM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST