BMW X3 Forum
BMW X3 Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
XBimmers | BMW X3 Forum > BMW X3 Forums | E83 (2003-2010) > First Generation BMW X3 General Forum » radio issue, please help

Post Reply
 
Thread Tools Search this Thread
      12-10-2012, 12:31 PM   #1
cleung
Private
1
Rep
77
Posts

 
Drives: 1997 Z3 1.9,2014 X1 28i xdrive
Join Date: Jun 2011
Location: Saskatchewan Canada

iTrader: (2)

radio issue, please help

My radio will stop working once in a while when it is cold out. I have it narrowed down a little, it only happens when it is cold out, it will stop working no display no sound no bluetooth but the buttons will remain lit and the memory will keep. Then if I pull out fuse #42 (maybe its 41 can't remember) and reinsert it the radio will begin working again. I read somewhere that this may be because the radio is sensing a low voltage and going into sleep mode to reserve battery life. I changed to a agm battery last month hoping that it would fix my issue but no luck. My wife does make short trips daily which I know drains on the battery but is there any way to stop this radio issue from happening? Is this normal is my radio too sensitive to voltage changes?
__________________
2003 325xi (retired)
2004 530i (retired)
2008 X3 3.0i (retired)
1997 Z3 1.9
2014 X1 28i xdrive
Appreciate 0
      03-26-2013, 11:17 PM   #2
joylove
Private
0
Rep
56
Posts

 
Drives: X3 LCI
Join Date: Mar 2013
Location: West Coast.

iTrader: (0)

Somewhere in the depth of my mind this is either a duff connection on the back of the radio or a new radio required.
Appreciate 0
      04-01-2013, 12:06 PM   #3
cleung
Private
1
Rep
77
Posts

 
Drives: 1997 Z3 1.9,2014 X1 28i xdrive
Join Date: Jun 2011
Location: Saskatchewan Canada

iTrader: (2)

this turned out to be a faulty head unit issue. BMW replaced the radio and has been well.
__________________
2003 325xi (retired)
2004 530i (retired)
2008 X3 3.0i (retired)
1997 Z3 1.9
2014 X1 28i xdrive
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:42 AM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST