BMW X3 Forum
BMW X3 Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
XBimmers | BMW X3 Forum > BMW X3 Forums | F25 (2011 - Current) > Second Generation BMW X3 General Forum » Missing the "X3" badge on rear right end

Post Reply
 
Thread Tools Search this Thread
      09-06-2012, 01:23 AM   #1
heverlee
Private
 
Drives: X3
Join Date: Apr 2012
Location: AZ

Posts: 54
iTrader: (0)

Missing the "X3" badge on rear right end

Just a heads up

have been driving my X3 for four months and just noticed that badge is missing from this week.

Had the car inspected by the dealer and their pretty surprised on this. The manager sighed today looking at that place where an X3 badge should stay " American workers, built in Spartanburg".

Dealer will order one piece and put it back on in a couple of days. Am a bit surprised at the QA in the factory. How come they can miss this?
heverlee is offline  
0
Reply With Quote
      09-06-2012, 01:55 AM   #2
JimmyTheHand
Private
 
Drives: X3
Join Date: Aug 2012
Location: UK

Posts: 52
iTrader: (0)

doesn't the "Model designation deletion" remove that along with the ones on the side.
JimmyTheHand is offline   United Kingdom
0
Reply With Quote
      09-06-2012, 02:49 AM   #3
gareth3685
Private First Class
 
Drives: 2.0D
Join Date: Oct 2011
Location: UK

Posts: 157
iTrader: (0)

Quote:
Originally Posted by JimmyTheHand View Post
doesn't the "Model designation deletion" remove that along with the ones on the side.
I don't believe that option is available in the US.
gareth3685 is offline  
0
Reply With Quote
      09-06-2012, 09:11 AM   #4
DonC
First Lieutenant
 
Drives: 2013 X3 3.5i M sport, etc
Join Date: Aug 2012
Location: near Seattle

Posts: 353
iTrader: (0)

I bet there is a gang looking for the badges - had an "EX" stolen from my last car...
__________________
2013 X3 3.5i AW,Msprt,rear fogs,PS,CP, Tech, etc...
Other cars
2005 S2000
2007 TL-S
DonC is offline   United_States
0
Reply With Quote
      09-06-2012, 11:14 AM   #5
JimmyTheHand
Private
 
Drives: X3
Join Date: Aug 2012
Location: UK

Posts: 52
iTrader: (0)

Quote:
Originally Posted by DonC View Post
I bet there is a gang looking for the badges - had an "EX" stolen from my last car...
or maybe just a group of pop fans confused about the badge and year - Link
JimmyTheHand is offline   United Kingdom
0
Reply With Quote
      09-06-2012, 12:29 PM   #6
n55x3
Captain
 
Drives: n55 BMWs
Join Date: Dec 2011
Location: us - ohio

Posts: 729
iTrader: (0)

Badge delete is not available from the factory on US models.

I have deleted mine manually!! If you want the rear X3 badge it is all yours...
n55x3 is offline  
0
Reply With Quote
      09-06-2012, 02:01 PM   #7
mdallas
New Member
 
Drives: 2013 X3 35i
Join Date: Aug 2012
Location: Vermont

Posts: 29
iTrader: (0)

Quote:
Originally Posted by n55x3 View Post
Badge delete is not available from the factory on US models.

I have deleted mine manually!! If you want the rear X3 badge it is all yours...

a hairdryer and dentalfloss?
mdallas is offline  
0
Reply With Quote
      09-06-2012, 03:20 PM   #8
n55x3
Captain
 
Drives: n55 BMWs
Join Date: Dec 2011
Location: us - ohio

Posts: 729
iTrader: (0)

I did use floss and a hot summer day on my Tahoe but for the X3 I was able to just pull them off on a really hot day shortly after taking delivery. I removed the rear X3 badge along with the side XDrive badges. They all came off really easy with only a tiny bit of residue left over. Did a once over with some goo-gone and it looked great.
n55x3 is offline  
0
Reply With Quote
      09-06-2012, 05:43 PM   #9
mdallas
New Member
 
Drives: 2013 X3 35i
Join Date: Aug 2012
Location: Vermont

Posts: 29
iTrader: (0)

Quote:
Originally Posted by n55x3 View Post
I did use floss and a hot summer day on my Tahoe but for the X3 I was able to just pull them off on a really hot day shortly after taking delivery. I removed the rear X3 badge along with the side XDrive badges. They all came off really easy with only a tiny bit of residue left over. Did a once over with some goo-gone and it looked great.
+1

think the "blue efficency" badges on my 2012 ML550 are going to come up missing!!!

Last edited by mdallas; 09-07-2012 at 08:53 AM.
mdallas is offline  
0
Reply With Quote
      09-09-2012, 10:32 PM   #10
DonC
First Lieutenant
 
Drives: 2013 X3 3.5i M sport, etc
Join Date: Aug 2012
Location: near Seattle

Posts: 353
iTrader: (0)

I've been looking at the side badges - think they might go away.
__________________
2013 X3 3.5i AW,Msprt,rear fogs,PS,CP, Tech, etc...
Other cars
2005 S2000
2007 TL-S
DonC is offline   United_States
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:28 AM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST