BMW X3 Forum
BMW X3 Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
XBimmers | BMW X3 Forum > BMW X3 Forums | F25 (2011 - Current) > Second Generation BMW X3 General Forum » TPM Malfunction

Post Reply
 
Thread Tools Search this Thread
      07-16-2012, 11:14 AM   #1
mistermagoo
Enlisted Member
 
Drives: 2012 X3 xDrive35i
Join Date: Nov 2011
Location: New York, NY

Posts: 31
iTrader: (0)

TPM Malfunction

Hi all. My wife told me she's been getting a "TPM Malfunction" message on her 2012 X3. I checked the tire pressure, and they're fine, but this message is a bit disconcerting given that she uses the car on a daily basis, which also includes dropping our 5 month old off at day care.

Has anyone seen this error? Is it something that goes away after a while, or should I bring the car in to have it checked out?

I searched the forums to see if a post similar to this already existed, but I didn't find any. Apologies of this is redundant.

Thanks again everyone.
mistermagoo is offline   United_States
0
Reply With Quote
      07-16-2012, 11:42 AM   #2
NordicBMW
Private
 
NordicBMW's Avatar
 
Drives: 2012 X3 / 2013 X1
Join Date: Jul 2012
Location: Norway

Posts: 76
iTrader: (0)

The systems/sensors are a bit different in US and Europe. But what I did with my other car (haven't seen this warning in my X3 yet) when getting this error was to check my tyre pressure and when I found nothing wrong there I re-calibrated the system as per the manual and have been driving without any more fuss after that.

My suggestion is to top off the tyres, re-calibrate and check pressure daily for a while just to be sure. If the error returns you may have a leakage.
NordicBMW is offline   Norway
0
Reply With Quote
      07-16-2012, 12:03 PM   #3
April1
Love All
 
April1's Avatar
 
Drives: X3 28i 2011
Join Date: Nov 2011
Location: San Francisco

Posts: 738
iTrader: (1)

Send a message via Yahoo to April1
Quote:
Originally Posted by mistermagoo View Post
Hi all. My wife told me she's been getting a "TPM Malfunction" message on her 2012 X3. I checked the tire pressure, and they're fine, but this message is a bit disconcerting given that she uses the car on a daily basis, which also includes dropping our 5 month old off at day care.

Has anyone seen this error? Is it something that goes away after a while, or should I bring the car in to have it checked out?

I searched the forums to see if a post similar to this already existed, but I didn't find any. Apologies of this is redundant.

Thanks again everyone.
Check the tire pressures and reset the TPM. If the problem reappears, see your dealer.
April1 is offline   United_States
0
Reply With Quote
      11-12-2012, 04:51 PM   #4
mistermagoo
Enlisted Member
 
Drives: 2012 X3 xDrive35i
Join Date: Nov 2011
Location: New York, NY

Posts: 31
iTrader: (0)

Thought this was a done issue, but three visits to the dealer, and the TPM malfunction persists. First time I brought it in, they said it was due to low tire pressure (tires were inflated to recommended PSI, but whatever). Second time I brought it in for the same issue, they said it was due to a faulty sensor, which they fixed. As I was driving off, the TPM malfunction indicator came on. I brought it in for the third time that weekend. They kept the car for over a week and said they had to reinitialize the TPM system. Drove fine for a couple of days, and then it came back. Now it's going off every 30 seconds. Very distracting, and a bit disconcerting given that my wife doesn't know whether there's anything wrong with the car. What makes matters worse is that she drives our 9-month old to day care.

Has anyone experienced anything similar to this? Not sure why it's taking so many trips to the dealership to get this problem fixed once and for all. Love the car when it's not chiming every 30 seconds...
mistermagoo is offline   United_States
0
Reply With Quote
      11-19-2012, 08:56 AM   #5
nyalpine90
Major General
 
nyalpine90's Avatar
 
Drives: '15 X3 28i cCB
Join Date: Feb 2008
Location: L.I. & Bklyn

Posts: 8,983
iTrader: (4)

Garage List
2012 X3  [3.83]
Send a message via MSN to nyalpine90
it should tell u which tire is low, i have an issue with tpms. it shows on the screen rear right tire but when i check the psi its fine. i decided to check rear left tire found out it was low. so theres something wrong with tpms system. i have service appt tomorrow.
__________________
nyalpine90 is offline   Colombia
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:40 AM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST