BMW X3 Forum
BMW X3 Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
XBimmers | BMW X3 Forum > BMW X3 Forums | F25 (2011 - Current) > Second Generation BMW X3 General Forum » SI B24 02 12 - throttle lag (and steering pull fix)?

Post Reply
 
Thread Tools Search this Thread
      07-09-2012, 09:56 PM   #133
lbjgh
Major
 
lbjgh's Avatar
 
Drives: 2013 AW X3 M-Sport
Join Date: Dec 2011
Location: North of Toronto

Posts: 1,451
iTrader: (0)

cer2225,

My car is a 2013 and this is the profile infor:

<?xml version="1.0" encoding="utf-8"?>
<bmwExportData>
<signedContent>
<header>
<date>2012-07-09T22:50:05</date>
<version>1</version>
<username>(------)</username>
<vin>Lxxxxx</vin>
<i-step>F001-12-03-511</i-step>
</header>
<body>
<securityContainer type="vehicle" securityLevel="1">
Quote:
Originally Posted by cer2225 View Post
Okay, So I was able to figure out that we can read the software revision by exporting a profile to a USB stick and opening it up in Notepad.

When I exported it I get the following <i-step>F001-11-09-501</i-step>

When I cross reference that with it comes back as 2.43 and actually for an 7 series.

Man I hate some dealers....

Can someone that has the latest build do the same and tell me what you see?

Thanks
-CR
__________________
2013, AW, xDrive35i, M Sport Package, Technology Package, Dynamic Comfort Package, Premium Package, 3M Clear Bra, Euro foglight switch, a few coded fixes
lbjgh is offline   Canada
0
Reply With Quote
      07-10-2012, 05:42 AM   #134
cer2225
Enlisted Member
 
Drives: 2011 X3
Join Date: Apr 2011
Location: NY

Posts: 33
iTrader: (0)

Thanks for checking. Looks like either they did not want to do the update or are just plain dumb. I will call the service manager and complain.

Mine is a 2011 28i. I guess the F001 code is to be expected.

-CR
cer2225 is offline  
0
Reply With Quote
      07-10-2012, 01:48 PM   #135
75bullish
New Member
 
Drives: BMW X3
Join Date: May 2011
Location: Vancouver, Canada

Posts: 27
iTrader: (0)

Quote:
Originally Posted by Hornet_Rider View Post
Got the update and it works great, but now language settings and others don`t hold. I need to change it everytime I start the car...
When the dealer had my car for the "cannot choose English" issue, they went through the sleep cycle 4 times to make sure the language and other settings will not reset automatically.

Take it back to the dealer and have them fix it for you.
75bullish is offline   Canada
0
Reply With Quote
      07-10-2012, 04:33 PM   #136
Harplayr
Lieutenant
 
Drives: 2011 BMW X3 28i, F25
Join Date: Apr 2011
Location: Chicago

Posts: 424
iTrader: (0)

Quote:
Originally Posted by DouginNC View Post
I had the update performed on my 2011 2.8 and noticed a couple of changes:


Now instead of the transmission shifting from 1st 2nd and 3rd within just a few feet, the transmission lets the RPMs come up in 1st, then 2nd and then 3rd. The way my transmission was running through the gears seems to have been causing the delay in my X3. Big improvement. It's more like the old Sport mode, but not quite as long of shift intervals.


The steering now is heavier and more center weighted. I like the change. The steering is still no where as heavy as my 128, but at least there is a more connected feeling to the road now. Definitely is center weighted, as the wheel really wants to be at center after making a turn. Acts more like they performed a wheel alignment, but they didn't.

Some of my user settings were erased and others were not. All of my radio presets were gone, yet bluetooth was still set up to pare with my iPhone.

The update to my X3 took 3 hours. I waited while it was done. The dealer found the TSB after I complained about throttle response.

Glad I had it done.

Doug in NC
I had the TSB done but there was no change in steering feel. Has anybody else notice a change in handling?
Harplayr is offline  
0
Reply With Quote
      09-28-2012, 08:21 AM   #137
flash3
Captain
 
Drives: X3 28i
Join Date: Feb 2011
Location: NC

Posts: 652
iTrader: (0)

What do I need to print out and bring with me?
flash3 is offline  
0
Reply With Quote
      09-28-2012, 10:02 AM   #138
flash3
Captain
 
Drives: X3 28i
Join Date: Feb 2011
Location: NC

Posts: 652
iTrader: (0)

just called my service advisor and said I need to drive the car with a technician and show him the problem, we just don't apply updates.
flash3 is offline  
0
Reply With Quote
      10-09-2012, 10:05 PM   #139
flash3
Captain
 
Drives: X3 28i
Join Date: Feb 2011
Location: NC

Posts: 652
iTrader: (0)

Bump - hate to do it but had to
flash3 is offline  
0
Reply With Quote
      10-09-2012, 11:01 PM   #140
lbjgh
Major
 
lbjgh's Avatar
 
Drives: 2013 AW X3 M-Sport
Join Date: Dec 2011
Location: North of Toronto

Posts: 1,451
iTrader: (0)

Just try a different dealership.
__________________
2013, AW, xDrive35i, M Sport Package, Technology Package, Dynamic Comfort Package, Premium Package, 3M Clear Bra, Euro foglight switch, a few coded fixes
lbjgh is offline   Canada
0
Reply With Quote
      10-10-2012, 08:09 AM   #141
gareth12468
First Lieutenant
 
Drives: 2011 X3 xDrive 28i
Join Date: Mar 2011
Location: Toronto

Posts: 307
iTrader: (0)

Garage List
2011 BMW X3  [0.00]
Quote:
Originally Posted by flash3 View Post
Bump - hate to do it but had to
I went to the dealership 3 times before they contact BMW Canada and agree to perform a full reprogramming with my 28i.....
gareth12468 is offline   Canada
0
Reply With Quote
      10-10-2012, 12:51 PM   #142
kglo
New Member
 
Drives: 2013 X3 28i
Join Date: Sep 2012
Location: Toronto

Posts: 10
iTrader: (0)

Quote:
Originally Posted by cer2225 View Post
Thanks for checking. Looks like either they did not want to do the update or are just plain dumb. I will call the service manager and complain.

Mine is a 2011 28i. I guess the F001 code is to be expected.

-CR
Is there any reason why the X3's are installed with F001 code? It looks like these are either for 7 series or 5 series? Or does that matter as long as its the right ISTA/P version?
kglo is offline  
0
Reply With Quote
      10-12-2012, 12:38 PM   #143
Scamper
New Member
 
Scamper's Avatar
 
Drives: 2011 X3 28i Deep Sea Blue
Join Date: Oct 2012
Location: Central Illinois

Posts: 5
iTrader: (0)

Quote:
Originally Posted by walendvay View Post
Who's had it done and what are the comments?
Is this something I should request as I have just taken delivery of a 2011 28i with 13k miles.

Thanks
Scamper is offline   United_States
0
Reply With Quote
      10-12-2012, 12:51 PM   #144
pokerface
Lieutenant Colonel
 
pokerface's Avatar
 
Drives: B8 A4 2.0T
Join Date: Apr 2006
Location: Toronto

Posts: 1,679
iTrader: (1)

they didnt "find" the problem on ours. gonna have to press harder.
__________________
F25 X3 N20:

2010 B8 A4 2.0T quattro (current)/
2013 F25 X3 x28 N20 (babymobile)
pokerface is offline   Canada
0
Reply With Quote
      10-19-2012, 09:34 PM   #145
XB101
Second Lieutenant
 
Drives: 2011 TiAg X3 35i
Join Date: Jun 2011
Location: Western Canada

Posts: 225
iTrader: (0)

When I went to a Canadian dealer about 2 months ago they don't know about the SB and couldn't find anything wrong with the hesitation!
XB101 is offline   Canada
0
Reply With Quote
      11-03-2012, 04:54 PM   #146
cwr001
Registered
 
Drives: 2008 328I
Join Date: Jul 2010
Location: Nashville TN

Posts: 3
iTrader: (0)

Took my 2012 2.8 in this week to Nashville BMW and gave them a copy of the service bulletin. They checked and said my build date was a month past the cut off. They decided to apply the upgrade anyway and it makes a big difference. The lag is gone and the shifts are much tighter. I was surprised they were so willing to deal with the problem.
cwr001 is offline  
0
Reply With Quote
      11-03-2012, 05:36 PM   #147
April1
Love All
 
April1's Avatar
 
Drives: X3 28i 2011
Join Date: Nov 2011
Location: San Francisco

Posts: 738
iTrader: (1)

Send a message via Yahoo to April1
Quote:
Originally Posted by Scamper View Post
Is this something I should request as I have just taken delivery of a 2011 28i with 13k miles.

Thanks
Yes go for it if you do not like the throttle lag.
April1 is offline   United_States
0
Reply With Quote
      04-01-2013, 03:26 PM   #148
flash3
Captain
 
Drives: X3 28i
Join Date: Feb 2011
Location: NC

Posts: 652
iTrader: (0)

Quote:
Originally Posted by Beyu View Post
I'm almost due for my 1st 12,000 mile service and will be asking BMW to upgrade my software when the time comes.

My plan is to print off the TSB as suggested in another thread. However, will there be any way to check the version number or will I just have to take the technicians' word for it?
Where can I get the TSB?
flash3 is offline  
0
Reply With Quote
      04-02-2013, 11:20 AM   #149
mspringer
Enlisted Member
 
Drives: BMW X3 35i SAP/DHP
Join Date: May 2011
Location: NJ

Posts: 47
iTrader: (0)

Garage List
2002 BMW M3  [0.00]
2011 BMW X3 35i  [0.00]
SI B24 02 12

Subject:
N52T/N55 with 8HP45: Delay in Engine Response

Model
E70, E71 with the N55 engine and 8HP45 transmission from 4/1/2010 to 1/16/2012

F07, F10 and F25 with either N52T or N55 engines and 8HP45 transmission up to 1/16/2012

Situation
When slowing down to lower suburban road speeds and then reaccelerating, a delay in engine response may be experienced

This situation may be more noticeable when driving in a bend in the road or on roads with a rising gradient.

Cause
Unfavorable EGS and DME software calibration

Correction
Program the vehicle using ISTA/P 2.46.0 or higher

Marty
mspringer is online now   United_States
0
Reply With Quote
      09-25-2013, 02:17 PM   #150
saulgoodman
Private First Class
 
saulgoodman's Avatar
 
Drives: 2012 F25 N52T
Join Date: Jan 2012
Location: Boston, MA

Posts: 142
iTrader: (0)

Garage List
I see an updated SB for the throttle delay issue...does any one had this s/w updated? Or is this same as SI-B24-02-12?


2012 Bmw X3 (pws) Service Bulletin Number: SIB-24-03-13

NHTSA: Action Number: 10052360 Service Bulletin Number: SIB-24-03-13

Report Date: May 01, 2013
Component: (pws)


Summary: Bmw: some vehicle engines may experience a delay in response to acceleration, after slowing down, due to an unfavorable software calibration. Models f10, 25, 07, e70, 71. No model years listed. *pe
saulgoodman is offline   United_States
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:56 PM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST