BMW X3 Forum
BMW X3 Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
XBimmers | BMW X3 Forum > BMW X3 Forums | F25 (2011 - Current) > Second Generation BMW X3 General Forum » SI B24 02 12 - throttle lag (and steering pull fix)?

Post Reply
 
Thread Tools Search this Thread
      05-29-2012, 09:49 AM   #89
April1
Love All
 
April1's Avatar
 
Drives: X3 28i 2011
Join Date: Nov 2011
Location: San Francisco

Posts: 738
iTrader: (1)

Send a message via Yahoo to April1
Once you give the correct SIB number, your SA should be able to locate it easily unless this is not released in your country.
April1 is offline   United_States
0
Reply With Quote
      05-31-2012, 08:11 PM   #90
rgx3
Enlisted Member
 
rgx3's Avatar
 
Drives: 2012 X3 xDrive 35i
Join Date: Nov 2011
Location: Western Washington State

Posts: 40
iTrader: (0)

I have my fingers crossed!

Quote:
Originally Posted by jdavid2 View Post
I remember reading somewhere that this fix is "officially" to fix a shifting/acceleration delay when slowing down to slow speed of 3 - 10 mph and then trying to accelerate from this slow speed. This is just one of the symptoms of the throttle lag when pulling away from a stop. Maybe the "official" symptom there are stating the update is for is more of a safety issue then just pulling away smoothly from a stop. Either way, both issues are fixed with the update.
Dropped the car of at the dealer for a software update that specifically was for the above mentioned issue. The SA kept drilling me that if I didn't have this specific problem that the software update didn't apply. I kept referencing info from this forum and telling him that throttle response was abrubt after slowing down and speeding up and after stopping at a stop sign and then accelerating. He said they would drive it and see if it had the specific problem the software update was for. I argued that if there is a software update then why isn't it installed automatically? Oh, he also asked if I tried driving in sport mode? Should I have to? I feel like I'll go back tomorrow and they will have done nothing. I'm trying to remain cool but many of you have said the software update is the bomb and fixes the throttle response. It's frustrating to say the least.
rgx3 is offline   United_States
0
Reply With Quote
      05-31-2012, 08:28 PM   #91
lbjgh
Major
 
lbjgh's Avatar
 
Drives: 2013 AW X3 M-Sport
Join Date: Dec 2011
Location: North of Toronto

Posts: 1,395
iTrader: (0)

As you know thx3 I bitched about the crappy throttle response on the x3 before I bought my car. My 13 doesn't exhibit any delay so I can appreciate this tsb without having to deal with the bs. Good luck dealing with your dealership.
__________________
2013, AW, xDrive35i, M Sport Package, Technology Package, Dynamic Comfort Package, Premium Package, 3M Clear Bra, Euro foglight switch, a few coded fixes
lbjgh is offline   Canada
0
Reply With Quote
      05-31-2012, 09:13 PM   #92
WavyMD
New Member
 
Drives: 2012 AW X3 28i
Join Date: Apr 2012
Location: NY

Posts: 6
iTrader: (0)

Quote:
Originally Posted by rgx3 View Post
Dropped the car of at the dealer for a software update that specifically was for the above mentioned issue. The SA kept drilling me that if I didn't have this specific problem that the software update didn't apply. I kept referencing info from this forum and telling him that throttle response was abrubt after slowing down and speeding up and after stopping at a stop sign and then accelerating. He said they would drive it and see if it had the specific problem the software update was for. I argued that if there is a software update then why isn't it installed automatically? Oh, he also asked if I tried driving in sport mode? Should I have to? I feel like I'll go back tomorrow and they will have done nothing. I'm trying to remain cool but many of you have said the software update is the bomb and fixes the throttle response. It's frustrating to say the least.
Same thing happened to a buddy of mine, where the didn't want to do software update and kept giving me the run around. He just refused to pick up the car until the software update was done and the dealer finally did the update just to make him pick it up and he is much happier now. Good Luck with your dealer.
WavyMD is offline   United_States
0
Reply With Quote
      06-01-2012, 01:57 PM   #93
twistediron
Enlisted Member
 
Drives: Bmw X3 35i M Sport
Join Date: Mar 2011
Location: Toronto

Posts: 47
iTrader: (0)

Hrmm, I had it in for an unrelated problem and they had to apply a software update to it.

the loaner was an x1 28i with the n52, throttle response on that was fantastic in normal mode; better than post update n55

I also noticed they changed the colour of turning dsc off to a faint yellow you can't read in the indicator panel (at least with the enhanced display)
twistediron is offline   Canada
0
Reply With Quote
      06-01-2012, 10:53 PM   #94
rgx3
Enlisted Member
 
rgx3's Avatar
 
Drives: 2012 X3 xDrive 35i
Join Date: Nov 2011
Location: Western Washington State

Posts: 40
iTrader: (0)

Squeaky wheel gets the software update!

Quote:
Originally Posted by rgx3 View Post
Dropped the car of at the dealer for a software update that specifically was for the above mentioned issue. The SA kept drilling me that if I didn't have this specific problem that the software update didn't apply. I kept referencing info from this forum and telling him that throttle response was abrubt after slowing down and speeding up and after stopping at a stop sign and then accelerating. He said they would drive it and see if it had the specific problem the software update was for. I argued that if there is a software update then why isn't it installed automatically? Oh, he also asked if I tried driving in sport mode? Should I have to? I feel like I'll go back tomorrow and they will have done nothing. I'm trying to remain cool but many of you have said the software update is the bomb and fixes the throttle response. It's frustrating to say the least.
After getting a bunch of grief from the first service tech, I picked the car up from a second guy who said he knew all about the throttle response issue and assured me I will like the results. Viola! Smooth take offs are now super easy and throttle response issues seem to be a thing of the past. I will definately be contacting the first service tech and telling him when customers come in and complain about abrupt throttle response and mention a software update that may not seem to match based on the description, go ahead and just do it for them. Next!
rgx3 is offline   United_States
0
Reply With Quote
      06-01-2012, 11:17 PM   #95
Robocheme
Private
 
Drives: 2013 X3 28i, 2014 X1 sDrive
Join Date: Nov 2011
Location: Northern California

Posts: 76
iTrader: (0)

I just picked up my MY13 28i a couple of weeks ago. Do you think that I need to ask about this update or was it done at the factory?
Robocheme is offline   United_States
0
Reply With Quote
      06-02-2012, 12:00 AM   #96
April1
Love All
 
April1's Avatar
 
Drives: X3 28i 2011
Join Date: Nov 2011
Location: San Francisco

Posts: 738
iTrader: (1)

Send a message via Yahoo to April1
Quote:
Originally Posted by Robocheme View Post
I just picked up my MY13 28i a couple of weeks ago. Do you think that I need to ask about this update or was it done at the factory?
It's already imemented in 2013.
April1 is offline   United_States
0
Reply With Quote
      06-04-2012, 02:58 PM   #97
Chalky White
Private First Class
 
Drives: 2006 e90, 325i
Join Date: Dec 2005
Location: atlanta

Posts: 131
iTrader: (0)

Garage List
2006 325i  [0.00]
Follow-up after software update: I noticed that after filling up my tank, the fuel level indicator (which used to be spot-on accurate), now is not at all accurate. After fill up, it may only show 1/2 full. If I drive around a lot, it eventually creeps up to full. But if I fill up, go home and park, start it up the next morning, it still shows only half full.

It appears that the only way to get an accurate reading is to drive around until it gets to full, then it's fine. Any one else have a similar issue?
__________________
12/5/13 PCD Delivery of X3 3.5i, Alpine, Chestnut, Premium, Tech, Heated Seats, BMW Apps

2006 325i, Sparkling, Grey, Xenons, Premium, Heated, Comfort (SOLD)
Chalky White is offline  
0
Reply With Quote
      06-04-2012, 04:13 PM   #98
April1
Love All
 
April1's Avatar
 
Drives: X3 28i 2011
Join Date: Nov 2011
Location: San Francisco

Posts: 738
iTrader: (1)

Send a message via Yahoo to April1
Quote:
Originally Posted by Chalky White View Post
Follow-up after software update: I noticed that after filling up my tank, the fuel level indicator (which used to be spot-on accurate), now is not at all accurate. After fill up, it may only show 1/2 full. If I drive around a lot, it eventually creeps up to full. But if I fill up, go home and park, start it up the next morning, it still shows only half full.

It appears that the only way to get an accurate reading is to drive around until it gets to full, then it's fine. Any one else have a similar issue?
No, I didn't see this issue.
April1 is offline   United_States
0
Reply With Quote
      06-04-2012, 04:15 PM   #99
lbjgh
Major
 
lbjgh's Avatar
 
Drives: 2013 AW X3 M-Sport
Join Date: Dec 2011
Location: North of Toronto

Posts: 1,395
iTrader: (0)

This sounds like an unrelated fault.

Quote:
Originally Posted by Chalky White View Post
Follow-up after software update: I noticed that after filling up my tank, the fuel level indicator (which used to be spot-on accurate), now is not at all accurate. After fill up, it may only show 1/2 full. If I drive around a lot, it eventually creeps up to full. But if I fill up, go home and park, start it up the next morning, it still shows only half full.

It appears that the only way to get an accurate reading is to drive around until it gets to full, then it's fine. Any one else have a similar issue?
__________________
2013, AW, xDrive35i, M Sport Package, Technology Package, Dynamic Comfort Package, Premium Package, 3M Clear Bra, Euro foglight switch, a few coded fixes
lbjgh is offline   Canada
0
Reply With Quote
      06-04-2012, 04:47 PM   #100
Chalky White
Private First Class
 
Drives: 2006 e90, 325i
Join Date: Dec 2005
Location: atlanta

Posts: 131
iTrader: (0)

Garage List
2006 325i  [0.00]
Quote:
Originally Posted by lbjgh View Post
This sounds like an unrelated fault.
I noticed this as soon as I left the dealership. I went and got gas and on the way home, wondered why the indicator was so low.

I am dreading a trip back to the stealership, they just had it for two weeks while they worked on fixing the crappy factory paint job on my car.
__________________
12/5/13 PCD Delivery of X3 3.5i, Alpine, Chestnut, Premium, Tech, Heated Seats, BMW Apps

2006 325i, Sparkling, Grey, Xenons, Premium, Heated, Comfort (SOLD)
Chalky White is offline  
0
Reply With Quote
      06-04-2012, 05:18 PM   #101
Want the thrill
Major
 
Drives: X3 35i
Join Date: Mar 2011
Location: MI

Posts: 1,103
iTrader: (1)

Garage List
2011 X3 35i  [3.88]
Chalky White, there is a service bulletin out for what you are describing:

http://www.automd.com/tsb/bulletin_b330100/

Hope that helps!
Want the thrill is offline  
0
Reply With Quote
      06-05-2012, 08:50 AM   #102
Docray1
Private
 
Drives: 2007 BMW 335 Convertible
Join Date: Oct 2006
Location: Detroit, MI

Posts: 68
iTrader: (0)

Quote:
Originally Posted by Chalky White View Post
I noticed this as soon as I left the dealership. I went and got gas and on the way home, wondered why the indicator was so low.

I am dreading a trip back to the stealership, they just had it for two weeks while they worked on fixing the crappy factory paint job on my car.
Mine is also not registering completely "Full" after refueling. And it happened right after my software was updated as well.
Docray1 is offline  
0
Reply With Quote
      06-05-2012, 08:55 AM   #103
Chalky White
Private First Class
 
Drives: 2006 e90, 325i
Join Date: Dec 2005
Location: atlanta

Posts: 131
iTrader: (0)

Garage List
2006 325i  [0.00]
Quote:
Originally Posted by Want the thrill View Post
Chalky White, there is a service bulletin out for what you are describing:

http://www.automd.com/tsb/bulletin_b330100/

Hope that helps!
Thanks! I have informed the stealer about this update and will schedule a time, yet again, to take in my car to have, yet another, update.
__________________
12/5/13 PCD Delivery of X3 3.5i, Alpine, Chestnut, Premium, Tech, Heated Seats, BMW Apps

2006 325i, Sparkling, Grey, Xenons, Premium, Heated, Comfort (SOLD)
Chalky White is offline  
0
Reply With Quote
      06-05-2012, 03:41 PM   #104
alekseyz
Registered
 
Drives: 97 M3/4, 02 330CiC, 12 X3 3.5i
Join Date: Jan 2012
Location: Maryland, USA

Posts: 2
iTrader: (0)

I had the update done yesterday at Tischer BMW at Silver Spring, MD. Brought the car in at 9:00am and picked up my car at 5pm. Excellent service, as always with them. The SA did not question anything, wrote up service request for hesitation, took my printout of the SB, and said that the update will be applied if allowed for my vehicle. The ticket stated "...applied software update...".
Definitely felt the difference right away. The acceleration curve is much better. It is even more fun to drive now, it feels more springy and alive on takeoffs.
Transmission shifts smoother as well.
I noticed different sound (instead of whoosh) when unlocking the doors.
Fuel economy did not become worse.
Did not get a chance to refuel, so no comment on fuel gauge.
Steering feels lighter when going slow.
alekseyz is offline  
0
Reply With Quote
      06-05-2012, 07:38 PM   #105
bigcat_lu
New Member
 
Drives: bmw x3
Join Date: Nov 2011
Location: usa

Posts: 5
iTrader: (0)

new sports config

Quote:
Originally Posted by Chalky White View Post
I noticed a new option in settings that lets me configure what happens when I shift into sport mode. I can pick sport drivetrain and chassis, sport drivetrain only, or sport chassis only. Pretty sure that wasn't there before?
Your config seems didn't have sports activity package/DHP so the 2012 x3 35i should not have the sports toggle. How did you actually use this new sports config? I think DS mode should only affect drivetran.

Mine is 2012 x3 35i without sports/DHP. I'm wondering whether I should get the upgrade, since people reports lighter steering in normal mode. The normal setting is then different before/after the upgrade. If I couldn't activate sport mode, I'll end up with such lighter steering all the time. Anyone have experience how to activate sport mode in non sports/DHP after the upgrade?
bigcat_lu is offline  
0
Reply With Quote
      06-05-2012, 11:10 PM   #106
jdavid2
Enlisted Member
 
Drives: 2011 X3 35i White
Join Date: Oct 2011
Location: Los Angeles, CA

Posts: 45
iTrader: (0)

Quote:
Originally Posted by bigcat_lu View Post
Your config seems didn't have sports activity package/DHP so the 2012 x3 35i should not have the sports toggle. How did you actually use this new sports config? I think DS mode should only affect drivetran.

Mine is 2012 x3 35i without sports/DHP. I'm wondering whether I should get the upgrade, since people reports lighter steering in normal mode. The normal setting is then different before/after the upgrade. If I couldn't activate sport mode, I'll end up with such lighter steering all the time. Anyone have experience how to activate sport mode in non sports/DHP after the upgrade?
I have a 2011 35i without sport or DHP and after the update I now have the Sports setting option under vehicle settings but I don't think it does anything. I was hoping that when selecting MS mode using the shifter that it would also tighten up the steering but it doesn't. The steering has definitely loosened up when driving at highway speeds. It's is much less sensitive when driving straight or making small corrections/turns, I now wish I had sport mode to tighten up the steering.
jdavid2 is offline  
0
Reply With Quote
      06-06-2012, 06:42 AM   #107
ATX78703
Captain
 
Drives: 2014 335i
Join Date: Jul 2011
Location: Austin, TX

Posts: 996
iTrader: (0)

Are there any similar software updates for the throttle lag in the x5xdrive35i? This is a well documented complaint on both the f10, e70 forums.
__________________
2014 335i RWD: ZMM, ZDA, ZDH, ZPP, ZTP, 2NH, 2TB, 5DL; Z4A MPPK; AW ext / VB int

2014 ML350: P01, R33, 297, 319, 846, 864, 889, 996; LB ext / AB int
ATX78703 is offline  
0
Reply With Quote
      06-07-2012, 10:05 PM   #108
paul386
Second Lieutenant
 
Drives: 2011 X3 35i Jet Black
Join Date: Oct 2009
Location: Florida

Posts: 274
iTrader: (0)

I had my software updated and it make a major difference. As many have reported, the standard transmission setting is fabulous and is reminds me of the former sports mode. The throttle lurch is completely gone and the oscillations experienced at start-up sometimes no longer happen. The transmission also shifts noticeably harder and faster in sports mode and there is a slight "blimp" on downshifting.

There are also many "Easter Eggs" to be found across the iDrive and dash from the software update. I'm very happy.
paul386 is offline  
0
Reply With Quote
      06-08-2012, 04:42 AM   #109
Nahoa
Lieutenant Colonel
 
Drives: F25 35i Mineral Silver/Black
Join Date: May 2008
Location: Virginia

Posts: 1,876
iTrader: (0)

Mine's in for rear brakes and this software update. Took a long time to convince them of the software update and still not sure they're going to do it.

Had an appointment for Tuesday with a loaner. Arrived and they said, "no loaner". So, what did they expect me to do to get to work that day after planning with the expectation of a loaner? They explained that the appointment was really just an appointment to sit and talk to the SA about the car's problem and not to leave the car -- what?? Since when? Now they've had the car three days and have called each day to report they've been a little backed up (and no, I didn't recommend fiber) so they haven't even started working on the car yet. Why make an appointment for a repair if you're so behind you can't do the repair? That sounds like you don't really have an appointment available; schedule me in when you can actually do the work!

Anyway, I've never been bothered by the "take off lag" issue. I have experienced the start-up oscillation, but only over the last few months. Not sure what changed. I did experience the "bottoming out" on deceleration and transition to acceleration where the response is flat, forcing you to keep pressing to try to get it going and then it finally launches. So, curious to see what it's like if they actually do the software install.
__________________
Nahoa is offline   United_States
0
Reply With Quote
      06-08-2012, 09:04 AM   #110
Chalky White
Private First Class
 
Drives: 2006 e90, 325i
Join Date: Dec 2005
Location: atlanta

Posts: 131
iTrader: (0)

Garage List
2006 325i  [0.00]
Quote:
Originally Posted by Nahoa View Post
Mine's in for rear brakes and this software update. Took a long time to convince them of the software update and still not sure they're going to do it.

Had an appointment for Tuesday with a loaner. Arrived and they said, "no loaner". So, what did they expect me to do to get to work that day after planning with the expectation of a loaner? They explained that the appointment was really just an appointment to sit and talk to the SA about the car's problem and not to leave the car -- what?? Since when? Now they've had the car three days and have called each day to report they've been a little backed up (and no, I didn't recommend fiber) so they haven't even started working on the car yet. Why make an appointment for a repair if you're so behind you can't do the repair? That sounds like you don't really have an appointment available; schedule me in when you can actually do the work!

Anyway, I've never been bothered by the "take off lag" issue. I have experienced the start-up oscillation, but only over the last few months. Not sure what changed. I did experience the "bottoming out" on deceleration and transition to acceleration where the response is flat, forcing you to keep pressing to try to get it going and then it finally launches. So, curious to see what it's like if they actually do the software install.
Sounds like you either need a new service department or a phone call with BMW NA.
__________________
12/5/13 PCD Delivery of X3 3.5i, Alpine, Chestnut, Premium, Tech, Heated Seats, BMW Apps

2006 325i, Sparkling, Grey, Xenons, Premium, Heated, Comfort (SOLD)
Chalky White is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:16 AM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST