BMW X3 Forum
BMW X3 Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
XBimmers | BMW X3 Forum > BMW X3 Forums | F25 (2011 - Current) > Second Generation BMW X3 General Forum » SI B24 02 12 - throttle lag (and steering pull fix)?

Post Reply
 
Thread Tools Search this Thread
      05-11-2012, 03:23 PM   #45
lbjgh
Major
Canada
24

 
lbjgh's Avatar
 
Drives: 2013 AW X3 M-Sport
Join Date: Dec 2011
Location: North of Toronto


Posts: 1,461
iTrader: (0)

I hate to beat a dead horse but there was a problem or BMW wouldn't have updated the software.

The defect wouldn't be acceptable on the steering system or braking system so why would it be acceptable on the accelerator (which by the way is a safety feature too)?

Quote:
Originally Posted by April1 View Post
I will not say that the old programming was defective but yes now the update has totally changed the way it responds at low speeds. If you want to have fun, go for the update, I didnt notice any change in mpg.
Appreciate 0
      05-11-2012, 03:29 PM   #46
xDrive35i
Lieutenant Colonel
United_States
43

 
Drives: Porsche Macan S
Join Date: Feb 2011
Location: Chicago


Posts: 1,771
iTrader: (0)

Quote:
Originally Posted by lbjgh
I hate to beat a dead horse but there was a problem or BMW wouldn't have updated the software.

The defect wouldn't be acceptable on the steering system or braking system so why would it be acceptable on the accelerator (which by the way is a safety feature too)?

Quote:
Originally Posted by April1 View Post
I will not say that the old programming was defective but yes now the update has totally changed the way it responds at low speeds. If you want to have fun, go for the update, I didnt notice any change in mpg.
It wasn't a defect it was a poor decision.
Appreciate 0
      05-11-2012, 10:36 PM   #47
Adguytx
AdGuyTX
United_States
0

 
Drives: Infiniti G37
Join Date: Mar 2012
Location: Houston, TX


Posts: 7
iTrader: (0)

I purchased a 2012 x3 28i at the beginning of April. Is this update needed on my car as well? After having it for a month I'm still finding it difficult to start from a complete stop without giving myself and anyone else whiplash. I'm taking it in on Monday to have chrome tips put on the exhaust pipes. Should I bring it up when dropping the car off? I'm already set to have a loaner.
Appreciate 0
      05-11-2012, 10:43 PM   #48
lbjgh
Major
Canada
24

 
lbjgh's Avatar
 
Drives: 2013 AW X3 M-Sport
Join Date: Dec 2011
Location: North of Toronto


Posts: 1,461
iTrader: (0)

Hey it's your car... but if it was my car I'd have it fixed.

The acceleration on my 2013 car is smooth and linear.

Quote:
Originally Posted by Adguytx View Post
I purchased a 2012 x3 28i at the beginning of April. Is this update needed on my car as well? After having it for a month I'm still finding it difficult to start from a complete stop without giving myself and anyone else whiplash. I'm taking it in on Monday to have chrome tips put on the exhaust pipes. Should I bring it up when dropping the car off? I'm already set to have a loaner.
Appreciate 0
      05-13-2012, 03:26 AM   #49
S1000RRPilot
New Member
United_States
2

 
Drives: '12 X3 35i M-Sport Carbon Blk
Join Date: Jan 2012
Location: California, USA


Posts: 11
iTrader: (0)

I just got the update and have only been driving it just a little since I got the update a day and a half ago.

Unfortunately, so far for me, I don't feel any real improvement in any mode (Norm,Sp,SP+). If there is...it's subtle but still can't feel the difference yet. Maybe just need to drive it a bit to really see.

I first went in there for the throttle delay issue, and immediately went on a drive with the shop foreman. He sort of acknowledged the delay, but then he started making excuses like, "...well it's XDrive..." and "...it's turbo lag" but said he'll still look into it.

Pfft! Whatever...

So they call me back up later giving me the "operating as normal". I sent my service advisor information about this thread, but when I went to pick up car, they said it has the newest, available software and updates. So I get the SIB number mentioned here and ask him to look it up. He looks at it, prints it out, goes and talks to the tech, and they agreed the update may address the problem I mentioned.

Well they say they installed it, but like I said, so far not much noticeable difference, but will keep on driving it and will report back if anything has changed.

Any way to tell that you absolutely have the update? I'm a little skeptical about whether or not the update was really applied.
__________________
Past: 10 Subaru STi SE, 08 E92 335i, 06 E90 330i, 04 Subaru STi, 02 Subaru WRX, others
Bikes: 08 BMW K1300S, 08 Yamaha FJR1300, 06 CBR1000RR, 95 CBR900RR, 92 CBR600F2
Appreciate 0
      05-13-2012, 07:35 AM   #50
lbjgh
Major
Canada
24

 
lbjgh's Avatar
 
Drives: 2013 AW X3 M-Sport
Join Date: Dec 2011
Location: North of Toronto


Posts: 1,461
iTrader: (0)

Does moderate acceleration result in a pause then whiplash?

Other than the notes on the service work order I don't know.
Appreciate 0
      05-13-2012, 10:34 AM   #51
April1
Love All
United_States
16

 
April1's Avatar
 
Drives: X3 28i 2011
Join Date: Nov 2011
Location: San Francisco


Posts: 739
iTrader: (2)

Send a message via Yahoo to April1
Quote:
Originally Posted by S1000RRPilot View Post
I just got the update and have only been driving it just a little since I got the update a day and a half ago.

Unfortunately, so far for me, I don't feel any real improvement in any mode (Norm,Sp,SP+). If there is...it's subtle but still can't feel the difference yet. Maybe just need to drive it a bit to really see.

I first went in there for the throttle delay issue, and immediately went on a drive with the shop foreman. He sort of acknowledged the delay, but then he started making excuses like, "...well it's XDrive..." and "...it's turbo lag" but said he'll still look into it.

Pfft! Whatever...

So they call me back up later giving me the "operating as normal". I sent my service advisor information about this thread, but when I went to pick up car, they said it has the newest, available software and updates. So I get the SIB number mentioned here and ask him to look it up. He looks at it, prints it out, goes and talks to the tech, and they agreed the update may address the problem I mentioned.

Well they say they installed it, but like I said, so far not much noticeable difference, but will keep on driving it and will report back if anything has changed.

Any way to tell that you absolutely have the update? I'm a little skeptical about whether or not the update was really applied.
1. You don't have to drive for days to figure out the difference, you should know instantly.

2. I don't know if there is a way to find out if an update was really applied to your X3.

3. My X3 didn't have Sport but now after update I see three new settings for Sport.

4. My mpg average values were reset as if it's a new X3.

Last edited by April1; 05-13-2012 at 10:39 AM.
Appreciate 0
      05-13-2012, 12:12 PM   #52
Beyu
Lieutenant
United_States
5

 
Beyu's Avatar
 
Drives: 135i
Join Date: Feb 2011
Location: WA


Posts: 579
iTrader: (0)

Quote:
Originally Posted by S1000RRPilot View Post
I just got the update and have only been driving it just a little since I got the update a day and a half ago.

Unfortunately, so far for me, I don't feel any real improvement in any mode (Norm,Sp,SP+). If there is...it's subtle but still can't feel the difference yet. Maybe just need to drive it a bit to really see.

I first went in there for the throttle delay issue, and immediately went on a drive with the shop foreman. He sort of acknowledged the delay, but then he started making excuses like, "...well it's XDrive..." and "...it's turbo lag" but said he'll still look into it.

Pfft! Whatever...

So they call me back up later giving me the "operating as normal". I sent my service advisor information about this thread, but when I went to pick up car, they said it has the newest, available software and updates. So I get the SIB number mentioned here and ask him to look it up. He looks at it, prints it out, goes and talks to the tech, and they agreed the update may address the problem I mentioned.

Well they say they installed it, but like I said, so far not much noticeable difference, but will keep on driving it and will report back if anything has changed.

Any way to tell that you absolutely have the update? I'm a little skeptical about whether or not the update was really applied.
You should feel a large difference between pre-updated "normal mode" and post-updated "normal mode," "sport mode" is less noticeable imo. In the Motor Trend article they noticed a throttle lag when the X3 slows down then suddenly speeds up along with when suddenly accelerating from a stop. Since you said that you don't notice much of a difference then do you still experience the issues Motor Trend is describing?

A way that you can easily tell if they updated your software is by looking at the small screen between you speedo and tach, does it now say "mpg" in small, white letters by your red & blue mpg bar? Also, when you first turn on your car does it say in bold, red letters to fasten your seat belts?
Appreciate 0
      05-14-2012, 07:32 AM   #53
walendvay
Second Lieutenant
11

 
Drives: '11 F25 28i
Join Date: Jan 2011
Location: Pacific NW


Posts: 290
iTrader: (0)

great discussion. Quick report, car seems to drive outstanding with the new software update (7/2011 build date).
Appreciate 0
      05-14-2012, 11:36 AM   #54
ChitownX
Private
United_States
1

 
Drives: 11 CB X3 35i MS; 07 BS M Coupé
Join Date: Apr 2011
Location: Chicago


Posts: 84
iTrader: (0)

Quote:
Originally Posted by Beyu View Post
You should feel a large difference between pre-updated "normal mode" and post-updated "normal mode," "sport mode" is less noticeable imo. In the Motor Trend article they noticed a throttle lag when the X3 slows down then suddenly speeds up along with when suddenly accelerating from a stop. Since you said that you don't notice much of a difference then do you still experience the issues Motor Trend is describing?

A way that you can easily tell if they updated your software is by looking at the small screen between you speedo and tach, does it now say "mpg" in small, white letters by your red & blue mpg bar? Also, when you first turn on your car does it say in bold, red letters to fasten your seat belts?
Interesting, I thought the "mpg" was new but wasn't certain. You know confirmed it. Thanks
Appreciate 0
      05-16-2012, 12:21 AM   #55
S1000RRPilot
New Member
United_States
2

 
Drives: '12 X3 35i M-Sport Carbon Blk
Join Date: Jan 2012
Location: California, USA


Posts: 11
iTrader: (0)

Quote:
Originally Posted by Beyu View Post
You should feel a large difference between pre-updated "normal mode" and post-updated "normal mode," "sport mode" is less noticeable imo. In the Motor Trend article they noticed a throttle lag when the X3 slows down then suddenly speeds up along with when suddenly accelerating from a stop. Since you said that you don't notice much of a difference then do you still experience the issues Motor Trend is describing?

A way that you can easily tell if they updated your software is by looking at the small screen between you speedo and tach, does it now say "mpg" in small, white letters by your red & blue mpg bar? Also, when you first turn on your car does it say in bold, red letters to fasten your seat belts?
Hi all, thanks for the responses. Yeah, I've got the Fasten your seatbelt in RED and the little MPG right under the left side of the MPG bar. So if that's a good indicator, then yes I got the update.

Still there's no appreciable difference in acceleration from stop. Still the same delay in normal and sport modes.

__________________
Past: 10 Subaru STi SE, 08 E92 335i, 06 E90 330i, 04 Subaru STi, 02 Subaru WRX, others
Bikes: 08 BMW K1300S, 08 Yamaha FJR1300, 06 CBR1000RR, 95 CBR900RR, 92 CBR600F2
Appreciate 0
      05-16-2012, 12:36 AM   #56
lbjgh
Major
Canada
24

 
lbjgh's Avatar
 
Drives: 2013 AW X3 M-Sport
Join Date: Dec 2011
Location: North of Toronto


Posts: 1,461
iTrader: (0)

There is something fishy... there is no delay in my '13 model and others who have had the update report a dramatic improvement.

Quote:
Originally Posted by S1000RRPilot View Post
Hi all, thanks for the responses. Yeah, I've got the Fasten your seatbelt in RED and the little MPG right under the left side of the MPG bar. So if that's a good indicator, then yes I got the update.

Still there's no appreciable difference in acceleration from stop. Still the same delay in normal and sport modes.

Appreciate 0
      05-16-2012, 12:45 AM   #57
April1
Love All
United_States
16

 
April1's Avatar
 
Drives: X3 28i 2011
Join Date: Nov 2011
Location: San Francisco


Posts: 739
iTrader: (2)

Send a message via Yahoo to April1
Quote:
Originally Posted by lbjgh View Post
There is something fishy... there is no delay in my '13 model and others who have had the update report a dramatic improvement.
Update is not for 2013 models.
Appreciate 0
      05-16-2012, 04:16 PM   #58
smovva
New Member
United_States
1

 
Drives: F25 2011 X3 3.5
Join Date: Nov 2011
Location: Florida


Posts: 26
iTrader: (0)

Mine is a 5/2011 build and it has the white mpg letters (when headlights are on, and red when the lights are off) and it does not have the software upgrade (actually never seen the dealer since I bought it a year ago!). It does not have the message to fasten your seatbelt though so that message may genuinely be a sign of new software than what I have. I am scheduled to visit the dealer tomorrow for the upgrade so I will post back on any other changes I notice.

Cheers

Quote:
Originally Posted by Beyu View Post
You should feel a large difference between pre-updated "normal mode" and post-updated "normal mode," "sport mode" is less noticeable imo. In the Motor Trend article they noticed a throttle lag when the X3 slows down then suddenly speeds up along with when suddenly accelerating from a stop. Since you said that you don't notice much of a difference then do you still experience the issues Motor Trend is describing?

A way that you can easily tell if they updated your software is by looking at the small screen between you speedo and tach, does it now say "mpg" in small, white letters by your red & blue mpg bar? Also, when you first turn on your car does it say in bold, red letters to fasten your seat belts?
Appreciate 0
      05-16-2012, 09:23 PM   #59
Radioactive
Captain
United_States
9

 
Drives: '11 X3 28i '10 535i '04 325i
Join Date: Mar 2011
Location: San Diego


Posts: 659
iTrader: (0)

This should be interesting. Going to dealer for first service tomorrow and hopefully the update. Build date is 4/2011. I already have the "mpg" under the eff. dyna. bar in white and red. Seat belt message is also white and red.
Appreciate 0
      05-17-2012, 11:44 AM   #60
X3Factor
New Member
Canada
2

 
Drives: 2012 X3 35i - M Sport - Loaded
Join Date: Dec 2011
Location: Montreal


Posts: 8
iTrader: (0)

Garage List
2012 BMW X3 35i  [0.00]
Hi,

I'm in Montreal, QC Canada and the guy is telling me that the SIB-24-02-12 only applies to US cars, is it true or he is kidding me ?

Do you know where i can find this TSB ?

Thanks
Appreciate 0
      05-17-2012, 12:24 PM   #61
lbjgh
Major
Canada
24

 
lbjgh's Avatar
 
Drives: 2013 AW X3 M-Sport
Join Date: Dec 2011
Location: North of Toronto


Posts: 1,461
iTrader: (0)

The throttle issue is not restricted to the USA... Time to find a new dealership.
Appreciate 0
      05-17-2012, 01:50 PM   #62
April1
Love All
United_States
16

 
April1's Avatar
 
Drives: X3 28i 2011
Join Date: Nov 2011
Location: San Francisco


Posts: 739
iTrader: (2)

Send a message via Yahoo to April1
Quote:
Originally Posted by X3Factor View Post
Hi,

I'm in Montreal, QC Canada and the guy is telling me that the SIB-24-02-12 only applies to US cars, is it true or he is kidding me ?

Do you know where i can find this TSB ?

Thanks
Ask them to show the doc which shows that the update is only applicable to US X3s.

If you are facing the throttle delays too and want the X3 to be more responsive, pursue it hard with SA. They try to avoid it as it takes about 6 hours of their programming time.
Appreciate 0
      05-17-2012, 08:58 PM   #63
jlr_1304
Private First Class
Canada
3

 
jlr_1304's Avatar
 
Drives: none
Join Date: Apr 2011
Location: Canada


Posts: 160
iTrader: (0)

Quote:
Originally Posted by X3Factor View Post
Hi,

I'm in Montreal, QC Canada and the guy is telling me that the SIB-24-02-12 only applies to US cars, is it true or he is kidding me ?

Do you know where i can find this TSB ?

Thanks
my montreal south shore dealer made it last week. Your dealer doesnt know sh!t or dont want to make the upgrade.
Appreciate 0
      05-18-2012, 12:48 PM   #64
rgx3
Enlisted Member
United_States
1

 
rgx3's Avatar
 
Drives: 2012 X3 xDrive 35i
Join Date: Nov 2011
Location: Western Washington State


Posts: 40
iTrader: (0)

Phantom Software Upgrade and Service Bulletin

Quote:
Originally Posted by X3Factor View Post
Hi,

I'm in Montreal, QC Canada and the guy is telling me that the SIB-24-02-12 only applies to US cars, is it true or he is kidding me ?

Do you know where i can find this TSB ?

Thanks
My dealer says the SIB is for a transmission problem and has nothing to do with throttle lag. I've asked about software updates but they haven't gotten back to me yet. It's interesting how some owners report getting the software update and others are confronted with "what software update?" I'm hoping I'm in the first group.
Appreciate 0
      05-18-2012, 01:39 PM   #65
Radioactive
Captain
United_States
9

 
Drives: '11 X3 28i '10 535i '04 325i
Join Date: Mar 2011
Location: San Diego


Posts: 659
iTrader: (0)

Quote:
Originally Posted by rgx3 View Post
My dealer says the SIB is for a transmission problem and has nothing to do with throttle lag. I've asked about software updates but they haven't gotten back to me yet. It's interesting how some owners report getting the software update and others are confronted with "what software update?" I'm hoping I'm in the first group.
Throttle movement and transmission are pretty much linked in the smooth timely movement of the vehicle. Dealer could tell me that the SIB was for a tail light, but if it fixed the lag problem, I'm good.

Mine is at the dealer as of yesterday. Funny thing happens everytime you go to the dealer for a fix. The drivers window which was really rattling a couple of days ago was almost quiet and the throttle response was good. But then on the off ramp; "the lag". I guess one out of two isn't bad!

I went to a new dealer and took a copy of the SIB. SA hadn't seen it and was going to give it to the shop foreman. I'm guessing that they're doing the update due to the length of time. Two days for just an oil change and a couple of little things would be quite long.
Appreciate 0
      05-18-2012, 02:38 PM   #66
smovva
New Member
United_States
1

 
Drives: F25 2011 X3 3.5
Join Date: Nov 2011
Location: Florida


Posts: 26
iTrader: (0)

I had better luck with my dealer. Went in told them throttle lag and rough idle and they went Oh that problem needs a software update, we will need the car overnight and here is a brand new (200 miles) 535i to tide you over until then. I am going to pick up my car later today and will report back on the idle and lag.

Quote:
Originally Posted by Radioactive View Post
Throttle movement and transmission are pretty much linked in the smooth timely movement of the vehicle. Dealer could tell me that the SIB was for a tail light, but if it fixed the lag problem, I'm good.

Mine is at the dealer as of yesterday. Funny thing happens everytime you go to the dealer for a fix. The drivers window which was really rattling a couple of days ago was almost quiet and the throttle response was good. But then on the off ramp; "the lag". I guess one out of two isn't bad!

I went to a new dealer and took a copy of the SIB. SA hadn't seen it and was going to give it to the shop foreman. I'm guessing that they're doing the update due to the length of time. Two days for just an oil change and a couple of little things would be quite long.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:18 PM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST