BMW X3 Forum
BMW X3 Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
XBimmers | BMW X3 Forum > BMW X3 Forums | F25 (2011 - Current) > Second Generation BMW X3 General Forum » Rear window recall?

Post Reply
 
Thread Tools Search this Thread
      10-03-2011, 09:44 PM   #1
walendvay
Second Lieutenant
 
Drives: '11 F25 28i
Join Date: Jan 2011
Location: Pacific NW

Posts: 283
iTrader: (0)

Rear window recall?

I received a letter in the mail today about a manufacturing defect in my rear window defroster and that I need the window replaced. What's the scoop on this?
walendvay is offline  
0
Reply With Quote
      10-03-2011, 09:52 PM   #2
Dukat
First Lieutenant
 
Dukat's Avatar
 
Drives: 2012 X3 35i
Join Date: Aug 2011
Location: NJ

Posts: 383
iTrader: (0)

Do you have a recall code in your notice?
__________________
2012 X3 35i | Mineral Silver | Oyster | Wave Wood
Packages | Sports | Cold Weather | Dynamic Handling | Premium | Technology | Premium Sound
Dukat is offline   United_States
0
Reply With Quote
      10-03-2011, 11:04 PM   #3
walendvay
Second Lieutenant
 
Drives: '11 F25 28i
Join Date: Jan 2011
Location: Pacific NW

Posts: 283
iTrader: (0)

No code in the letter... It is part of ongoing outgoing quality analysis states the letter.
walendvay is offline  
0
Reply With Quote
      10-04-2011, 08:52 AM   #4
mspringer
Enlisted Member
 
Drives: BMW X3 35i SAP/DHP
Join Date: May 2011
Location: NJ

Posts: 45
iTrader: (0)

Garage List
2002 BMW M3  [0.00]
2011 BMW X3 35i  [0.00]
Do you have a problem with yours? The inner 2/3rds of mine works fine, but the outer portion, where the spacing between elements gets larger, doesn't defog and I assume there is some kind of connectivity problem to those elements. It hasn't been enough of an issue yet to take it in to get it looked at but as winter approaches I will do so.

Marty
mspringer is online now   United_States
0
Reply With Quote
      10-05-2011, 12:07 PM   #5
MattUK
Captain Unsensible
 
Drives: 2011 X3 3.0D MSport
Join Date: Sep 2011
Location: United Kingdom

Posts: 509
iTrader: (0)

Garage List
Interesting, I've noticed not the entire rear screen clears, and the side windows that appear to have elements in do not clear at all
MattUK is online now   United Kingdom
0
Reply With Quote
      10-05-2011, 06:38 PM   #6
LEDZEP
Lieutenant General
 
LEDZEP's Avatar
 
Drives: 2009 E70 & 2011 F25
Join Date: Jun 2005
Location: Area 51

Posts: 12,277
iTrader: (0)

Garage List
Interesting. Wonder if this is a design issue or limited to a batch or two. I hope mine isn't on the list. Replaced windows never fit quite like factory installs.
__________________


I think it is bad luck to be superstitious
LEDZEP is offline  
0
Reply With Quote
      10-05-2011, 09:35 PM   #7
Powerrunner
Second Lieutenant
 
Drives: BMW X3 35i 2011
Join Date: Mar 2011
Location: Naperville

Posts: 275
iTrader: (0)

First I have heard of this, is this tied to a specific date code?
Powerrunner is offline   United_States
0
Reply With Quote
      10-10-2011, 08:19 AM   #8
jc4ho
New Member
 
Drives: BMW
Join Date: Jul 2011
Location: Toronto

Posts: 26
iTrader: (0)

I noticed that the outer elements of my rear window doesn't defog as well.
jc4ho is offline  
0
Reply With Quote
      10-10-2011, 09:41 AM   #9
Ural
Private First Class
 
Ural's Avatar
 
Drives: 2011 X3 20d
Join Date: Aug 2011
Location: Istanbul,Turkey

Posts: 125
iTrader: (0)

I used the rear defroster for the first time this morning. It seemed to me it wasn't defogging fast enough. Maybe it's the design, maybe it was too short time I wasn't really paying attention . Anyway, following days I will monitor how it does its job .
Ural is offline  
0
Reply With Quote
      10-27-2011, 11:24 AM   #10
s1948
New Member
 
Drives: 2011 x3 xdrive 35i
Join Date: Oct 2011
Location: california

Posts: 12
iTrader: (0)

Quote:
Originally Posted by MattUK View Post
Interesting, I've noticed not the entire rear screen clears, and the side windows that appear to have elements in do not clear at all
Mine is more like in the middle and noticed there is a lot of glue that you can't get off close to the connection. Delivered July of 2011
s1948 is offline  
0
Reply With Quote
      10-29-2011, 03:16 PM   #11
Nahoa
Lieutenant Colonel
 
Drives: F25 35i Mineral Silver/Black
Join Date: May 2008
Location: Virginia

Posts: 1,876
iTrader: (0)

Aren't those extra elements that don't clear radio antenna sections? On mine they don't clear when the defroster is on. The small side windows on mine don't have any elements in them.
__________________
Nahoa is offline   United_States
0
Reply With Quote
      10-29-2011, 05:21 PM   #12
mspringer
Enlisted Member
 
Drives: BMW X3 35i SAP/DHP
Join Date: May 2011
Location: NJ

Posts: 45
iTrader: (0)

Garage List
2002 BMW M3  [0.00]
2011 BMW X3 35i  [0.00]
If so that's terrible engineering as it leaves a fairly substantial portion of an already small rear window uncleared. It's like looking through a tunnel when it's snowing or the window is fogged.
mspringer is online now   United_States
0
Reply With Quote
      10-31-2011, 02:21 AM   #13
teegee
New Member
 
Drives: F25 35i
Join Date: Apr 2011
Location: Tokyo

Posts: 15
iTrader: (0)

I had a mail about this too - had it replaced last week...
I'm in Japan, car received back in April, so probably manufactured in Feb / March. Didin't notice anything beforehand, haven't noticed anything since.
Had tint films on my last window, so they had to replace those too - as a result, the job took 3 days. Was given a crappy circa-1999 318i whilst the 35i was in the garage, was chimping at the bit to get it back!
teegee is offline  
0
Reply With Quote
      10-31-2011, 07:33 PM   #14
flash3
Captain
 
Drives: X3 28i
Join Date: Feb 2011
Location: NC

Posts: 652
iTrader: (0)

how do i get more information on this? is there a number i can call?
flash3 is offline  
0
Reply With Quote
      11-17-2011, 02:53 AM   #15
JimBeamer
Enlisted Member
 
JimBeamer's Avatar
 
Drives: F25 X3 2.0d SE
Join Date: Jul 2011
Location: Berkshire, UK

Posts: 36
iTrader: (0)

I've only had my X3 for 3 weeks, this morning I needed to clear the rear window as it had misted up and just the inner portion (where the wiper goes) cleared. The outer top corners stayed fogged up.

Is this right or is there an inssue?

Please help, before I go to the dealer
__________________
X3 2.0d SE Ordered W9, Build W38, Deliverd W43, Deep Sea Blue, Black Leather (Sports), Access, Cold Weather, Visibility, Media Pro, Auto, Sun Glass
JimBeamer is offline   England
0
Reply With Quote
      11-17-2011, 04:41 AM   #16
cooldude00
First Lieutenant
 
Drives: x3 2.0d
Join Date: Jan 2011
Location: uk

Posts: 312
iTrader: (0)

mine does the same thing which does look odd seeing how there looks to be heating elements in the outer areas of the window as well.

would be interested to know as well.
__________________
it's here!!!
cooldude00 is offline  
0
Reply With Quote
      11-17-2011, 06:29 AM   #17
Nahoa
Lieutenant Colonel
 
Drives: F25 35i Mineral Silver/Black
Join Date: May 2008
Location: Virginia

Posts: 1,876
iTrader: (0)

The parts in the corners are antennae and not part of the rear defroster. The rear defroster is only those portions where the wiper goes. Or, so I was told by the service center. Makes sense, though.
__________________
Nahoa is offline   United_States
0
Reply With Quote
      11-17-2011, 07:01 AM   #18
JimBeamer
Enlisted Member
 
JimBeamer's Avatar
 
Drives: F25 X3 2.0d SE
Join Date: Jul 2011
Location: Berkshire, UK

Posts: 36
iTrader: (0)

Quote:
Originally Posted by Nahoa View Post
The parts in the corners are antennae and not part of the rear defroster. The rear defroster is only those portions where the wiper goes. Or, so I was told by the service center. Makes sense, though.
Thanks for the info.
__________________
X3 2.0d SE Ordered W9, Build W38, Deliverd W43, Deep Sea Blue, Black Leather (Sports), Access, Cold Weather, Visibility, Media Pro, Auto, Sun Glass
JimBeamer is offline   England
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:29 PM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST