BMW X3 Forum
BMW X3 Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
XBimmers | BMW X3 Forum > BMW X3 Forums | F25 (2011 - Current) > Second Generation BMW X3 General Forum » 2-wk driving feelings

Post Reply
 
Thread Tools Search this Thread
      03-06-2014, 02:40 PM   #1
kwcbimmer
New Member
 
Drives: 2014 X3 28i
Join Date: Feb 2014
Location: ON, Canada

Posts: 14
iTrader: (0)

2-wk driving feelings

Got my X3 2-3 wks ago, like its power and acceleration on hwys...but have some small issues/questions:
1) as mentioned in the previous reply to a thread, the "HiFi" sound really dissapoint me;
2) slight "squeaking" noise from the mid-pillar;
3) feel vibrating from the steering wheel when it's around 50-60 km/h under light acceleration...feel like engine/transmission doesn't know where to go...it's struggling? I didn't feel it during test drive.
4) its around 11.5 L/100 Km (never reset it since pickup) about 40/60 hwy/local. Is it normal?

It's my first BMW, maybe I'm too sensitive, or something really wrong?
kwcbimmer is offline   Canada
0
Reply With Quote
      03-06-2014, 03:04 PM   #2
ianfp
Private First Class
 
ianfp's Avatar
 
Drives: X3 XDrive 20D M Sport
Join Date: Aug 2012
Location: UK

Posts: 181
iTrader: (0)

I am sorry you are having issues with your X3. I was not entirely happy with mine for perhaps 3 months when I bought it.
I am surprised that your HiFi isn't good. I think I have the standard business HiFi and I am really impressed by the sound quality. I did adjust bass and balance for my ears and I love it!
I am sure the squeaking noise is a simple fix.
Are you driving in 'comfort' mode, because the system will drop you to as low a gear as it can in order to save fuel. This can have the effect of feeling like the engine is laboring and it can be felt through the steering wheel. I am used to this on my car now, but if I want the engine to respond quicker, I flip the shift into sport mode and this normally puts it in a higher gear and lifts the revs.
Not sure about the economy? Mine is a diesel!
Hope you can resolve your problems and start to enjoy your car! I love mine now from a point where I was ready to sell it!
ianfp is offline   United Kingdom
0
Reply With Quote
      03-06-2014, 03:27 PM   #3
pokerface
Lieutenant Colonel
 
pokerface's Avatar
 
Drives: B8 A4 2.0T
Join Date: Apr 2006
Location: Toronto

Posts: 1,605
iTrader: (1)

I'm tracking at 11.3 roughly since we took delivery of the car a year ago. It's worse this winter because it has been especially cold.
__________________
F25 X3 N20:

2010 B8 A4 2.0T quattro (current)/
2013 F25 X3 x28 N20 (babymobile)
pokerface is online now   Canada
0
Reply With Quote
      03-06-2014, 07:08 PM   #4
The X Men
Lieutenant Colonel
 
Drives: 2012 535xi 2013 X3 35i
Join Date: Mar 2012
Location: MA

Posts: 1,780
iTrader: (0)

Quote:
Originally Posted by kwcbimmer View Post
Got my X3 2-3 wks ago, like its power and acceleration on hwys...but have some small issues/questions:
1) as mentioned in the previous reply to a thread, the "HiFi" sound really dissapoint me;
2) slight "squeaking" noise from the mid-pillar;
3) feel vibrating from the steering wheel when it's around 50-60 km/h under light acceleration...feel like engine/transmission doesn't know where to go...it's struggling? I didn't feel it during test drive.
4) its around 11.5 L/100 Km (never reset it since pickup) about 40/60 hwy/local. Is it normal?

It's my first BMW, maybe I'm too sensitive, or something really wrong?
If you like listening to loud music, you should have gotten the audio upgrade option. The standard audio is not bad, better than most other standard audio systems.
Get the dealer to look the squeak, maybe its a easy fix.
Its a BMW, you are suppose to feel the road.
Don't even look at the gas mileage computer before 5000 miles, 10000 km, as your car is still breaking in as far as gas mileage wise.
The X Men is offline  
0
Reply With Quote
      03-07-2014, 11:14 AM   #5
xDrive35i
Lieutenant Colonel
 
Drives: 2011 X3 35i
Join Date: Feb 2011
Location: Chicago

Posts: 1,639
iTrader: (0)

Quote:
Originally Posted by The X Men View Post
If you like listening to loud music, you should have gotten the audio upgrade option. The standard audio is not bad, better than most other standard audio systems.
Get the dealer to look the squeak, maybe its a easy fix.
Its a BMW, you are suppose to feel the road.
Don't even look at the gas mileage computer before 5000 miles, 10000 km, as your car is still breaking in as far as gas mileage wise.
He did get the audio upgrade...
__________________
2001 Audi A6 Allroad 2.7T (C5); 2005 Audi A6 4.2 Quattro (C6); 2005 BMW X5 4.4i (E53); 2008 BMW 535xi Sports Wagon (E61); 2011 BMW X3 xDrive35i (F25); 2009 Audi A4 3.2 Quattro Prestige (B8)
xDrive35i is offline   United_States
0
Reply With Quote
      03-07-2014, 11:54 AM   #6
pokerface
Lieutenant Colonel
 
pokerface's Avatar
 
Drives: B8 A4 2.0T
Join Date: Apr 2006
Location: Toronto

Posts: 1,605
iTrader: (1)

I don't quite remember the packaging on 2014 X3 28i Canadian Spec.. but on 2013.. the base stereo is a 5 speaker.. and would require the Executive Package to get the 676 HiFi. Much better.. but not great. US Spec gets 676 standard.
__________________
F25 X3 N20:

2010 B8 A4 2.0T quattro (current)/
2013 F25 X3 x28 N20 (babymobile)
pokerface is online now   Canada
0
Reply With Quote
      03-07-2014, 01:34 PM   #7
kwcbimmer
New Member
 
Drives: 2014 X3 28i
Join Date: Feb 2014
Location: ON, Canada

Posts: 14
iTrader: (0)

Quote:
Originally Posted by The X Men View Post
If you like listening to loud music, you should have gotten the audio upgrade option. The standard audio is not bad, better than most other standard audio systems.
Get the dealer to look the squeak, maybe its a easy fix.
Its a BMW, you are suppose to feel the road.
Don't even look at the gas mileage computer before 5000 miles, 10000 km, as your car is still breaking in as far as gas mileage wise.
-ya, I've got the best sound system available to Canadians on 28i...for the next level, I need up to 35i
-have called the dealer...gonna get them to look at the squeaking next Mon.
-I turely don't think it's the feeling of road...just want to know whether vibration at 50-60km/h at light acceleration is normal for all? if it is, I guess I have to live with it, or always put it in sport.
-it jumps to 11.6L/100km today. I'll keep monitoring it...it may be due to harsh winter here....ya, kinda start feeling Spring today
kwcbimmer is offline   Canada
0
Reply With Quote
      03-07-2014, 01:39 PM   #8
The X Men
Lieutenant Colonel
 
Drives: 2012 535xi 2013 X3 35i
Join Date: Mar 2012
Location: MA

Posts: 1,780
iTrader: (0)

Quote:
Originally Posted by kwcbimmer View Post
-ya, I've got the best sound system available to Canadians on 28i...for the next level, I need up to 35i
-have called the dealer...gonna get them to look at the squeaking next Mon.
-I turely don't think it's the feeling of road...just want to know whether vibration at 50-60km/h at light acceleration is normal for all? if it is, I guess I have to live with it, or always put it in sport.
-it jumps to 11.6L/100km today. I'll keep monitoring it...it may be due to harsh winter here....ya, kinda start feeling Spring today
Not sure what the option packages are in Canada. How mant watt is your sound system?
So you are saying that if you put the car in sport mode and cruise at 60km/h, the problem goes away?
The X Men is offline  
0
Reply With Quote
      03-09-2014, 07:48 PM   #9
kwcbimmer
New Member
 
Drives: 2014 X3 28i
Join Date: Feb 2014
Location: ON, Canada

Posts: 14
iTrader: (0)

Quote:
Originally Posted by The X Men View Post
Not sure what the option packages are in Canada. How mant watt is your sound system?
So you are saying that if you put the car in sport mode and cruise at 60km/h, the problem goes away?
Here is the sound system specs I got from BMW customer service:

HiFi speaker system, digital amplifier with vehicle-specific
equalizing, 205 W amplifier power, multi-channel.
12 loudspeakers:
- 1 centre tweeter in the instrument panel
- 1 centre midrange speaker in the instrument panel
- 2 tweeters in the front door trims
- 2 midrange speakers in the front door trims
- 2 central bass speakers underneath the front seats
- 2 tweeters in the rear door trims
- 2 midrange speakers in the rear door trims

I couldn't find Equalizer settings, though they said "digital amplifier with vehicle-specific equalizing". I can only adjust treble,bass,balance,and fader.
kwcbimmer is offline   Canada
0
Reply With Quote
      03-10-2014, 09:05 AM   #10
The X Men
Lieutenant Colonel
 
Drives: 2012 535xi 2013 X3 35i
Join Date: Mar 2012
Location: MA

Posts: 1,780
iTrader: (0)

This is the HK audio upgrade option in the US: Harman Kardon Surround Sound Audio system with vehicle-specific equalizing and powerful 600-watt amplifier; 16-speaker system includes 6 tweeters, 4 midrange speakers located in the door panels and 2 midrange speakers located under the rear shelf space, 2 bass speakers under front seats, 1 midrange center channel speaker and 1 tweeter located in the instrument cluster.

I believe your setup is standard in the US version of the F10.
The X Men is offline  
0
Reply With Quote
      03-10-2014, 01:59 PM   #11
AnandS
New Member
 
Drives: 2014 X3
Join Date: Feb 2014
Location: Calgary, AB

Posts: 17
iTrader: (0)

The audio in the Canadian X3 28i isn't good. Apparently MY2015 gets Harmon Kardon as an option. While the audio isn't in the same league as my wife's 2014 Kia, thanks to the Executive package the audio is way better than my mom's 2006 Mazda 3. I'll take that as a win.

Did you solve the vibration at 50-60 km/h? I haven't experienced that on my car. Perhaps you have a wheel out of balance, or ice/snow/mud packed inside a wheel.
AnandS is offline  
0
Reply With Quote
      03-10-2014, 05:53 PM   #12
ghostdog1108
New Member
 
Drives: 2014' X3 35i M SPORT
Join Date: Mar 2012
Location: Eau Claire, WI

Posts: 18
iTrader: (0)

Quote:
Originally Posted by kwcbimmer View Post
-ya, I've got the best sound system available to Canadians on 28i...for the next level, I need up to 35i
-have called the dealer...gonna get them to look at the squeaking next Mon.
-I turely don't think it's the feeling of road...just want to know whether vibration at 50-60km/h at light acceleration is normal for all? if it is, I guess I have to live with it, or always put it in sport.
-it jumps to 11.6L/100km today. I'll keep monitoring it...it may be due to harsh winter here....ya, kinda start feeling Spring today
Vibration is not normal. Get it checked.
__________________
2014 X3 35i / M SPORT/ BLACK SAPPHIRE
ghostdog1108 is offline  
0
Reply With Quote
      03-10-2014, 10:26 PM   #13
kwcbimmer
New Member
 
Drives: 2014 X3 28i
Join Date: Feb 2014
Location: ON, Canada

Posts: 14
iTrader: (0)

wrt. vibration, I got the dealer check it today. here is the "result":
Cause: Normal characteristic of the four cylinder engine.
Correction: Road test. verified complaint. slight vibration in body at 1500 rpm. checked all mounts. ok. compared to another X3 28i. found vehicle had same vibration as well. normal operation. and is a characteristic of the four cylinder engine.

DO YOU BELIEVE IT? anyone driving X3 28i has the same experience?
kwcbimmer is offline   Canada
0
Reply With Quote
      03-20-2014, 07:34 AM   #14
drivesmooth
Registered
 
Drives: X3 Xdrive 20D SE
Join Date: Mar 2014
Location: London

Posts: 3
iTrader: (0)

Quote:
Originally Posted by kwcbimmer View Post
wrt. vibration, I got the dealer check it today. here is the "result":
Cause: Normal characteristic of the four cylinder engine.
Correction: Road test. verified complaint. slight vibration in body at 1500 rpm. checked all mounts. ok. compared to another X3 28i. found vehicle had same vibration as well. normal operation. and is a characteristic of the four cylinder engine.

DO YOU BELIEVE IT? anyone driving X3 28i has the same experience?
same problem with my X3 20D and same answers from the dealer. looks like we just have to put up with bmw until many more people complain and they eventually acknowledge!!!
drivesmooth is offline  
0
Reply With Quote
      03-20-2014, 01:21 PM   #15
mge.92
SPEED RACER
 
mge.92's Avatar
 
Drives: X3 28I M SPORT
Join Date: Jul 2012
Location: Washington DC

Posts: 168
iTrader: (0)

I have a 2013 BMW X3 and it doesn't vibrate when I drive but when I first start it, it vibrates a little. It shouldn't be normal, try going to a different dealership or complain to the GM of the dealership. The mileage is normal like what a couple people have said, don't look at it for the first 5000 miles. Mine has horrible city mpg but has amazing highway mpg. Mine has 14 mpg average ( 16.8 L/100km ) with 90 percent city but I also have a very heavy foot. On the highway I get average of 29 mpg ( 8.11 L/ 100Km ). Hope things get sorted.
mge.92 is offline   United_States
0
Reply With Quote
      03-24-2014, 04:05 PM   #16
mosborn78108
Enlisted Member
 
Drives: 2013 Frozen Blue M3
Join Date: Apr 2013
Location: Kaiserslautern, Germany

Posts: 39
iTrader: (0)

Quote:
Originally Posted by mge.92
I have a 2013 BMW X3 and it doesn't vibrate when I drive but when I first start it, it vibrates a little. It shouldn't be normal, try going to a different dealership or complain to the GM of the dealership. The mileage is normal like what a couple people have said, don't look at it for the first 5000 miles. Mine has horrible city mpg but has amazing highway mpg. Mine has 14 mpg average ( 16.8 L/100km ) with 90 percent city but I also have a very heavy foot. On the highway I get average of 29 mpg ( 8.11 L/ 100Km ). Hope things get sorted.
I have a 2014 X3 x28i, no noticeable vibrations from steering wheel while driving. Only small vibration is on engine restart when at stop light.

Gas mileage, 2800km, 20.6mpg city (70%) 26mpg autobahn--currently stationed in Germany, but US service member.

For the issues you describe, continue to bug the dealer--go to the GM. In the US there are lemon laws and the vibration lowers the value which is one of the reasons for buy back if uncorrected

Ride comfort on trips is good.

One poster suggested that comfort selects lowest possible rpm in comfort mode, I've experienced in Eco mode but no vibration
__________________

Mike
------------------
2013 Frozen Blue M3, Akropovic Exhaust
2011 Mini Clubman S
mosborn78108 is offline   Germany
0
Reply With Quote
      03-25-2014, 12:25 PM   #17
kwcbimmer
New Member
 
Drives: 2014 X3 28i
Join Date: Feb 2014
Location: ON, Canada

Posts: 14
iTrader: (0)

Quote:
Originally Posted by mosborn78108 View Post
I have a 2014 X3 x28i, no noticeable vibrations from steering wheel while driving. Only small vibration is on engine restart when at stop light.

Gas mileage, 2800km, 20.6mpg city (70%) 26mpg autobahn--currently stationed in Germany, but US service member.

For the issues you describe, continue to bug the dealer--go to the GM. In the US there are lemon laws and the vibration lowers the value which is one of the reasons for buy back if uncorrected

Ride comfort on trips is good.

One poster suggested that comfort selects lowest possible rpm in comfort mode, I've experienced in Eco mode but no vibration
Thanks for the reply.

I'm currently dealing with them on the creaking issue. the dealer has identified the noise from rear doors, and tried to apply a type of lubricant. but the noise came back after two days. Now, they are going to replace the seal strips on the rear doors.

wrt. vibration, I'm going to try other dealers and also complain to BMW canada in the near future. do it one by one...as it takes a lot of time and I have kids to take care of
kwcbimmer is offline   Canada
0
Reply With Quote
      03-26-2014, 03:01 PM   #18
drivesmooth
Registered
 
Drives: X3 Xdrive 20D SE
Join Date: Mar 2014
Location: London

Posts: 3
iTrader: (0)

Quote:
Originally Posted by kwcbimmer View Post
Thanks for the reply.

I'm currently dealing with them on the creaking issue. the dealer has identified the noise from rear doors, and tried to apply a type of lubricant. but the noise came back after two days. Now, they are going to replace the seal strips on the rear doors.

wrt. vibration, I'm going to try other dealers and also complain to BMW canada in the near future. do it one by one...as it takes a lot of time and I have kids to take care of

I seems like not everyone is having vibration problem. I am going to take it to another dealer next week and see what happens. I am surprised they were able to prove me that it is a characteristic in all X3's. I will post the results next week.
drivesmooth is offline  
0
Reply With Quote
      03-26-2014, 09:58 PM   #19
richard in NC
Major
 
Drives: 2009 Z4 35i
Join Date: Jul 2009
Location: Charlotte, NC

Posts: 1,321
iTrader: (0)

Make sure all 4 tires are properly inflated. At least that they match side to side. I've been told that X-Drive is critical of tire diameter or it may compensate by brief single wheel braking causing the vibration issue. Sounds far fetched but it helped mine a lot.
__________________
2013 X3 35i, Vermillion Red/Sand Beige: MSport, Premium, Technology, Premium Sound, Hud, More...
2012 335is, Space Gray/Oyster-Black: DCT, 19s, Premium, Convenience, Nav, Heated Seats, More...
Gone '11 X5 50i, '09 Z4 35i, '08 550i, 06 X3, 06 650i, '02 M5, '99 540i
richard in NC is offline   United_States
0
Reply With Quote
      03-27-2014, 12:12 PM   #20
kwcbimmer
New Member
 
Drives: 2014 X3 28i
Join Date: Feb 2014
Location: ON, Canada

Posts: 14
iTrader: (0)

QUOTE=drivesmooth;15671623]I seems like not everyone is having vibration problem. I am going to take it to another dealer next week and see what happens. I am surprised they were able to prove me that it is a characteristic in all X3's. I will post the results next week.[/quote]
Thanks for the update. Please keep me posted.

Quote:
Originally Posted by richard in NC View Post
Make sure all 4 tires are properly inflated. At least that they match side to side. I've been told that X-Drive is critical of tire diameter or it may compensate by brief single wheel braking causing the vibration issue. Sounds far fetched but it helped mine a lot.
Good suggestion. I'll talk to my local dealer.

Yesterday's results on creaking noise repair: the dealer didn't replace the strips, as they found the lubricant previously applied had evaporated. So they applied CARBFLO, THIS TIME ON ALL FOUR DOORS. It looked greasy, and the dealer explained it would be absorbed. The noise has gone. It's the second day...keep my fingers crossed.
kwcbimmer is offline   Canada
0
Reply With Quote
      03-27-2014, 01:37 PM   #21
The X Men
Lieutenant Colonel
 
Drives: 2012 535xi 2013 X3 35i
Join Date: Mar 2012
Location: MA

Posts: 1,780
iTrader: (0)

Quote:
Originally Posted by kwcbimmer View Post
Good suggestion. I'll talk to my local dealer.

Yesterday's results on creaking noise repair: the dealer didn't replace the strips, as they found the lubricant previously applied had evaporated. So they applied CARBFLO, THIS TIME ON ALL FOUR DOORS. It looked greasy, and the dealer explained it would be absorbed. The noise has gone. It's the second day...keep my fingers crossed.
I remember reading about the creaking door problem and the lube repair, most of the time, the lube fix is only temp. If the remember right, the door need to be re-align.
The X Men is offline  
0
Reply With Quote
      04-01-2014, 11:13 AM   #22
drivesmooth
Registered
 
Drives: X3 Xdrive 20D SE
Join Date: Mar 2014
Location: London

Posts: 3
iTrader: (0)

took the care to another dealer; same result; characteristic of the vehicle!!!
given up all hopes and just use the sport mode for local driving


Quote:
Originally Posted by kwcbimmer View Post
QUOTE=drivesmooth;15671623]I seems like not everyone is having vibration problem. I am going to take it to another dealer next week and see what happens. I am surprised they were able to prove me that it is a characteristic in all X3's. I will post the results next week.
Thanks for the update. Please keep me posted.


Good suggestion. I'll talk to my local dealer.

Yesterday's results on creaking noise repair: the dealer didn't replace the strips, as they found the lubricant previously applied had evaporated. So they applied CARBFLO, THIS TIME ON ALL FOUR DOORS. It looked greasy, and the dealer explained it would be absorbed. The noise has gone. It's the second day...keep my fingers crossed.[/quote]
drivesmooth is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:32 PM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST