BMW X3 Forum
BMW X3 Forum
Welcome to the ultimate BMW X3 community.
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
XBimmers | BMW X3 Forum BMW X3 and X4 Forums | F25 (2011 - 2017) | F26 (2014 - Current) Second Generation BMW X3 General Forum Transmission Fault & more

Post Reply
 
Thread Tools Search this Thread
      08-21-2012, 05:48 AM   #1
Aaqui
New Member
1
Rep
15
Posts

Drives: X3
Join Date: Feb 2012
Location: Malta

iTrader: (0)

Transmission Fault & more

Hi all,

I am from Malta and have taken deliver of my F25 X3 20d around 3 months ago.

Unfortunately I am quite disappointed with my experience so far. The following is a summary of what I have been through so far:

1. The car has developed a "Transmission Fault" twice in these three months (see attached pic). The first time the dealer told me that this was nothing and that a simple restart would clear the error. In fact it does however I am not convinced of this explanation since I believe that something must be causing this fault.

2. From the first day that I took delivery I was hearing a rattling noise on the front right side suspension when going over certain road bumps/potholes (unfortunately the roads in Malta are not that great). After taking it to dealer they said that tightened some bolts (could not believe this!) and that the problem should have been resolved. However, it wasn't so I had to take the car back in and after a couple of days at the dealer they advised that they ordered some parts (I think they said a complete suspension system).

3. The lumbar support on the driver's seat does not work. This first started playing up but now it does not work at all.

The car is now due in at the dealer for the third time in three months on the 4th September.

The car is a joy to drive, however I did not expect all the above problems from my first BMW and quite honestly it ruined all the enjoyment that usually comes with a new car.

I wonder if anyone has experienced similar issues to the above. I am mostly concerned with the transmission fault as this seems to be something electronic related.

Thanks to all for any feedback and BTW great forum.

aaqui
Attached Images
 
Appreciate 0
      08-21-2012, 10:23 AM   #2
vojak
Private First Class
vojak's Avatar
United Kingdom
3
Rep
106
Posts

Drives: F25 35d M Sport
Join Date: Mar 2012
Location: North Lincs, UK

iTrader: (0)

The transmission fault happened with mine on the drive home after collection. Went (limped) back to the dealership for diagnosis. Was told that this can sometimes happen as the transmission/engine 'calibrates itself'
This wasnt too reassuring but I havent had a single problem after 3,600 miles so I'm not to concerned now.
Appreciate 0
      08-21-2012, 04:22 PM   #3
troggy1969
Lieutenant
United Kingdom
28
Rep
470
Posts

Drives: 335D MSport 2016
Join Date: Sep 2011
Location: Ludlow

iTrader: (0)

Garage List
Happened to mine too at 4500 miles.
Apart from the embarassment of being 3rd in line at the traffic lights and being unable to select a gear everything seemed ok once I switched off and re-started
Appreciate 0
      08-22-2012, 03:14 AM   #4
Aaqui
New Member
1
Rep
15
Posts

Drives: X3
Join Date: Feb 2012
Location: Malta

iTrader: (0)

Thanks for your feedback.

I have barely done 4,000 km and it happened twice.

A simple restart resolved the fault, but my main concern is if this persists and eventually develops into a permanent fault once the warranty period is over.

The I-drive system flags it as a 'fault' so I guess something must be wrong.

Anyway, now I have asked the dealer to give me a written report about it and I will take it from there.

Hopefully they will also resolve the rattling noise on the front end which is also very annoying and the lumbar support.
Appreciate 0
      08-22-2012, 04:16 AM   #5
sfax
Brigadier General
sfax's Avatar
United Kingdom
85
Rep
3,854
Posts

Drives: BMW X3 2011 F25
Join Date: Nov 2010
Location: Berkshire, UK

iTrader: (0)

Sorry to hear about your issues Aaqui. I have been to Malta a few times and driven a Fiat Panda hire car there once. Beautiful place but I can understand why you went for the X3 given some of the roads!
__________________

F25 xDrive20d SE __ professional multimedia package | dynamic package | climate package | 309s | xline | xenons | electric seats | folding mirrors | business speakers
Appreciate 0
      08-22-2012, 06:18 AM   #6
cooldude00
First Lieutenant
6
Rep
332
Posts

Drives: x3 2.0d
Join Date: Jan 2011
Location: uk

iTrader: (0)

says something about the build quality for the x3 i must admit... so far i've only had to replace the reversing camera but now seem to be picking up a whining noise on the steering wheel when turning at low speeds...

didn't have any such issues with my 5 series or z4 previously so a little disppointing.

hope the dealer resolves it to your satisfaction!
__________________
it's here!!!
Appreciate 0
      08-23-2012, 07:06 AM   #7
Aaqui
New Member
1
Rep
15
Posts

Drives: X3
Join Date: Feb 2012
Location: Malta

iTrader: (0)

Quote:
Originally Posted by sfax View Post
Sorry to hear about your issues Aaqui. I have been to Malta a few times and driven a Fiat Panda hire car there once. Beautiful place but I can understand why you went for the X3 given some of the roads!
That's right. I used to drive a Honda CRV and was actually going to replace it with an Audi TTS coupe until I had the chance to to drive an Audi A4 2.0T Convertible for a couple of months.

This made me change my mind for two reasons: 1. the roads in Malta do not allow you to enjoy driving a sporty vehicle. 2. With two young children such a car was very impractical and also uncomfortable for them at the back.

Having said this, the roads are getting better gradually with quite a few roads being rebuilt from scratch over the past months and also some others planned for the future.

That is why I opted for the X3 and chose this over the Audi Q5.
Appreciate 0
      08-23-2012, 07:15 AM   #8
Aaqui
New Member
1
Rep
15
Posts

Drives: X3
Join Date: Feb 2012
Location: Malta

iTrader: (0)

Quote:
Originally Posted by cooldude00 View Post
says something about the build quality for the x3 i must admit... so far i've only had to replace the reversing camera but now seem to be picking up a whining noise on the steering wheel when turning at low speeds...

didn't have any such issues with my 5 series or z4 previously so a little disppointing.

hope the dealer resolves it to your satisfaction!

I am actually quite disappointed with the build quality of the X3. I've had three separate issues in three months. I was looking forward to my first BMW and was actually counting the days until I took delivery but these problems have ruined all the fun.

As an update, the dealer called me today and informed me that a foreign BMW representative will be in Malta in September and he will be looking into my issues while here. Now I am booked for the 11th September.

Fingers crossed that these issues will be resolved once and for all.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 11:45 PM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST