BMW X3 Forum
BMW X3 Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
XBimmers | BMW X3 Forum > BMW X3 Forums | F25 (2011 - Current) > Second Generation BMW X3 General Forum » Mottled effect on rubber around windows.

Post Reply
 
Thread Tools Search this Thread
      05-16-2011, 09:42 AM   #1
durbana
New Member
 
Drives: F25 X3 2.0D/F20 Urban 1.6I
Join Date: May 2011
Location: Durban,South Africa

Posts: 10
iTrader: (0)

Mottled effect on rubber around windows.

I picked my 2.0d on Saturday, very satisfied but for the mottled effect on the rubber surrounds of the windows. Has anyone else have the same problem?
durbana is offline  
0
Reply With Quote
      05-16-2011, 11:18 AM   #2
pault
Private First Class
 
Drives: 2011 F25 35i
Join Date: Jan 2009
Location: Boston, MA

Posts: 198
iTrader: (0)

Garage List
2011 BMW X3 35i  [0.00]
Quote:
Originally Posted by durbana View Post
I picked my 2.0d on Saturday, very satisfied but for the mottled effect on the rubber surrounds of the windows. Has anyone else have the same problem?
Not sure I know what you mean, can you send a pic?
__________________
2011 F25 35i Space Gray with Black Leather
Cold Weather | Convenience | Dynamic Handling | Premium | Sport Activity | Technology | Dynamic Damper Control | Head-up Display | Smartphone | BMW Apps | Premium hi-fi | Satellite radio | Automatic high beams
pault is offline  
0
Reply With Quote
      05-16-2011, 11:33 AM   #3
Radioactive
Captain
 
Drives: '11 X3 28i '10 535i '04 325i
Join Date: Mar 2011
Location: San Diego

Posts: 655
iTrader: (0)

Somebody else had this problem a couple of months ago. Cleaned it up I believe with rubber/vinyl protectant, microcloth and hard rubbing.
Radioactive is offline   United_States
0
Reply With Quote
      05-16-2011, 02:08 PM   #4
Marisa330i
Private
 
Drives: 2006 330i
Join Date: Apr 2011
Location: NJ

Posts: 53
iTrader: (0)

I have this on my current 330i only it's on the chrome around the windows. It's all blotchy and even chrome polish doesn't help it.
Marisa330i is offline   United_States
0
Reply With Quote
      05-16-2011, 04:13 PM   #5
Harplayr
Lieutenant
 
Drives: 2011 BMW X3 28i, F25
Join Date: Apr 2011
Location: Chicago

Posts: 424
iTrader: (0)

Did the dealer detail it before delivery?
They may have used a buffing machine and got some of the wax on it.
I had a similar problem on my last X3 on black plastic parts. Used “Back to Black” and it removed the wax. I’m not sure if it’s good on rubber though.
Harplayr is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:38 AM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST