BMW X3 Forum
BMW X3 Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
XBimmers | BMW X3 Forum > BMW X3 Forums | F25 (2011 - Current) > Second Generation BMW X3 General Forum » New 2011 BMW X3 test drive.

Post Reply
 
Thread Tools Search this Thread
      05-14-2011, 03:49 PM   #1
BimmerGuyFL
Lieutenant
 
Drives: 2013 F10 BMW 535i M-sport
Join Date: Jun 2005
Location: Orlando, FL USA

Posts: 515
iTrader: (0)

New 2011 BMW X3 test drive.

So today I had the chance to test drive a new 2011 BMW X3. The test drive was conducted on the highway, left, middle, right lane, and back roads. First I must say I checked also to see if it had a drift or pull to the right. The X3 definitely had a feeling more towards drifting to the right than the left on all lanes and roads I went on. I paid CLOSE attention to this. It wasn't severe but paying close attention to it did display a tendency for a right side pull. My 328i also has this slight behavior.

I believe this seems to be normal in my opinion. Some cars might show it more than others. But in general because of crowns in the road for drainage there is no way around this. Just my two cents.
__________________
2013 F10 BMW 535i Alpine White / Oyster Dakota Leather / Anthracite Wood Trim / Steptronic transmission / M Sport Package / Premium Package / Technology Package / Rear-view camera / Park Distance Control
BimmerGuyFL is offline   United_States
0
Reply With Quote
      05-14-2011, 05:13 PM   #2
Harplayr
Lieutenant
 
Drives: 2011 BMW X3 28i, F25
Join Date: Apr 2011
Location: Chicago

Posts: 424
iTrader: (0)

Yes, all cars will follow the crown somewhat, but I don’t find a radical pull that constant corrections are needed or that the car is wandering. I find the ride and handling very relaxing and enjoyable when cruising the highways. Still waiting and looking forward to a long trip, but from the short rides I know it's gonna be great.
Harplayr is offline  
0
Reply With Quote
      05-14-2011, 06:30 PM   #3
Radioactive
Captain
 
Drives: '11 X3 28i '10 535i '04 325i
Join Date: Mar 2011
Location: San Diego

Posts: 655
iTrader: (0)

Quote:
Originally Posted by Harplayr View Post
Yes, all cars will follow the crown somewhat, but I donít find a radical pull that constant corrections are needed or that the car is wandering. I find the ride and handling very relaxing and enjoyable when cruising the highways. Still waiting and looking forward to a long trip, but from the short rides I know it's gonna be great.
+1

On the freeway I did notice a very slight propensity to "wander" to the right. No biggie, just kinda a characteristic of the car.
Radioactive is offline   United_States
0
Reply With Quote
      05-14-2011, 07:10 PM   #4
Itchywasabi
Private
 
Drives: BMW X3
Join Date: May 2011
Location: Abottabad

Posts: 56
iTrader: (0)

I thought it was just me imagining things ( I was thinking maybe the wind or anything else)... but I am also having this issue in my 28i... slightly turning right when on highway. Annoying specially on high speed and high traffic areas.
Itchywasabi is offline  
0
Reply With Quote
      05-14-2011, 07:43 PM   #5
Harplayr
Lieutenant
 
Drives: 2011 BMW X3 28i, F25
Join Date: Apr 2011
Location: Chicago

Posts: 424
iTrader: (0)

Mine’s not significant enough to be annoying. If I take my hands off the wheel eventually it will very mildly drift in the direction of the crown, it will hold its lane for quite a bit but not for miles. I wouldn’t characterize it as a “pull” but just normal for about any car I’ve driven.

I would say if it’s to the point of being really noticeable or annoying the alignment should be checked.

Last edited by Harplayr; 05-15-2011 at 08:08 AM.
Harplayr is offline  
0
Reply With Quote
      05-15-2011, 08:56 AM   #6
Powerrunner
Second Lieutenant
 
Drives: BMW X3 35i 2011
Join Date: Mar 2011
Location: Naperville

Posts: 275
iTrader: (0)

Wow, years back on my BMW 740il I did notice a pull to the right, and was annoying. However on my X3 35i I have not noticed any pull!
Powerrunner is offline   United_States
0
Reply With Quote
      05-15-2011, 09:19 AM   #7
Radioactive
Captain
 
Drives: '11 X3 28i '10 535i '04 325i
Join Date: Mar 2011
Location: San Diego

Posts: 655
iTrader: (0)

I was on the same highway last night and didn't feel any pull. Original pull could have be caused by insufficient new tire break in.
Radioactive is offline   United_States
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:42 AM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST