BMW X3 Forum
BMW X3 Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
XBimmers | BMW X3 Forum > BMW X3 Forums | F25 (2011 - Current) > Second Generation BMW X3 General Forum » X3 (F25) Trailer Hitch

Post Reply
 
Thread Tools Search this Thread
      10-20-2011, 01:06 AM   #67
x3and535i
New Member
 
Drives: 535i, X3 F25
Join Date: Sep 2011
Location: California

Posts: 10
iTrader: (0)

terrible service by Execuhitch

To: Dean and Bill at Execuhitch 1400 Upper Hembree Rd Roswell, GA 30076
Dear Execuhitch Team,
I would like to let you know that I am very disappointed with your services. On October 7-th Execuhitch received my return of the trailer hitch for 2011 BMW X3 (FedEx Shipment ID# 997094350070568) that San Francisco BMW dealership refused to install. My numerous calls to the number “Dean direct (404) 316-9840” trying to understand when I will receive my refund are not answered during last 2 (two) weeks. My multiple e-mails to the “customer service” at Execuhitch are not answered either. Before I file a claim with my bank, which is BMW Financial Bank and before I do the same claim with BBB and use all other legal means to protect my consumer rights, I would like to ask you last time to provide me exact date when my refund will be processed.
Slava Adeyev
x3and535i is offline  
0
Reply With Quote
      10-20-2011, 12:20 PM   #68
x3valk
New Member
 
Drives: m3 sedan
Join Date: Jun 2011
Location: San Diego

Posts: 27
iTrader: (0)

I was planning on going the Execuhitch route as well. It did not occur to me that the dealership might refuse to install it....and if I cannot get a refund....I will have to go with with BMW hitch and wait until it arrives in SD.
x3valk is offline  
0
Reply With Quote
      10-20-2011, 12:23 PM   #69
x3valk
New Member
 
Drives: m3 sedan
Join Date: Jun 2011
Location: San Diego

Posts: 27
iTrader: (0)

Razel, did you have the pulling-to-the-right resolved? I am in the same situation: the car pulls slightly to the right, just enough so that it is annoying and might create issues down the road....
x3valk is offline  
0
Reply With Quote
      10-20-2011, 01:44 PM   #70
Razel
Rider and driver
 
Razel's Avatar
 
Drives: 2011 Black X35i Rides: K1300GT
Join Date: Feb 2011
Location: Fremont, CA.

Posts: 251
iTrader: (0)

Send a message via ICQ to Razel
Quote:
Originally Posted by x3valk View Post
Razel, did you have the pulling-to-the-right resolved? I am in the same situation: the car pulls slightly to the right, just enough so that it is annoying and might create issues down the road....
Well, in a word, no. They swapped the front tires (left-to-right and right-to-left) and it's not happening with the same "intensity". Doesn't pull all time, but it's still there. I'm waiting to let the tires wear in a bit and see if it doesn't come back to the stronger pull.

About 40 years ago my dad bought a Bavaria (E35?) and it had the same issue, but also had asymmetrical tires, and the pull to the right went away for good with that tire swap. Dad was incredulous over that fix when they told him, but turned out it was what it took. So, while I'm skeptical that the tire-swap is the fix, I'll let it pan out a bit.
__________________
2011 X3 35i
Black Saphire - Nevada Mojave - Y Spoke 308 - Premium Sound - Navigation

I work for Keyser Söze
Razel is offline   United_States
0
Reply With Quote
      10-20-2011, 01:53 PM   #71
Razel
Rider and driver
 
Razel's Avatar
 
Drives: 2011 Black X35i Rides: K1300GT
Join Date: Feb 2011
Location: Fremont, CA.

Posts: 251
iTrader: (0)

Send a message via ICQ to Razel
Oh. One more item to note before they install the hitch. They have to download software to the car, one thing being the ability to disable the parking sensors in the rear when the electrical connection to the trailer is made.

If you haven't gotten a USB memory stick and backed up your profile to it, get one and export the profiles. Be prepared for the settings to be erased in the car. I'd set the profile to "Guest" with my fob. When getting the car back, I put it back to "Ray" and seats didn't move with the memory buttons. Mirrors, etc., weren't anything like I'd had before dropping it off. Imported the profile, and all good now.

Computer (theirs or mine, not sure) crashed three times while programming the car. One thing I noticed is that my mileage has gone from 21 MPG (US) to 17 MPG while at the service bay, so some other goodies may have be reset as well.
__________________
2011 X3 35i
Black Saphire - Nevada Mojave - Y Spoke 308 - Premium Sound - Navigation

I work for Keyser Söze
Razel is offline   United_States
0
Reply With Quote
      10-20-2011, 08:03 PM   #72
Brutus1
Private First Class
 
Drives: 2011 x3 -Alpine white
Join Date: Dec 2010
Location: Tennessee

Posts: 161
iTrader: (0)

Thanks Razel for the info and now will you give the "Cliff Notes" on the simple way to back up profiles on a USB stick or flash drive.
Brutus1 is offline   United_States
0
Reply With Quote
      10-21-2011, 01:58 AM   #73
Razel
Rider and driver
 
Razel's Avatar
 
Drives: 2011 Black X35i Rides: K1300GT
Join Date: Feb 2011
Location: Fremont, CA.

Posts: 251
iTrader: (0)

Send a message via ICQ to Razel
Quote:
Originally Posted by Brutus1 View Post
Thanks Razel for the info and now will you give the "Cliff Notes" on the simple way to back up profiles on a USB stick or flash drive.

Plug memory stick into glovebox USB connector.
Press menu button on IDrive
Scroll down to "Settings" and select
Scroll down to "Profiles" and select
Check mark is next to the current profile.
Scroll to "Export Profile" and follow instructions to export that profile to the USP in the glovebox.
Select "Ok" when finished.
Select next profile to be saved, if needed and save it the same way.

When you get your car back, same steps except instead of noting where the check mark is, you scroll to "Import Profile" and select. DO NOT be driving when you do this unless you really relish a weird driving adventure.
__________________
2011 X3 35i
Black Saphire - Nevada Mojave - Y Spoke 308 - Premium Sound - Navigation

I work for Keyser Söze
Razel is offline   United_States
0
Reply With Quote
      10-21-2011, 08:06 PM   #74
Brutus1
Private First Class
 
Drives: 2011 x3 -Alpine white
Join Date: Dec 2010
Location: Tennessee

Posts: 161
iTrader: (0)

Thumbs up

Got it! Thanks so much.
Brutus1 is offline   United_States
0
Reply With Quote
      10-22-2011, 07:32 PM   #75
Razel
Rider and driver
 
Razel's Avatar
 
Drives: 2011 Black X35i Rides: K1300GT
Join Date: Feb 2011
Location: Fremont, CA.

Posts: 251
iTrader: (0)

Send a message via ICQ to Razel
Quote:
Originally Posted by x3and535i View Post
yes, that's exactly what I have installed by San Francisco BMW
Just curious, did you have any vehicle settings reset after the download? Did your profile remain or did you have to reset the seats and mirrors?
__________________
2011 X3 35i
Black Saphire - Nevada Mojave - Y Spoke 308 - Premium Sound - Navigation

I work for Keyser Söze
Razel is offline   United_States
0
Reply With Quote
      10-22-2011, 11:56 PM   #76
x3and535i
New Member
 
Drives: 535i, X3 F25
Join Date: Sep 2011
Location: California

Posts: 10
iTrader: (0)

Quote:
Originally Posted by Razel View Post
Just curious, did you have any vehicle settings reset after the download? Did your profile remain or did you have to reset the seats and mirrors?
well, I had all profiles on my car intact. All I had to do is to choose the right profile after reprogramming was done.
x3and535i is offline  
0
Reply With Quote
      11-05-2011, 07:45 PM   #77
Brutus1
Private First Class
 
Drives: 2011 x3 -Alpine white
Join Date: Dec 2010
Location: Tennessee

Posts: 161
iTrader: (0)

Thumbs up

Well,finally was able to get the hitch installed after a 9 months wait and picked it up yesterday! Razel- you saved my settings and thanks so much. I asked the SA about them and he said no problem but I probably only had the seats and radio stations but I explained about having others. After leaving, I found that truly they were gone but after importing via my flash drive as you instructed - all back.

Last edited by Brutus1; 11-08-2011 at 09:19 PM.
Brutus1 is offline   United_States
0
Reply With Quote
      11-08-2011, 09:11 PM   #78
Binas_daddy
Mid-life compromise
 
Drives: '11 X3 35i F25 N55 Z8
Join Date: Jun 2011
Location: Texas

Posts: 13
iTrader: (0)

My father and I installed an Execuhitch on my F25 today in about 3 hours. Everything went fine and according to the internet pictorial instructions. Very pleased with this piece of high tech equipment.
Binas_daddy is offline   United_States
0
Reply With Quote
      01-03-2012, 12:05 AM   #79
jsplayin
Private
 
Drives: E46 M3
Join Date: Oct 2011
Location: Boston Area, MA

Posts: 79
iTrader: (0)

Does anybody know if the BWM hitch comes with installation instructions or is it assumed that it's going to be installed by the dealer? Anybody install one themselves and brought it to the dealer for the software?
jsplayin is offline   United_States
0
Reply With Quote
      01-03-2012, 01:52 PM   #80
jsplayin
Private
 
Drives: E46 M3
Join Date: Oct 2011
Location: Boston Area, MA

Posts: 79
iTrader: (0)

Ok, I found the instructions for installing the BMW hitch at bavauto.com

http://www.bavauto.com/assets/inst_pages/ins429.pdf

I'm waiting to find out from my service advisor how much they would charge for just the software programming.
jsplayin is offline   United_States
0
Reply With Quote
      03-04-2012, 03:22 PM   #81
jsplayin
Private
 
Drives: E46 M3
Join Date: Oct 2011
Location: Boston Area, MA

Posts: 79
iTrader: (0)

OEM BMW hitch DIY

I just installed the BMW OEM hitch myself yesterday and it was pretty easy, although time consuming. In case anybody is wondering the BMW hitch is mfg by Thule. I was quoted one hr @ $125 for programming by the dealer, which I will do next week. So diy saved me about $300-600 or so based on what people are posting dealers charge.

I didn't take any pictures since this excellent diy for the execuhitch shows most of what is needed.
http://www.bimmerfest.com/forums/sho...d.php?t=572155

I also used the BMW instructions I linked from bavauto, which is essential for torque specs and fuse locations. http://www.bavauto.com/Assets/inst_pages/ins429.pdf

First you should probably remove the battery, which is sort of a pain but it does provide for some good mental exercise in figuring out how to remove the most over engineered battery attachment system I've ever seen.

I found it nice that the wiring harness is just plug and play, you pull out the existing harness that feeds the parking sensors etc, pop this one in and plug the ends of the old one into this one. I does take some head scratching to figure out how to feed the harness through the trunk opening since the hitch module plug is big and the opening is small. What you need to do is feed the harness starting with this plug first and from the outside of the car feed it in at an angle that will allow it to fit through the hole.

After that the next part of confusion was wiring the fuse box. I suppose I should have taken pics for this since the BMW instructions are confusing as to where exactly the new connectors go in the fuse box. And in case anybody attempts this, the car already has the fuses provided in fuse locations 100 and 145, then you just turn to the back of the panel and the wires go into those corresponding spots to enable those fuses. To install the fuse wiring you first have to remove all the fuses in that plug (take a picture of it before you do this so you know where they go) and pull out the entire plug from the back of the fuse panel. Then the plug has a sort of locking tab on each side, you open that up, pop in the wire, close it and plug it back in.

The only splicing involved was to the blue/brown right tail lamp wire, I was not provided a wire tap btw, so check if you need to purchase one.

The last bit of wiring was just a plug connecting the harness to the pre-wired plug that is taped to the back of the fuse box.

You will also need single use plastic expanding rivets for attaching the wheel arch trim, part #51777171004. I got by with removing only 3 on each side, but it would be much easier to just to remove the entire arches or at least 4 rivets. These rivets require a special rivet gun, since they won't fit a standard riveter as I found out. I'm probably going to have to order one of these http://www.sjdiscounttools.com/mar48000.html to properly attach the trim.

So in summary you would need to purchase to do the job:
1. Trailer kit - Tischer provides new hex bolts and control module holder, other sources most likely don't.
2. one wire tap if you don't receive one with the kit
3. at least 4 rivets and special rivet gun
4. thread lock for the hex nuts - not specified in instructions but prob a good idea




Last edited by jsplayin; 03-04-2012 at 03:59 PM.
jsplayin is offline   United_States
0
Reply With Quote
      08-08-2012, 01:04 PM   #82
x3valk
New Member
 
Drives: m3 sedan
Join Date: Jun 2011
Location: San Diego

Posts: 27
iTrader: (0)

Thanks for the pics. How much did it cost you for the parts+labor. The local dealership is asking $1395 plus tax. I find that a bit excessive...
x3valk is offline  
0
Reply With Quote
      11-26-2012, 12:17 AM   #83
Definitive
definitivecars.com
 
Definitive's Avatar
 
Drives: Elsa - 2015 F80 M3 - YMB/SS
Join Date: Aug 2006
Location: So Cal

Posts: 3,729
iTrader: (3)

Garage List
Send a message via AIM to Definitive Send a message via MSN to Definitive
For this BMW hitch, do you just order the main part number? or do you need most of these below? I already have a ball and tounge.

82712157704 Hitch Kit 700.00 560.00
72110303879 2in ball & tongue 42.50 34.00
61359217232 Foam holder 20.70 16.56
07147266441 Nuts(x4) 1.62 1.29
61138364566 2 pin conn 1.89 1.89
01412249020 Replacement manual 1.00 1.00

D
__________________
Definitive is online now   United_States
0
Reply With Quote
      07-12-2013, 10:56 AM   #84
george2064
Registered
 
Drives: X3 2011
Join Date: Jul 2013
Location: Portland, Maine

Posts: 1
iTrader: (0)

thanks for the pictures... I still have hard time with the re-attachment process.
What is your starting position? is the key in the un-locked and the rotating knob in the green?
I shove it in and does not want to stay ... do I have to lock the key? or the key and the knob in the red?

Very confused ... not very user friendly.
george2064 is offline  
0
Reply With Quote
Post Reply

Bookmarks

Tags
f25, hitch, trailer

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:49 AM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST