BMW X3 Forum
BMW X3 Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
XBimmers | BMW X3 Forum > BMW X3 Forums | F25 (2011 - Current) > Second Generation BMW X3 General Forum » 15 months later after software update. Throttle response

Post Reply
 
Thread Tools Search this Thread
      12-24-2012, 05:00 PM   #1
sard
Major
141

 
Drives: 2008 M3
Join Date: Oct 2008
Location: Southern California


Posts: 1,330
iTrader: (1)

Send a message via AIM to sard
15 months later after software update. Throttle response

When I first picked up the car in August of last year I was bitching about the throttle delay from a stop. How when you pressed the gas pedal, it didn't seem to want to move forward and as you kept pressing on the gas pedal it would finally jerk forward. Also sometimes when you came to a near stop and then needed to accelerate, it would result in a jerky acceleration.

I finally took the car back in today for service for an annual oil change. I should have probably brought it back at 12 months, but I got lazy. The car only has 9k miles on it. So they updated the software and here are my thoughts.

I got so used to how the car drove I never really noticed it anymore. Maybe it fixed itself? It seems a little smoother after the software update, but I find myself questioning if it's psychological.
__________________

E92 M3 - DCT - 20" BBS LM-R - KW Clubsport - Akrapovic Exhaust - Powerchip Tune - Arkym Aero Kit - HID Halo
Appreciate 0
      12-24-2012, 11:04 PM   #2
lbjgh
Major
Canada
57

 
lbjgh's Avatar
 
Drives: 2013 AW X3 M-Sport
Join Date: Dec 2011
Location: North of Toronto


Posts: 1,460
iTrader: (0)

It's not in your head my friend.

I almost didn't buy the X3 after test driving the car... I thought to myself, "this is a premium car and they don't know how to modulate drive-by-wire"??

I started researching aftermarket fixes for the problem and figured I could fix the problem until BMW fired the junior engineer who did the original programing.

Well by the time my car was built BMW had fixed the design fault and my car was delivered with a nice smooth linear accelerator.

Maybe you just taught yourself to use the non-linear accelerator.
__________________
2013, AW, xDrive35i, M Sport Package, Technology Package, Dynamic Comfort Package, Premium Package, 3M Clear Bra, Euro foglight switch, a few coded fixes
Appreciate 0
      12-25-2012, 12:05 AM   #3
X Three
New Member
0

 
Drives: 2011 BMW X3 xDrive28i
Join Date: Aug 2012
Location: Boston, MA


Posts: 7
iTrader: (0)

I just had my transmission serviced for another problem where the service guys had to contact Germany (at least that was what I was told), and they must have updated the programming. I'm also not sure if it's in my head, but from the moment I drove off the service lot, the transmission felt different. It does seem to be quicker off the start, but at higher speeds ironically the transmission shifts are more perceptible almost to the point of being rough. Also, my rear wheels used to spin out a little from the start on loose gravel and the like, it doesn't do that anymore. I liked the fact it used to do that! Again, it might be psychological but I was not expecting them to change any software programming so I wasn't expecting any changes to how the car drove, but I noticed something different about how the car drives now. I am going to call the service guys to try to find out exactly what they did.
Appreciate 0
      12-25-2012, 09:27 AM   #4
kskpsu
Second Lieutenant
United_States
5

 
kskpsu's Avatar
 
Drives: Anything German
Join Date: Jul 2011
Location: Minneapolis, MN


Posts: 200
iTrader: (0)

Garage List
'11 BMW 1M  [5.00]
'13 BMW X5M  [0.00]
'14 Audi S6  [0.00]
'05 MB CLK55 AMG Cab  [0.00]
Had the software update, and while improved, it hasn't alleviated the abrupt start entirely. The most extreme "jerk" still being when slowing to a roll, then getting back on the throttle. Upshifts at higher speeds seem to be faster, I like that.
__________________
-kskpsu
Appreciate 0
      12-27-2012, 06:17 AM   #5
Nahoa
Lieutenant Colonel
United_States
30

 
Drives: F25 35i Mineral Silver/Black
Join Date: May 2008
Location: Virginia


Posts: 1,876
iTrader: (0)

I still prefer the original programming. Once learned, it worked great.
__________________
Appreciate 0
      12-27-2012, 07:37 PM   #6
sard
Major
141

 
Drives: 2008 M3
Join Date: Oct 2008
Location: Southern California


Posts: 1,330
iTrader: (1)

Send a message via AIM to sard
Quote:
Originally Posted by kskpsu View Post
Had the software update, and while improved, it hasn't alleviated the abrupt start entirely. The most extreme "jerk" still being when slowing to a roll, then getting back on the throttle. Upshifts at higher speeds seem to be faster, I like that.
I definitely can replicate the abrupt jerk still also. Sometimes not intentionally hah.
__________________

E92 M3 - DCT - 20" BBS LM-R - KW Clubsport - Akrapovic Exhaust - Powerchip Tune - Arkym Aero Kit - HID Halo
Appreciate 0
      12-27-2012, 07:47 PM   #7
c3uo
Private
9

 
Drives: 3 Series
Join Date: Jun 2005
Location: NB


Posts: 83
iTrader: (0)

Drives me nuts too. I've compensated by manually tapping the steering left hand steering wheel paddle when coming to a stop so it starts in first gear. Otherwise it is LAG city, followed by downshift then jerky take off.

I miss my old NA inline-6 with a linear 6-speed automatic.

I'm sure this can be fixed with programming which will make up the X3 nearly perfect (assuming my other niggles get repaired).
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 11:25 AM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST