BMW X3 Forum
BMW X3 Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
XBimmers | BMW X3 Forum > BMW X3 Forums | F25 (2011 - Current) > Second Generation BMW X3 General Forum » Coding made Easy: A step by step procedure

Post Reply
 
Thread Tools Search this Thread
      10-11-2012, 09:52 PM   #221
April1
Love All
 
April1's Avatar
 
Drives: X3 28i 2011
Join Date: Nov 2011
Location: San Francisco

Posts: 738
iTrader: (1)

Send a message via Yahoo to April1
Just double click on copy_Cafd files utility, all will be done for you.
April1 is offline   United_States
0
Reply With Quote
      10-12-2012, 05:32 PM   #222
richardchou
Enlisted Member
 
Drives: 2011 X3 35i M Sport - White
Join Date: Aug 2011
Location: Edmonton, AB CAN

Posts: 43
iTrader: (0)

DVD in Motion

Hi all,

I have attached a screen shot of my issue. I am trying to code DVD in Motion but I don't have an option to set the speed value to "FF". Any ideas?

Also, can you please teach me how to revert all codes back to the original setting? I have a backup of the orginal code (CAF folder)

Thank you,
Richard
Attached Images
 
richardchou is offline  
0
Reply With Quote
      10-12-2012, 05:43 PM   #223
shawnsheridan
Brigadier General
 
shawnsheridan's Avatar
 
Drives: 2011 535i M-Sport
Join Date: Feb 2010
Location: Houston, TX

Posts: 4,112
iTrader: (0)

Garage List
Quote:
Originally Posted by richardchou View Post
Hi all,

I have attached a screen shot of my issue. I am trying to code DVD in Motion but I don't have an option to set the speed value to "FF". Any ideas?

Also, can you please teach me how to revert all codes back to the original setting? I have a backup of the orginal code (CAF folder)

Thank you,
Richard
Do not change the Drop Down, change the Werte Value below it. Right click on it (00) and select Edit in the bottom window, change 00 to FF, and then in the upper right corner of that same bottom window, hit the save icon (or Ctrl-Enter I think), then save the NCD, back up and FDL Code it.

You can use your .ncd files by right-clicking on the ECU and selecting add or insert, and the selecting the corresponding .ncd file, and then FDL Coding the ECU.

However, the easiest thing to do (assuming you have not modified your VO in any way) is to simply Read you VO, Read VCM, and then highlight each ECU one at at time, Right-Click on it and select CODE. This "VO Coding" (as opposed to "FDL Coding") will restore each ECU to it's as delivered condition.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
shawnsheridan is offline   United_States
0
Reply With Quote
      10-12-2012, 06:02 PM   #224
lbjgh
Major
 
lbjgh's Avatar
 
Drives: 2013 AW X3 M-Sport
Join Date: Dec 2011
Location: North of Toronto

Posts: 1,436
iTrader: (0)

Hey guys...

I noticed something interesting with disabling start/stop.

The car remembers the setting (off) however start/stop is restored when Ecopro is selected.

Quote:
Originally Posted by lbjgh View Post
edited

woohoo!

To date working:

Working

Lift gate close with fob and button on drivers side
Auto close widows, moonroof, fold in mirrors from fob and comfort access
Disable legal disclaimers for iDrive
Auto stop/start: remember last setting
Digital speed on BC display
__________________
2013, AW, xDrive35i, M Sport Package, Technology Package, Dynamic Comfort Package, Premium Package, 3M Clear Bra, Euro foglight switch, a few coded fixes
lbjgh is offline   Canada
0
Reply With Quote
      10-12-2012, 06:14 PM   #225
shawnsheridan
Brigadier General
 
shawnsheridan's Avatar
 
Drives: 2011 535i M-Sport
Join Date: Feb 2010
Location: Houston, TX

Posts: 4,112
iTrader: (0)

Garage List
Quote:
Originally Posted by lbjgh View Post
Hey guys...

I noticed something interesting with disabling start/stop.

The car remembers the setting (off) however start/stop is restored when Ecopro is selected.
Makes sense considering the goal of ECO PRO is to maximize fuel efficiency, and Auto Start/Stop is a major contributor towards that.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
shawnsheridan is offline   United_States
0
Reply With Quote
      10-12-2012, 08:29 PM   #226
richardchou
Enlisted Member
 
Drives: 2011 X3 35i M Sport - White
Join Date: Aug 2011
Location: Edmonton, AB CAN

Posts: 43
iTrader: (0)

Thanks for your reply, Shawn.

So, I don't need to move any CAF files before reading VO & VCM? Simply CODE the ECU will bring everything back to default?

Richard

Quote:
Originally Posted by shawnsheridan View Post
Do not change the Drop Down, change the Werte Value below it. Right click on it (00) and select Edit in the bottom window, change 00 to FF, and then in the upper right corner of that same bottom window, hit the save icon (or Ctrl-Enter I think), then save the NCD, back up and FDL Code it.

You can use your .ncd files by right-clicking on the ECU and selecting add or insert, and the selecting the corresponding .ncd file, and then FDL Coding the ECU.

However, the easiest thing to do (assuming you have not modified your VO in any way) is to simply Read you VO, Read VCM, and then highlight each ECU one at at time, Right-Click on it and select CODE. This "VO Coding" (as opposed to "FDL Coding") will restore each ECU to it's as delivered condition.
richardchou is offline  
0
Reply With Quote
      10-12-2012, 08:30 PM   #227
shawnsheridan
Brigadier General
 
shawnsheridan's Avatar
 
Drives: 2011 535i M-Sport
Join Date: Feb 2010
Location: Houston, TX

Posts: 4,112
iTrader: (0)

Garage List
Quote:
Originally Posted by richardchou View Post
Thanks for your reply, Shawn.

So, I don't need to move any CAF files before reading VO & VCM? Simply CODE the ECU will bring everything back to default?

Richard
That is correct, so long as you are using your original factory VO.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
shawnsheridan is offline   United_States
0
Reply With Quote
      10-13-2012, 12:08 AM   #228
richardchou
Enlisted Member
 
Drives: 2011 X3 35i M Sport - White
Join Date: Aug 2011
Location: Edmonton, AB CAN

Posts: 43
iTrader: (0)

front turn signal illumination

Hi all,

Anyone know how to code so that front turn signals will not be illuminated when headlight is on?

Thank you!
richardchou is offline  
0
Reply With Quote
      10-13-2012, 03:46 AM   #229
shawnsheridan
Brigadier General
 
shawnsheridan's Avatar
 
Drives: 2011 535i M-Sport
Join Date: Feb 2010
Location: Houston, TX

Posts: 4,112
iTrader: (0)

Garage List
Quote:
Originally Posted by richardchou View Post
Hi all,

Anyone know how to code so that front turn signals will not be illuminated when headlight is on?

Thank you!
Look for this or something similar:

FEM_BODY / 3063 LceLampMapping2 / MAPPING_SIDEMARKER_L_OUTPUT = off
FEM_BODY / 3063 LceLampMapping2 / MAPPING_SIDEMARKER_R_OUTPUT = off
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
shawnsheridan is offline   United_States
0
Reply With Quote
      10-13-2012, 09:22 AM   #230
lbjgh
Major
 
lbjgh's Avatar
 
Drives: 2013 AW X3 M-Sport
Join Date: Dec 2011
Location: North of Toronto

Posts: 1,436
iTrader: (0)

So now that I've coded the obvious things I suppose I'm done with coding.

Are there any other 'tweaks' that I should look into?
__________________
2013, AW, xDrive35i, M Sport Package, Technology Package, Dynamic Comfort Package, Premium Package, 3M Clear Bra, Euro foglight switch, a few coded fixes
lbjgh is offline   Canada
0
Reply With Quote
      10-18-2012, 08:55 AM   #231
tobert
New Member
 
Drives: 2013 X3 28i
Join Date: Sep 2012
Location: Boston, MA

Posts: 9
iTrader: (0)

Hey everyone...following the tested cheat sheet, I coded my F25 to unlock the doors when the engine is stopped, however, it seems to unlock only the DRIVERS door. The rest of the doors still require a double pull to open. Is this how it should be working, or have I done something incorrectly? I set the following:

CAS 3002 CLM ER_KEYOUT_AUTOVR aktiv / Werte=01

I'm not sure what I may have done wrong? Or...if that is the intent...to unlock the drivers door only...does anyone know how to code it to unlock the rest of the doors when the engine is stopped?

Thanks!
Tim
tobert is offline  
0
Reply With Quote
      10-18-2012, 09:42 AM   #232
shawnsheridan
Brigadier General
 
shawnsheridan's Avatar
 
Drives: 2011 535i M-Sport
Join Date: Feb 2010
Location: Houston, TX

Posts: 4,112
iTrader: (0)

Garage List
Quote:
Originally Posted by tobert View Post
Hey everyone...following the tested cheat sheet, I coded my F25 to unlock the doors when the engine is stopped, however, it seems to unlock only the DRIVERS door. The rest of the doors still require a double pull to open. Is this how it should be working, or have I done something incorrectly? I set the following:

CAS 3002 CLM ER_KEYOUT_AUTOVR aktiv / Werte=01

I'm not sure what I may have done wrong? Or...if that is the intent...to unlock the drivers door only...does anyone know how to code it to unlock the rest of the doors when the engine is stopped?

Thanks!
Tim
Allows single pull of Driver's Side or All Doors to open door depending on iDrive Unlock Settings.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
shawnsheridan is offline   United_States
0
Reply With Quote
      10-18-2012, 07:16 PM   #233
Buffaloalchemist
New Member
 
Drives: 2013 X3 28i Deep Sea Blue
Join Date: Sep 2012
Location: Williamsville, NY

Posts: 5
iTrader: (0)

Does anyone know if there is a way to code the garage door opener so that it is always available? As it is now the ignition must be on for it to operate! The Acura I replaced with the BMW had it always on as does my Miata. I would like to be able to open the door before starting the engine. As it is now I can open from the wall switch or turn on the X3's ignition first open the door and then start the engine which is just more cumbersome.
Buffaloalchemist is offline  
0
Reply With Quote
      10-18-2012, 10:19 PM   #234
BeeMdblU
Second Lieutenant
 
BeeMdblU's Avatar
 
Drives: F30 328 XDS, CLK55, F25 35
Join Date: May 2012
Location: Montreal

Posts: 207
iTrader: (0)

Quote:
Originally Posted by richardchou View Post
Hi all,

Anyone know how to code so that front turn signals will not be illuminated when headlight is on?

Thank you!
let us know if you complete this successfully
BeeMdblU is offline  
0
Reply With Quote
      10-18-2012, 10:23 PM   #235
shawnsheridan
Brigadier General
 
shawnsheridan's Avatar
 
Drives: 2011 535i M-Sport
Join Date: Feb 2010
Location: Houston, TX

Posts: 4,112
iTrader: (0)

Garage List
Quote:
Originally Posted by BeeMdblU View Post
let us know if you complete this successfully
You can try what I suggested to him in Post # 229, which was to look for this or something similar:

FEM_BODY / 3063 LceLampMapping2 / MAPPING_SIDEMARKER_L_OUTPUT = off
FEM_BODY / 3063 LceLampMapping2 / MAPPING_SIDEMARKER_R_OUTPUT = off:

http://x3.xbimmers.com/forums/showpo...&postcount=229
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
shawnsheridan is offline   United_States
0
Reply With Quote
      10-20-2012, 01:05 PM   #236
CatFlap
Lieutenant
 
CatFlap's Avatar
 
Drives: X5 F15 M Sport
Join Date: Aug 2012
Location: Worcs UK

Posts: 405
iTrader: (0)

Garage List
Send a message via Skype™ to CatFlap
Thanks to April1 my coding 'kit' arrived today.

The install batch file supplied on the USB stick worked faultlessly as does e-sys on my old MS Vista laptop. Thus far I've successfully coded my X3 as follows:

DVD in motion.
Reverse camera in motion. (The kids like it!)
Welcome lights fade up instead of instant on, also enabled low beam HID's to come on with welcome lights too since our village doesn't have street lights.
Increased the wash before wipe delay to 300 msec from default 200 msec to get a bit more washer fluid on the glass before it's wiped away.
Added menu to change performance display units so that I can have good old fashioned horsepower and lb/ft!.
High beam assist to default ON.
Start/Stop setting memory.
Enabled Traffic info over DAB for navigation system. I assume the traffic data is ordinarily received via FM since TI_DAB_TMS was inactive.

All modified functions tested working OK with the possible exception of Traffic on DAB, I can see live traffic info via iDrive though I'm not sure if I should assume my mod has made any difference!

I had a play around with Speed Limit Display. My car has high beam assist camera and I managed to get the speed limit icon in the info display (red circle on white background) though the actual limit did not appear (just "--" in the centre of the symbol) despite driving past several speed limit signs. At one point I lost the BC display, only the current time was visible and the BC button on the stalk stopped working - the entire area of the display where the fuel economy gauge is positioned disappeared too. At this point I chickened out and reverted things back to standard in the Kombi and de-activated SPEEDLIMIT_INFO in HU_CIC any thoughts anyone?


Thanks again to april1.
__________________
X5 30d M Sport in Mineral White with Terra Dakota Leather.
CatFlap is offline   United Kingdom
0
Reply With Quote
      10-20-2012, 10:49 PM   #237
Colflqgg
New Member
 
Drives: 2013 X3 35i - Alpine White
Join Date: Sep 2012
Location: Phoenix, AZ

Posts: 7
iTrader: (0)

Quote:
Originally Posted by saggo
Thanks to April1 my coding 'kit' arrived today.

The install batch file supplied on the USB stick worked faultlessly as does e-sys on my old MS Vista laptop. Thus far I've successfully coded my X3 as follows:

DVD in motion.
Reverse camera in motion. (The kids like it!)
Welcome lights fade up instead of instant on, also enabled low beam HID's to come on with welcome lights too since our village doesn't have street lights.
Increased the wash before wipe delay to 300 msec from default 200 msec to get a bit more washer fluid on the glass before it's wiped away.
Added menu to change performance display units so that I can have good old fashioned horsepower and lb/ft!.
High beam assist to default ON.
Start/Stop setting memory.
Enabled Traffic info over DAB for navigation system. I assume the traffic data is ordinarily received via FM since TI_DAB_TMS was inactive.

All modified functions tested working OK with the possible exception of Traffic on DAB, I can see live traffic info via iDrive though I'm not sure if I should assume my mod has made any difference!

I had a play around with Speed Limit Display. My car has high beam assist camera and I managed to get the speed limit icon in the info display (red circle on white background) though the actual limit did not appear (just "--" in the centre of the symbol) despite driving past several speed limit signs. At one point I lost the BC display, only the current time was visible and the BC button on the stalk stopped working - the entire area of the display where the fuel economy gauge is positioned disappeared too. At this point I chickened out and reverted things back to standard in the Kombi and de-activated SPEEDLIMIT_INFO in HU_CIC any thoughts anyone?


Thanks again to april1.
What codes did you change to make the headlights fade on and to change the delay on the wiper spray?

Thanks!
Colflqgg is offline  
0
Reply With Quote
      10-21-2012, 09:04 AM   #238
April1
Love All
 
April1's Avatar
 
Drives: X3 28i 2011
Join Date: Nov 2011
Location: San Francisco

Posts: 738
iTrader: (1)

Send a message via Yahoo to April1
Quote:
Originally Posted by saggo View Post
Thanks to April1 my coding 'kit' arrived today.

The install batch file supplied on the USB stick worked faultlessly as does e-sys on my old MS Vista laptop. Thus far I've successfully coded my X3 as follows:

DVD in motion.
Reverse camera in motion. (The kids like it!)
Welcome lights fade up instead of instant on, also enabled low beam HID's to come on with welcome lights too since our village doesn't have street lights.
Increased the wash before wipe delay to 300 msec from default 200 msec to get a bit more washer fluid on the glass before it's wiped away.
Added menu to change performance display units so that I can have good old fashioned horsepower and lb/ft!.
High beam assist to default ON.
Start/Stop setting memory.
Enabled Traffic info over DAB for navigation system. I assume the traffic data is ordinarily received via FM since TI_DAB_TMS was inactive.

All modified functions tested working OK with the possible exception of Traffic on DAB, I can see live traffic info via iDrive though I'm not sure if I should assume my mod has made any difference!

I had a play around with Speed Limit Display. My car has high beam assist camera and I managed to get the speed limit icon in the info display (red circle on white background) though the actual limit did not appear (just "--" in the centre of the symbol) despite driving past several speed limit signs. At one point I lost the BC display, only the current time was visible and the BC button on the stalk stopped working - the entire area of the display where the fuel economy gauge is positioned disappeared too. At this point I chickened out and reverted things back to standard in the Kombi and de-activated SPEEDLIMIT_INFO in HU_CIC any thoughts anyone?


Thanks again to april1.
Wow, you could do so much just in a day. Well done.
April1 is offline   United_States
0
Reply With Quote
      10-21-2012, 03:42 PM   #239
CatFlap
Lieutenant
 
CatFlap's Avatar
 
Drives: X5 F15 M Sport
Join Date: Aug 2012
Location: Worcs UK

Posts: 405
iTrader: (0)

Garage List
Send a message via Skype™ to CatFlap
Some of my X3's re-coded "features" seem to have disappeared today...auto high beam assist and ability to enable the reversing camera seem to have somehow reverted back to standard functionality. Bearing in mind it was only 18 hours since my coding session is this possible?
__________________
X5 30d M Sport in Mineral White with Terra Dakota Leather.
CatFlap is offline   United Kingdom
0
Reply With Quote
      10-21-2012, 04:19 PM   #240
Buffaloalchemist
New Member
 
Drives: 2013 X3 28i Deep Sea Blue
Join Date: Sep 2012
Location: Williamsville, NY

Posts: 5
iTrader: (0)

CAF Viewer error:

When I attempt to use the Caf viewer offline I receive the following error:

Can not parse the caf file"C:\EsysData\CAF\CAFD_00000018_004_009_000.ncd "! [C010]
SAXParseException: Content is not allowed in prolog.

this happens for all cafs not just the one in the example!

the FDL editor works ok and I have sucessfully coded several options on my F25.

I did try removing and reinstalling the complete package but this did not solve the problem! I am using Windows 7!
Buffaloalchemist is offline  
0
Reply With Quote
      10-21-2012, 05:21 PM   #241
azaremba
New Member
 
Drives: 2012 F25 35i
Join Date: Mar 2012
Location: New York

Posts: 5
iTrader: (0)

Quote:
Originally Posted by saggo View Post
Thanks to April1 my coding 'kit' arrived today.

The install batch file supplied on the USB stick worked faultlessly as does e-sys on my old MS Vista laptop. Thus far I've successfully coded my X3 as follows:

DVD in motion.
Reverse camera in motion. (The kids like it!)
Welcome lights fade up instead of instant on, also enabled low beam HID's to come on with welcome lights too since our village doesn't have street lights.
Increased the wash before wipe delay to 300 msec from default 200 msec to get a bit more washer fluid on the glass before it's wiped away.
Added menu to change performance display units so that I can have good old fashioned horsepower and lb/ft!.
High beam assist to default ON.
Start/Stop setting memory.
Enabled Traffic info over DAB for navigation system. I assume the traffic data is ordinarily received via FM since TI_DAB_TMS was inactive.

All modified functions tested working OK with the possible exception of Traffic on DAB, I can see live traffic info via iDrive though I'm not sure if I should assume my mod has made any difference!

I had a play around with Speed Limit Display. My car has high beam assist camera and I managed to get the speed limit icon in the info display (red circle on white background) though the actual limit did not appear (just "--" in the centre of the symbol) despite driving past several speed limit signs. At one point I lost the BC display, only the current time was visible and the BC button on the stalk stopped working - the entire area of the display where the fuel economy gauge is positioned disappeared too. At this point I chickened out and reverted things back to standard in the Kombi and de-activated SPEEDLIMIT_INFO in HU_CIC any thoughts anyone?


Thanks again to april1.
Please pass along the codes for the real time traffic and wiper delay.
azaremba is offline  
0
Reply With Quote
      10-22-2012, 11:58 AM   #242
CatFlap
Lieutenant
 
CatFlap's Avatar
 
Drives: X5 F15 M Sport
Join Date: Aug 2012
Location: Worcs UK

Posts: 405
iTrader: (0)

Garage List
Send a message via Skype™ to CatFlap
Quote:
Originally Posted by azaremba View Post
Please pass along the codes for the real time traffic and wiper delay.
Wash before wipe delay:

JBBFE, 3000 Wipe_Wash, WASHWITHOUTWIPE_TIME

Default value on my X3 is 200mSec

Will post the dan mod details later when I get home...
__________________
X5 30d M Sport in Mineral White with Terra Dakota Leather.
CatFlap is offline   United Kingdom
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:38 PM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST