BMW X3 Forum
BMW X3 Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
XBimmers | BMW X3 Forum > BMW X3 Forums | F25 (2011 - Current) > Second Generation BMW X3 General Forum » Alarm messages

Post Reply
 
Thread Tools Search this Thread
      08-16-2012, 10:57 AM   #1
BillyT
New Member
0

 
Drives: BMW X3 X Drive 2.0dSE
Join Date: Aug 2012
Location: Bromley, Kent


Posts: 12
iTrader: (0)

Alarm messages

My two month old X3 2.0dSE Auto has been showing an array of alarm messages intermittently on the dash display, indicating that a) the Tyre Pressure Warning System is not working, b) the ABS is not working and c) the handbrake is not working - take to service immediately. After 2 visits to my main dealer he advises that I have been doing a lot of short journeys and the stop-start may have drained the battery to such an extent that the car's systems start to shut down. I find this explanation astounding as a) the stop-start should take note of battery condition anyway and b) this is tantamount to BMW telling me how to use the car. Anybody had this? Any other ideas?
Appreciate 0
      08-16-2012, 11:39 AM   #2
sfax
Brigadier General
United Kingdom
54

 
sfax's Avatar
 
Drives: BMW X3 2011 F25
Join Date: Nov 2010
Location: Berkshire, UK


Posts: 3,853
iTrader: (0)

Quote:
Originally Posted by BillyT View Post
My two month old X3 2.0dSE Auto has been showing an array of alarm messages intermittently on the dash display, indicating that a) the Tyre Pressure Warning System is not working, b) the ABS is not working and c) the handbrake is not working - take to service immediately. After 2 visits to my main dealer he advises that I have been doing a lot of short journeys and the stop-start may have drained the battery to such an extent that the car's systems start to shut down. I find this explanation astounding as a) the stop-start should take note of battery condition anyway and b) this is tantamount to BMW telling me how to use the car. Anybody had this? Any other ideas?
We had all of the warnings coming on together and BMW (called out on BMW Assist) gave us a similar explanation. They also reset the iDrive and the errors went away and didn't come back - this was last year. We made no effort to change our driving patterns and continue to use the X3 for a lot of very short journeys without any problems at all.

See this thread which is a mix of genuine problems and red herring messages allegedly caused by low battery charge

http://x3.xbimmers.com/forums/showthread.php?t=498221

My advice (assuming they did a reset and charged the battery) is to do nothing for the time being and wait and see if it comes back
__________________

F25 xDrive20d SE __ professional multimedia package | dynamic package | climate package | 309s | xline | xenons | electric seats | folding mirrors | business speakers
Appreciate 0
      08-20-2012, 12:36 PM   #3
BillyT
New Member
0

 
Drives: BMW X3 X Drive 2.0dSE
Join Date: Aug 2012
Location: Bromley, Kent


Posts: 12
iTrader: (0)

Alarms

It seems to be associated with stop-start as they said. We have tried isolating the stop start, with no other changes to our driving - no alarms. Activate the stop-start and we get the alarms again. If it is due to the battery being unduly discharged then either the battery is not man enough or the start-stop control algorithms are wrong. Either way it's unacceptable at present
Appreciate 0
      08-27-2012, 05:32 AM   #4
BillyT
New Member
0

 
Drives: BMW X3 X Drive 2.0dSE
Join Date: Aug 2012
Location: Bromley, Kent


Posts: 12
iTrader: (0)

The dealer is now taking a stronger interest and is asking questions of BMW UK. Will report any outcome
Appreciate 0
      09-17-2012, 07:07 AM   #5
BillyT
New Member
0

 
Drives: BMW X3 X Drive 2.0dSE
Join Date: Aug 2012
Location: Bromley, Kent


Posts: 12
iTrader: (0)

ALarms

They've "recoded" the car and now the start/stop appears not to work at all - they have just made the problem go away rather than fixing it. Totally unsatisfactory without the start/stop which is a key part of the Efficient Dynamics thing. Waiting for further response form dealer before calling Trading Standards
Appreciate 0
      09-20-2012, 06:35 AM   #6
BillyT
New Member
0

 
Drives: BMW X3 X Drive 2.0dSE
Join Date: Aug 2012
Location: Bromley, Kent


Posts: 12
iTrader: (0)

Now seems to be fixed finally with another full recode - watch this space!
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:46 PM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST