BMW X3 Forum
BMW X3 Forum
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
XBimmers | BMW X3 Forum > BMW X3 Forums | F25 (2011 - Current) > Second Generation BMW X3 General Forum » SI B24 02 12 - throttle lag (and steering pull fix)?

Post Reply
 
Thread Tools Search this Thread
      06-08-2012, 09:07 AM   #111
April1
Love All
 
April1's Avatar
 
Drives: X3 28i 2011
Join Date: Nov 2011
Location: San Francisco

Posts: 738
iTrader: (1)

Send a message via Yahoo to April1
First of all, sorry to hear that your dealer is not taking care of you and not scheduling your car timely for update / repair.

You would notice the difference when you drive after the software update. That experience can't be described here.
April1 is offline   United_States
0
Reply With Quote
      06-08-2012, 02:37 PM   #112
Dechy
Private
 
Drives: 2011 X3 35i M
Join Date: Apr 2011
Location: Ottawa

Posts: 67
iTrader: (0)

Just got an appointment for next week on the throttle lag, cold start idle fluctuation & cluster gauges getting stuck randomly.

I printed off the 2 PDFs found here about the 2 first issues which I have experienced but that I categorized a minor annoyances and showed it to the service rep and after looking at them and hearing me out immediately scheduled it. The cluster gauge is self-healing after 3-4 restarts, but still the worst of the bunch, but every time I went to see them it would be back to normal... hopefully they fix/change the weird thing!

This is the first dealership I go to after having so many different cars that I go in expecting some sort of battle/resistance and they always treat me like all friggin dealerships should.

Always a loaner available too. Having the throttle lag fixed will be nice for the family (I'm "used" to it, so when I feel it coming I brace for the jolt... the rest of the people just hit their heads on the headrests lol)
Dechy is offline   Canada
0
Reply With Quote
      06-08-2012, 03:04 PM   #113
April1
Love All
 
April1's Avatar
 
Drives: X3 28i 2011
Join Date: Nov 2011
Location: San Francisco

Posts: 738
iTrader: (1)

Send a message via Yahoo to April1
The update to fix the throttle lag on my X3 2011 gave great results and the drive became very responsive at low speeds. Off late I am noticing my car drifting to right slightly. Not sure if the cause of it is the sw update or incorrect adjustments during the update process. I will watch for few more days and then approach service advisor.
April1 is offline   United_States
0
Reply With Quote
      06-09-2012, 04:01 PM   #114
paul386
Second Lieutenant
 
Drives: 2011 X3 35i Jet Black
Join Date: Oct 2009
Location: Florida

Posts: 274
iTrader: (0)

Quote:
Originally Posted by Nahoa View Post
Mine's in for rear brakes and this software update. Took a long time to convince them of the software update and still not sure they're going to do it.

Had an appointment for Tuesday with a loaner. Arrived and they said, "no loaner". So, what did they expect me to do to get to work that day after planning with the expectation of a loaner? They explained that the appointment was really just an appointment to sit and talk to the SA about the car's problem and not to leave the car -- what?? Since when? Now they've had the car three days and have called each day to report they've been a little backed up (and no, I didn't recommend fiber) so they haven't even started working on the car yet. Why make an appointment for a repair if you're so behind you can't do the repair? That sounds like you don't really have an appointment available; schedule me in when you can actually do the work!

Anyway, I've never been bothered by the "take off lag" issue. I have experienced the start-up oscillation, but only over the last few months. Not sure what changed. I did experience the "bottoming out" on deceleration and transition to acceleration where the response is flat, forcing you to keep pressing to try to get it going and then it finally launches. So, curious to see what it's like if they actually do the software install.
I also had a tough time getting my dealer to do the software update... BMW Austin.
paul386 is offline  
0
Reply With Quote
      06-12-2012, 08:38 PM   #115
Nahoa
Lieutenant Colonel
 
Drives: F25 35i Mineral Silver/Black
Join Date: May 2008
Location: Virginia

Posts: 1,876
iTrader: (0)

They did mine. Not sure I consider it an improvement. I'm sure I'll adjust.

In terms of small changes, the mpg display added a yellow/orange highlight on the bar that used to be solid red. Light blue highlight on the final stage that used to be solid blue.
__________________

Last edited by Nahoa; 06-12-2012 at 08:53 PM.
Nahoa is offline   United_States
0
Reply With Quote
      06-19-2012, 12:41 AM   #116
Theodoros
Enlisted Member
 
Drives: Bmw x3 f25
Join Date: Dec 2011
Location: Switzerland

Posts: 33
iTrader: (0)

What about europe?

Hallo,
Few weeks ago I got delivery of me x3 2012 model and I immediately noticed this hesitation in acceleration.not really complaining but it would be good to do away with it.anyone knows if/when it will come to europe?
Theodoros is offline  
0
Reply With Quote
      06-19-2012, 02:35 AM   #117
yoye
New Member
 
Drives: bmw 325i E-90
Join Date: Sep 2006
Location: Spain - Valencia

Posts: 7
iTrader: (0)

Quote:
Originally Posted by Theodoros View Post
Hallo,
Few weeks ago I got delivery of me x3 2012 model and I immediately noticed this hesitation in acceleration.not really complaining but it would be good to do away with it.anyone knows if/when it will come to europe?
I had the same issue in acceleration and my dealer did the software upgrade. No changes on the the car, I was very disappointed but nothing to do in Europe, itīs like only works on US.....
yoye is offline   Spain
0
Reply With Quote
      06-19-2012, 08:52 AM   #118
lbjgh
Major
 
lbjgh's Avatar
 
Drives: 2013 AW X3 M-Sport
Join Date: Dec 2011
Location: North of Toronto

Posts: 1,428
iTrader: (0)

I have a 2013 model and there is no hesitation at all.

There is a software fix for the throttle delay... it just may be difficult to get it implemented in other markets. (I'm in Canada)
__________________
2013, AW, xDrive35i, M Sport Package, Technology Package, Dynamic Comfort Package, Premium Package, 3M Clear Bra, Euro foglight switch, a few coded fixes
lbjgh is offline   Canada
0
Reply With Quote
      06-20-2012, 09:16 AM   #119
Harplayr
Lieutenant
 
Drives: 2011 BMW X3 28i, F25
Join Date: Apr 2011
Location: Chicago

Posts: 424
iTrader: (0)

I had it done last week and notice a real improvement.

Two strange things though:
1) I don't have a sports package, but now under settings I have sports mode with options for adjusting the drive train and chasis. I notice no difference in handling in sport mode, but the gear ratios do change putting me at a higher rpm. Should sports mode chasis control do anything on a car without any of the sports options?

2) Before getting this, I could scroll through my preset radio AM/FM/Serius stations via the steering wheel thumb scroll. Now I each time I start the car I have to switch Idrive to prests to get this feature. Otherwise it just scrolls through every station in the band I'm currently in.
Harplayr is offline  
0
Reply With Quote
      06-20-2012, 09:18 AM   #120
Chalky White
Private First Class
 
Drives: 2006 e90, 325i
Join Date: Dec 2005
Location: atlanta

Posts: 131
iTrader: (0)

Garage List
2006 325i  [0.00]
Quote:
Originally Posted by Harplayr View Post
I had it done last week and notice a real improvement.

Two strange things though:
1) I don't have a sports package, but now under settings I have sports mode with options for adjusting the drive train and chasis. I notice no difference in handling in sport mode, but the gear ratios do change putting me at a higher rpm. Should sports mode chasis control do anything on a car without any of the sports options?

2) Before getting this, I could scroll through my preset radio AM/FM/Serius stations via the steering wheel thumb scroll. Now I each time I start the car I have to switch Idrive to prests to get this feature. Otherwise it just scrolls through every station in the band I'm currently in.
Mine did the same for #2, but after a few weeks, went back to presets-only.
__________________
12/5/13 PCD Delivery of X3 3.5i, Alpine, Chestnut, Premium, Tech, Heated Seats, BMW Apps

2006 325i, Sparkling, Grey, Xenons, Premium, Heated, Comfort (SOLD)
Chalky White is offline  
0
Reply With Quote
      06-20-2012, 09:26 AM   #121
Harplayr
Lieutenant
 
Drives: 2011 BMW X3 28i, F25
Join Date: Apr 2011
Location: Chicago

Posts: 424
iTrader: (0)

Quote:
Originally Posted by Chalky White View Post
Mine did the same for #2, but after a few weeks, went back to presets-only.
That's strange. I'll wait and see if mine also reverts to the way it was.
Harplayr is offline  
0
Reply With Quote
      06-20-2012, 10:43 AM   #122
blorrior
Registered
 
Drives: 2012 X3 35i
Join Date: Nov 2009
Location: New Jersey

Posts: 3
iTrader: (0)

I have a 2012 X3 35i that was Feb 2012 built. I'm not feeling the throttle delay or the steering pull..Not sure if those software fixes were already built into the Feb 2012 models. I picked this off the dealer lot last month and didnt use the build option.
blorrior is offline  
0
Reply With Quote
      06-20-2012, 11:54 AM   #123
April1
Love All
 
April1's Avatar
 
Drives: X3 28i 2011
Join Date: Nov 2011
Location: San Francisco

Posts: 738
iTrader: (1)

Send a message via Yahoo to April1
Quote:
Originally Posted by blorrior View Post
I have a 2012 X3 35i that was Feb 2012 built. I'm not feeling the throttle delay or the steering pull..Not sure if those software fixes were already built into the Feb 2012 models. I picked this off the dealer lot last month and didnt use the build option.
Test drive a 2013 X3 and compare the differences and decide accordingly.
April1 is offline   United_States
0
Reply With Quote
      06-21-2012, 07:13 PM   #124
blorrior
Registered
 
Drives: 2012 X3 35i
Join Date: Nov 2009
Location: New Jersey

Posts: 3
iTrader: (0)

Quote:
Originally Posted by April1 View Post
Test drive a 2013 X3 and compare the differences and decide accordingly.
I did try the 2013 X3 yesterday, but a 28i that the service center had since they didnt have a 35i on the lot.
Feels like the power comes on earlier on the 2013 28i than my 2012 35i, but eventually the 35i definitely feels more powerful in about 2 seconds.
I did mention about the software upgrade, they checked and told me that my car has a higher version than the SI B24 02 12 one and that they would anyways check and let me know.
Also that my car is too new, not done with the break-in/adaptive transmission will take time to adjust to my driving patterns etc etc. Got my car back today and it definitely feels more responsive.
Secret tuneup sauce or its purely psychological!
blorrior is offline  
0
Reply With Quote
      06-21-2012, 07:32 PM   #125
April1
Love All
 
April1's Avatar
 
Drives: X3 28i 2011
Join Date: Nov 2011
Location: San Francisco

Posts: 738
iTrader: (1)

Send a message via Yahoo to April1
Quote:
Originally Posted by blorrior View Post
I did try the 2013 X3 yesterday, but a 28i that the service center had since they didnt have a 35i on the lot.
Feels like the power comes on earlier on the 2013 28i than my 2012 35i, but eventually the 35i definitely feels more powerful in about 2 seconds.
I did mention about the software upgrade, they checked and told me that my car has a higher version than the SI B24 02 12 one and that they would anyways check and let me know.
Also that my car is too new, not done with the break-in/adaptive transmission will take time to adjust to my driving patterns etc etc. Got my car back today and it definitely feels more responsive.
Secret tuneup sauce or its purely psychological!
Yes first two seconds are where you feel the lag if the software update has not been done and you yourself noticed the difference. I am certain if the X3 was manufactutred on or before Feb 2012, It will not have the latest software.
April1 is offline   United_States
0
Reply With Quote
      06-22-2012, 05:20 PM   #126
jdg857
Enlisted Member
 
jdg857's Avatar
 
Drives: 2011 X3 XDrive 28i
Join Date: Jun 2012
Location: Santa Fe, NM

Posts: 33
iTrader: (0)

Nice!

I just got my X3 back after update.. a very noticeable improvement.

Invoice says:
Check and advise
Unfavorable EGS and DME calibration.
Verified customer concern found vehicle to have delay when accelerating after slowing and from stop. Found SIB 24 02 12
Programmed and encoded complete vehicle including CAS.
Cleared adaptations and test drove.
Defect code 10 42 03 71 00
Labor OP 00 00 006.
61 21 528. 61 00 730.
jdg857 is offline  
0
Reply With Quote
      06-29-2012, 06:46 AM   #127
DouginNC
Enlisted Member
 
DouginNC's Avatar
 
Drives: 2008 128i Convertible, 2011 X3
Join Date: Nov 2010
Location: Huntersville, NC

Posts: 37
iTrader: (0)

I had the update performed on my 2011 2.8 and noticed a couple of changes:


Now instead of the transmission shifting from 1st 2nd and 3rd within just a few feet, the transmission lets the RPMs come up in 1st, then 2nd and then 3rd. The way my transmission was running through the gears seems to have been causing the delay in my X3. Big improvement. It's more like the old Sport mode, but not quite as long of shift intervals.


The steering now is heavier and more center weighted. I like the change. The steering is still no where as heavy as my 128, but at least there is a more connected feeling to the road now. Definitely is center weighted, as the wheel really wants to be at center after making a turn. Acts more like they performed a wheel alignment, but they didn't.

Some of my user settings were erased and others were not. All of my radio presets were gone, yet bluetooth was still set up to pare with my iPhone.

The update to my X3 took 3 hours. I waited while it was done. The dealer found the TSB after I complained about throttle response.

Glad I had it done.

Doug in NC
DouginNC is offline   United_States
0
Reply With Quote
      07-05-2012, 11:39 AM   #128
75bullish
New Member
 
Drives: BMW X3
Join Date: May 2011
Location: Vancouver, Canada

Posts: 27
iTrader: (0)

I dropped off my car for this software update and a window regulator fix on Tuesday morning. Wasn't able to get hold of the service rep all afternoon and had to finally call my sales agent to check the status for me. The agent told me to keep driving the loaner and they will call me on Wednesday.

The service rep called me on Wednesday lunch time and told me the car is ready. So I went to the dealer and pick up my car after lunch. The service rep explained that when they did the software update, it failed and they had to redo it again. That's why it took them more than a day to finish the job. Fine, as long as it works. Just when I was all set to go home and experiment the effects of the upgrade, I noticed that the language on the iDrive screen is some language I don't understand. So I took the manual out and tried to switch it back to English. When I was in the language option screen, I have German, English (UK) and Spanish as options. I was able to switch the language to Spainish but I am not able to choose English at all. In fact, after switching to Spanish, I am not able to switch it back to German. I went back to the service rep and told him I am not able to change the language. He thought I am dumb and offered to show me how to change it. Now even he's not able to make the switch and he would need to have the technicians take a look. Apparently nobody was available and they needed to keep my car for another day and I had to drive the same loaner back home.

I hope I will get a call from them and I can get my car back today. Fingers crossed.

Last edited by 75bullish; 07-05-2012 at 11:40 AM. Reason: got the days wrong
75bullish is offline   Canada
0
Reply With Quote
      07-05-2012, 03:37 PM   #129
Radioactive
Captain
 
Drives: '11 X3 28i '10 535i '04 325i
Join Date: Mar 2011
Location: San Diego

Posts: 648
iTrader: (0)

Quote:
Originally Posted by 75bullish View Post
I dropped off my car for this software update and a window regulator fix on Tuesday morning. Wasn't able to get hold of the service rep all afternoon and had to finally call my sales agent to check the status for me. The agent told me to keep driving the loaner and they will call me on Wednesday.

The service rep called me on Wednesday lunch time and told me the car is ready. So I went to the dealer and pick up my car after lunch. The service rep explained that when they did the software update, it failed and they had to redo it again. That's why it took them more than a day to finish the job. Fine, as long as it works. Just when I was all set to go home and experiment the effects of the upgrade, I noticed that the language on the iDrive screen is some language I don't understand. So I took the manual out and tried to switch it back to English. When I was in the language option screen, I have German, English (UK) and Spanish as options. I was able to switch the language to Spainish but I am not able to choose English at all. In fact, after switching to Spanish, I am not able to switch it back to German. I went back to the service rep and told him I am not able to change the language. He thought I am dumb and offered to show me how to change it. Now even he's not able to make the switch and he would need to have the technicians take a look. Apparently nobody was available and they needed to keep my car for another day and I had to drive the same loaner back home.

I hope I will get a call from them and I can get my car back today. Fingers crossed.
Lo siento, aqui en los Estados Unidos, espanol es el nuevo ingles.

Kinda reminds me of Buzz Lightyear in Toy Story 3. Keep your wife or GF away from it and smashing Buzz with TV brought back "English".

Good Luck
Radioactive is offline   United_States
0
Reply With Quote
      07-09-2012, 12:02 PM   #130
Hornet_Rider
Enlisted Member
 
Drives: X3 35i 2011 M-Sport
Join Date: Jul 2011
Location: Saguenay, QC

Posts: 32
iTrader: (0)

Got the update and it works great, but now language settings and others don`t hold. I need to change it everytime I start the car...
Hornet_Rider is offline   Canada
0
Reply With Quote
      07-09-2012, 05:06 PM   #131
cer2225
Enlisted Member
 
Drives: 2011 X3
Join Date: Apr 2011
Location: NY

Posts: 33
iTrader: (0)

Find current software version...

Is there any way yo find out what version of the software we currently have?

I took mine in to have the sunroof fixed and complained about this issue. I even gave them the SIB number but they came back and said that I already had the highest software. The thing is the last time I took the car in was February and yes they did do an update at that time but I highly doubt I am on the latest one let alone the one that has the fix as I still had the lag.

They did reset the learning but since that is a really dumb system I think I will be back to complain again in 2 weeks.

And I did check and do not have the few noticed changes mentioned abouve by others.

Thanks

-CR
cer2225 is offline  
0
Reply With Quote
      07-09-2012, 09:40 PM   #132
cer2225
Enlisted Member
 
Drives: 2011 X3
Join Date: Apr 2011
Location: NY

Posts: 33
iTrader: (0)

Found wrong update...

Okay, So I was able to figure out that we can read the software revision by exporting a profile to a USB stick and opening it up in Notepad.

When I exported it I get the following <i-step>F001-11-09-501</i-step>

When I cross reference that with it comes back as 2.43 and actually for an 7 series.

Man I hate some dealers....

Can someone that has the latest build do the same and tell me what you see?

Thanks
-CR
cer2225 is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:59 AM.




xbimmers
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST