View Single Post
      11-23-2012, 11:05 PM   #4
gareth12468
First Lieutenant
Canada
4

 
Drives: 2011 X3 xDrive 28i
Join Date: Mar 2011
Location: Toronto


Posts: 308
iTrader: (0)

Garage List
2011 BMW X3  [0.00]
Quote:
Originally Posted by X Three View Post
About the "xDrive and DSC Malfunction" issue - I am currently trying to get my X3 fixed for a transmission malfunction.

As I was driving (20-30 mph) the car appeared to disengage the transmission then there were a couple of sharp jolts, almost like the transmission shifted abruptly. It was very noticeable and the car was very unresponsive. I immediately pulled the car off the road. During that time the error message "Transmission malfunction" was displayed, following that message another message appeared "DSC and xDrive Malfunction". I turned the car off and then restarted, and it appeared to be functioning/driving/shifting normally. This was the second time this issue occured, the first, however, I did not get any error messages and only the sharp jolts from the transmission and I did not need to restart the car.

I would recommend taking your car in to get checked, I ignored it the first time, thinking it was nothing serious. I took it in to get diagnosed, and your error message may be a different issue, but it appears that if you get any of these messages the car is going into a "safe mode" for some reason. In my case there seems to some kind of transmission fluid temperature sensor issue, I still have to bring it back, and will update here when I get the final fix, if any. . .
My 28i has the same issue as yours 5 times. The dealership and BMW Canada finally have to replaced the mechatronic unit and reprogram my car.

Here're the errors I have.....
http://x3.xbimmers.com/forums/showpo...&postcount=197